Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275101 - gnome application menu empty
Summary: gnome application menu empty
Status: RESOLVED DUPLICATE of bug 256614
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-22 19:50 UTC by Jeremy Huddleston Sequoia
Modified: 2009-07-07 11:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Huddleston Sequoia 2009-06-22 19:50:47 UTC
My gnome application menu is empty.  I deleted ~/.gnome*, ~/.dbus*, and ~/.gconf* to start fresh, and it's still empty.

The sys prefs menus are still working.  When I try to edit the application menu, alacarte crashes (it looks like it assumes the menu is non-empty and crashes due to it being empty... see the attached log file):

I am using a mostly KEYWORDS="amd64" system with a few ~amd64 packages thrown in (nothing gnome is ~amd64).  I have:
gnome-base/gnome-menus-2.24.2

Portage 2.2_rc33 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-hardened-r9 x86_64)
=================================================================
System uname: Linux-2.6.28-hardened-r9-x86_64-AMD_Athlon-tm-_64_Processor_2800+-with-glibc2.2.5
Timestamp of tree: Mon, 22 Jun 2009 06:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=k8"
DISTDIR="/var/tmp/gentoo/distfiles"
FEATURES="bindeps candy collision-protect distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv userpriv_fakeroot usersandbox verify-rdepend"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://gentoo.mirrors.pair.com/"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/var/tmp/gentoo/packages-amd64"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync15.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3ds S3TC X X509 Xaw3d a52 aac aalib acl acpi activefilter adplug aim alsa amd amd64 amr ao apache2 artworkextra atlas audiofile avahi avantgo bash-completion bcmath berkdb bidi browserplugin bzip2 bzlib c++ cairo calendar caps cdda cddb cdio cdparanoia cdr cgi chroot clamav clamd clamdtop clanJavaScript clanVoice clearpasswd cli client clisp cracklib crypt cscope css cups curl curlwrappers cvs cvsgraph dbase dbcp dbm dbus dbx dedicated dga dio divx4linux dlloader dmx dnd dri dts dv dvd dvdr dvdread edl eds emacs emacs-w3 enca encode enscript erandom esd ethereal evms2 evo exif exiv2 expat ext-png ext-zlib extensions f77 faac faad fam fame fat fax fbcon fbdev ffmpeg fftw filter firefox flac flash flatfile fltk fluidsynth font-server foomaticdb fortran fpx freetts freetype fs gb gcj gcl gd gd-external gdbm gif gimp gimpprint glade glep glib glibc-omitfp glitz glut gmp gmtfull gmthigh gmtsuppl gmttria gnome gnomedb gnuplot gnutls gocr gpm gps graphviz gs gstreamer gtk gtkhtml hal hash hbci hdri highlight howl howl-compat iconv icq idea idl idn ieee1394 image imagemagick imap imlib imlib2 inifile innodb ipalias iproute2 ipsec ipv6 isdnlog ithreads jabber jack java javacomm javamail javascript jbig jikes joystick jpeg jpeg2k junit justify kde ladcca latex lcms ldap libcaca libclamav libdsk libedit libg++ libgda libsamplerate libwww lids live lm_sensors lmtp log4j logitech-mouse ltsp lua lucid lzo mad maildir makecheck matroska mbrola mcal md5sum mdnsresponder-compat mhash midi mikmod mime ming mixer mjpeg mmx mmxext mng mod_python mozcalendar mozctl mozdevelop mozilla mozp3p mozsvg mozxmlterm mp2 mp3 mpeg mpeg4 mplayer mpm-prefork msession msn mtp mudflap mule multilib multislot musepack music mysql mysqli mythtv nas native ncurses neXt network nis nls nptl nptlonly nsplugin nviz oav objc objc++ objc-gc ocaml ocrad odbc offensive ofx ogg oggvorbis oldworld openal opendoc openexr opengl openmp openssl opensslcrypt opera oscar oss pam parse-clocks pcap pch pcntl pcre pda pdf perl php physfs pic pie plotutils png pnm pnp portaudio povray ppds pppd prelude procmail pulseaudio python q32 qhull qt qt3 qt3support qt4 quicktime rar readline recode reflection regexp rplay rtc samba sasl savedconfig sdk sdl sdl-image server session sharedmem sid silc slp sms sndfile soap socks5 sox speex spell spl sql sqlite sqlite3 src srt sse sse2 ssl subversion suexec svg sysfs sysvipc t1lib tcltk tcpd tesseract tetex tex tga theora tidy tiff timidity transcode transparent-proxy truetype trusted tta type1 ucs2 unicode urandom usb user-homedirs userlocales v4l v4l2 vcd vda vhosts videos vim-with-x virus-scan visualization vlm vnc vorbis wav wavpack wddx webkit wma wmf wsconvert wxwin wxwindows x264 xanim xchattext xcomposite xemacs xface xforms xfs xine xinerama xml xml2 xmlreader xmlrpc xmlwriter xorg xosd xpm xsl xulrunner xv xvid xvmc yahoo zeo zeroconf zip zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="wacom joystick keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Here is my stdout/err output from running 'startx >& x.log', clicking on the applications menu, and trying to edit the menu (note the alacarte crash)

xauth:  creating new authority file /home/cloud/jeremy/.serverauth.13227

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.28-hardened-r7 x86_64 
Current Operating System: Linux cloud.cs.berkeley.edu 2.6.28-hardened-r9 #1 Sat Jun 20 16:09:41 PDT 2009 x86_64
Build Date: 20 June 2009  09:23:49AM
 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun 22 12:37:10 2009
(==) Using config file: "/etc/X11/xorg.conf"

SESSION_MANAGER=local/cloud.cs.berkeley.edu:/tmp/.ICE-unix/13253
Window manager warning: Failed to read saved session file /home/cloud/jeremy/.config/metacity/sessions/default0.ms: Failed to open file '/home/cloud/jeremy/.config/metacity/sessions/default0.ms': No such file or directory
Connection failure: Connection refused
Failed to play sound: Sound disabled

(gnome-panel:13295): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -9 and height 24

** (nautilus:13297): WARNING **: Unable to add monitor: Not supported
22/06/2009 12:37:16 PM Autoprobing TCP port 
22/06/2009 12:37:16 PM Autoprobing selected port 5900
22/06/2009 12:37:16 PM Advertising security type: 'TLS' (18)
22/06/2009 12:37:16 PM Advertising authentication type: 'No Authentication' (1)
22/06/2009 12:37:16 PM Advertising security type: 'No Authentication' (1)
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 36, in <module>
    main()
  File "/usr/bin/alacarte", line 32, in main
    app = MainWindow(datadir, version, sys.argv)
  File "//usr/lib64/python2.5/site-packages/Alacarte/MainWindow.py", line 50, in __init__
    self.editor = MenuEditor()
  File "//usr/lib64/python2.5/site-packages/Alacarte/MenuEditor.py", line 36, in __init__
    self.__loadMenus()
  File "//usr/lib64/python2.5/site-packages/Alacarte/MenuEditor.py", line 42, in __loadMenus
    self.applications.path = os.path.join(util.getUserMenuPath(), self.applications.tree.get_menu_file())
  File "/usr/lib64/python2.5/posixpath.py", line 60, in join
    if b.startswith('/'):
AttributeError: 'NoneType' object has no attribute 'startswith'
** Message: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name

** (gnome-panel:13295): WARNING **: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!

waiting for X server to shut down
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-06-28 21:36:30 UTC
Could this be the return of bug #256614 ? Try rebuilding gnome-menus.
Comment 2 Jeremy Huddleston Sequoia 2009-07-07 02:52:56 UTC
Rebuilding gnome-menus does now fix the problem
Comment 3 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-07-07 11:02:05 UTC
Thanks for the follow-up

*** This bug has been marked as a duplicate of bug 270350 ***
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-07-07 11:02:57 UTC
Oops, copy-paste fail
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-07-07 11:03:28 UTC

*** This bug has been marked as a duplicate of bug 256614 ***