Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274925 - x11-apps/xfs is missing dev-tex/xmltex in it's dependencies.
Summary: x11-apps/xfs is missing dev-tex/xmltex in it's dependencies.
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 275019 275041 275425 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-21 10:11 UTC by Kfir Ozer
Modified: 2009-06-28 21:25 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log.gz,893 bytes, text/plain)
2009-06-21 22:46 UTC, Stelian Ionescu
Details
xfs-1.1.0.ebuild.patch (xfs-1.1.0.ebuild.patch,1021 bytes, patch)
2009-06-27 08:03 UTC, Christian Ruppert (idl0r)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kfir Ozer 2009-06-21 10:11:26 UTC
When i try to compile xfs-1.1.0 it gives me the following error: 

/usr/share/xmlto/format/docbook/../fo/pdf: line 17: pdfxmltex: command not found
make[1]: *** [doc/xfs-design.pdf] Error 1

i resolved the issue by emerging dev-tex/xml-tex.



Reproducible: Always

Steps to Reproduce:
1. emerge xfs (make sure xml-tex is not emerged)

Actual Results:  
/usr/share/xmlto/format/docbook/../fo/pdf: line 17: pdfxmltex: command not found
make[1]: *** [doc/xfs-design.pdf] Error 1

Expected Results:  
should be emerged properly.
Comment 1 Kfir Ozer 2009-06-21 10:41:37 UTC
actually.. after i emerged xmltex and i tried to re-emerge xfs i got the following error: 

***************************************************************************
abel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/usr/share/texmf-site/tex/xmltex/base/xmltex.cfg) 
No File: tmp.cfg

! LaTeX Error: File `fotex.xmt' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: xmt)

Enter file name: 
! Emergency stop.
<read *> 
         
l.2 ...shifts" writing-mode="lr-tb" language="en">
                                                  <fo:layout-master-set><fo:...

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on tmp.log.
make[1]: *** [doc/xfs-design.pdf] Error 1
make[1]: *** Waiting for unfinished jobs....
Writing ar01s11.html for sect1(handling_scalable_fonts)
Writing ar01s12.html for sect1(access_control)
Writing ar01s13.html for sect1(licensing)
Writing ar01s14.html for sect1(difs_contents)
Writing ar01s15.html for sect1(os_contents)
Writing ar01s16.html for sect1(utility_functions)
Writing ar01s17.html for sect1(server_request_details)
Writing ar01s18.html for sect1(configuration)
Writing ix01.html for index
Writing index.html for article(designms)
make[1]: Leaving directory `/var/tmp/portage/x11-apps/xfs-1.1.0/work/xfs-1.1.0'
make: *** [all] Error 2
*******************************************************************************

After I emerge app-text/passivetex xfs still won't emerge properly with the following error:
#########################################
This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
 %&-line parsing enabled.
entering extended mode
(./tmp.fo
LaTeX2e <2005/12/01>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/usr/share/texmf-site/tex/xmltex/base/xmltex.cfg) 
No File: tmp.cfg (/usr/share/texmf-site/tex/xmltex/passivetex/fotex.xmt)
(/usr/share/texmf-dist/tex/latex/base/article.cls
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
(/usr/share/texmf-dist/tex/latex/base/size10.clo))
(/usr/share/texmf-site/tex/xmltex/passivetex/fotex.sty
Writing ar01s12.html for sect1(access_control)
make[1]: *** [doc/xfs-design.pdf] Error 1
make[1]: *** Waiting for unfinished jobs....
Writing ar01s13.html for sect1(licensing)
Writing ar01s14.html for sect1(difs_contents)
Writing ar01s15.html for sect1(os_contents)
Writing ar01s16.html for sect1(utility_functions)
Writing ar01s17.html for sect1(server_request_details)
Writing ar01s18.html for sect1(configuration)
Writing ix01.html for index
Writing index.html for article(designms)
make[1]: Leaving directory `/var/tmp/portage/x11-apps/xfs-1.1.0/work/xfs-1.1.0'
make: *** [all] Error 2

#########################################


my emerge --info:
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.30-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 21 Jun 2009 08:30:01 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.4.4-r15, 2.5.4-r2, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.isoc.org.il/pub/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amavis amd64 amr animgif ao apache2 avahi bash-completion beagle beanshell berkdb bidi bittorrent bluetooth bsf bzip2 cairo cdaudio cdda cddb cdio cdr chm cjk cleartype cli consolekit cracklib crypt cups curl daap dbus device-mapper directfb divx dri dssi dvd dvdr dvdread emerald encode esd evo exif expat fam fasttrack fat fax fbcon ffmpeg firefox flac fontconfig fortran freetds freetype ftp fuse fusion galago gconf gcrypt gd gdbm gdm gif gimp git glade glitz glut gmedia gmp gnome gnome-keyring gnomecanvas gnutella gnutls gphoto2 gpm graphviz grub gstreamer gtk gtkhtml guile hal icap-client iconv icu imagemagick imlib inotify ipod ipv6 isdnlog jack java java6 javascript jikes jpeg kerberos krb4 latex ldap libcaca libedit libffi libgda libnotify log4j logrotate lua lucene maildir mailwrapper midi mikmod mmx mng modperl mono mp3 mp3tunes mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql nautilus ncurses networkmanager nls normalize nptl nptlonly nsplugin ntfs offensive ogg ole opengl openmp pam pango pcre pdf perl php pidgin png portaudio ppds pppd prelude pulseaudio python qt3 qt4 quicktime readline realmedia reflection ruby samba sasl scanner sdl sdl-image session slang slp smp sndfile snmp sourceview spamassassin speex spell spl sqlite sse sse2 ssl startup-notification subversion svg swig sysfs t1lib tcl tcpd threads thunderbird tiff timidity tk truetype unicode upnp usb v4l v4l2 vala vcd vim-syntax vorbis webkit wmf wmp x264 xcb xcomposite xfce xft xinerama xml xorg xpat xpm xscreensaver xslt xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy_ftp proxy_balancer proxy_ajp proxy proxy_connect proxybalancer proxy_http" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" NETBEANS_MODULES="xml visualweb php apisupport harness ide java nb websvccommon  groovy gsf j2ee webcommon cnd dlight enterprise ergonomics identity mobility profiler ruby" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 John Covici 2009-06-21 19:06:34 UTC
I am getting the same error -- if you need my emerge --info I can send it.
Comment 3 Stelian Ionescu 2009-06-21 22:46:36 UTC
Created attachment 195403 [details]
Build log

I'm getting this error even with xmltex installed.
Comment 4 Stelian Ionescu 2009-06-21 22:47:18 UTC
Portage 2.2_rc33 (default/linux/x86/2008.0/developer, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-tuxonice-r3 i686)
=================================================================
System uname: Linux-2.6.29-tuxonice-r3-i686-Intel-R-_Pentium-R-_M_processor_1.73GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 21 Jun 2009 18:45:02 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -ggdb -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev /etc/udev/rules.d /lib/modules"
CXXFLAGS="-O2 -ggdb -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps n"
FEATURES="candy collision-protect cvs digest distlocks fixpackages multilib-strict parallel-fetch prelink preserve-libs protect-owned sandbox severe sfperms sign splitdebug strict stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="		http://mirror.switch.ch/ftp/mirror/gentoo 		http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo 		http://gentoo.osuosl.org"
INSTALL_MASK="/usr/lib/debug/*"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"
LINGUAS="en ja"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--human-readable --progress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/mm/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/layman/emacs /usr/local/overlays/layman/enlightenment /usr/local/overlays/layman/sunrise /usr/local/overlays/gnome /home/hechee/lisp/gentoo-lisp-overlay /usr/local/overlays/ste"
SYNC="rsync://rsync3.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi adns afs alsa apache2 automount bash-completion berkdb bluetooth bzip2 cairo caps cdparanoia cdr cjk cli cracklib crypt cups curl dbus dga djvu dri dts dv dvb dvd dvdr dvdread dvi eds emacs emboss encode evo exif expat fam fbcon ffmpeg fftw flac fortran ftp fuse gd gdbm gif gmp gnome gnome-keyring gphoto2 gpm gps graphviz gs gtk gtkhtml guile hal iconv idn ieee1394 imagemagick imap imlib ipv6 irc isdnlog javascript jpeg jpeg2k kdeenablefinal kdehiddenvisibility latex lcms libffi libnotify live mad mailwrapper midi mmap mmx mng mp3 mp4 mpeg mudflap mysql nautilus ncurses network networkmanager nfs nls nptl nptlonly nsplugin offensive ogg openexr opengl openmp paludis_hooks_eselect pam pcmcia pcre pdf perl pic png postgres ppds pppd pulseaudio python qdbm qt3support qt4 quicktime readline reflection ruby samba sasl scanner sdl session slang sndfile snmp socks5 speex spell spl sqlite sse sse2 ssl startup-notification svg sysfs syslog tetex theora threads tiff truetype udev unicode urandom usb v4l v4l2 vcd vhosts vim-syntax vorbis webkit win32codecs wmf x86 xft xine xml xorg xpm xulrunner xv xvid zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="asis proxy proxy_balancer proxy_connect proxy_http" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics ps2mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ja" LIRC_DEVICES="all" USERLAND="GNU" VIDEO_CARDS="radeon vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 5 teidakankan 2009-06-22 08:17:12 UTC
From the xfs-1.1.0 changelog: 

commit be599b68334d2dea71e12f478e3201d3087ddf56
Author: Alan Coopersmith <alan.coopersmith@sun.com>
Date:   Wed Jun 17 18:56:09 2009 -0700

    Add --disable-devel-docs flag to configure to skip xfs-design doc conversion
    
    Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>

I added this option to the ebuild as follows and it finished compiling/installing:

pkg_setup() {
	CONFIGURE_OPTIONS="$(use_enable ipv6) --libdir=/etc --disable-devel-docs"

I'm not using any texlive packages on my system.
Comment 6 Kfir Ozer 2009-06-22 10:56:06 UTC
thanks, now xfs emerged properly.
Comment 7 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-27 08:03:29 UTC
Created attachment 195854 [details, diff]
xfs-1.1.0.ebuild.patch

That doesn't fix the broken docs target but it allows to disable it at least.
Comment 8 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-27 08:48:54 UTC
*** Bug 275425 has been marked as a duplicate of this bug. ***
Comment 9 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-27 08:49:33 UTC
*** Bug 275041 has been marked as a duplicate of this bug. ***
Comment 10 David Klempner 2009-06-28 15:15:06 UTC
Not to come off as an ungrateful whining luser, but did *anyone* try building this before version bumping it?

I run ~x86. I'm completely, absolutely understanding when a package with 15 USE flags doesn't build with some random combination of them.

Is there *any* configuration and combination of USE flags in which this builds?

I already have xmltex installed. I ran into bug 275425, which doesn't seem to have anything to do with xmltex but was duped to here...
Comment 11 Rémi Cardona gentoo-dev 2009-06-28 17:41:57 UTC
*** Bug 275019 has been marked as a duplicate of this bug. ***
Comment 12 Rémi Cardona gentoo-dev 2009-06-28 18:04:13 UTC
(In reply to comment #10)
> Not to come off as an ungrateful whining luser

Nice try

> but did *anyone* try building this before version bumping it?

I did, actually, like for all package bumps. And especially for this one since it had quite a few changed compared to the previous release. Unfortunately, I had all the needed deps...

(In reply to comment #7)
> Created an attachment (id=195854) [edit]
> xfs-1.1.0.ebuild.patch
> 
> That doesn't fix the broken docs target but it allows to disable it at least.

I've applied your patch in 1.1.0-r1, if xfs still needs some more deps, we can always add them later.

Thanks