Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274400 - app-emulation/virtualbox-modules-2.2.4: compilation failed with gentoo-sources-2.6.30
Summary: app-emulation/virtualbox-modules-2.2.4: compilation failed with gentoo-source...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Markus Ullmann (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 277944
  Show dependency tree
 
Reported: 2009-06-16 19:31 UTC by Michael 'BreiteSeite' Kühn
Modified: 2009-09-13 00:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 'BreiteSeite' Kühn 2009-06-16 19:31:40 UTC
build.log:
http://pastebin.com/f831a5d8

---
emerge --info:

Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.30-gentoo x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 16 Jun 2009 16:45:01 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.5.4-r2, 2.6.2-r1
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -mfpmath=sse -mmmx -msse -msse2 -msse3 -mssse3 -mno-sse4 -mno-sse4a -mno-sse5 -mno-3dnow "
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -mfpmath=sse -mmmx -msse -msse2 -msse3 -mssse3 -mno-sse4 -mno-sse4a -mno-sse5 -mno-3dnow "
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/berkano /usr/local/portage/breiti"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acpi additions alsa amarok amd64 audacious automount bluetooth bzip2 cairo cdda cddb cdio cdr cli cracklib crypt cups dbus divx dmi dri dvd dvdr dvdread emerald encode exif fam fastcgi ffmpeg firefox firefox3 fortran fuse gdbm gif gnutls gpm gtk gzip hal hddtemp iconv ipod irmc isdnlog ithreads java java6 javascript jfs jpeg jpeg2k kde kde4 kdeprefix kvm laptop libnotify lm_sensors logitech-mouse mad midi mikmod mmx mmxext mp3 mp4 mpeg mpeg2 mplayer mudflap multilib musicbrainz ncurses njb nls nojoystick nptl nptlonly nvidia ogg ogg123 opengl openssl pam pcre pdf perl pidgin pmount png ppds python qt3 qt3support qt4 quicktime rar readline reflection samba screen sdl session sftp spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcpd themes threads threadsonly tiff truetype unicode usb vorbis wma wmp wxwindows x264 xcb xml xorg xulrunner xv xvmc zip zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Reproducible: Always

Steps to Reproduce:
1.emerge virtualbox-modules
Actual Results:  
http://pastebin.com/f831a5d8 - compilation cancel
Comment 1 BT 2009-06-18 00:22:50 UTC
I fixed this issue by setting COMPAT_NET_DEV_OPS=y in my kernel as described in bug #273817. The correct fix would have the ebuild check for this option before proceeding, so please leave this bug open until a dev has had a chance to look at it.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-21 18:44:02 UTC
This is a quote from our bugzilla's bug filing form:

You should never use URL to point to pastebins for error messages, logs, emerge --info output, screenshots or similar information.
Instead, these should always be attached to the bug.

The reason for this is that pastebin sites could be down or have the pasted content removed.
Comment 3 .:deadhead:. 2009-07-03 06:17:42 UTC
(In reply to comment #1)
> I fixed this issue by setting COMPAT_NET_DEV_OPS=y in my kernel as described in
> bug #273817. The correct fix would have the ebuild check for this option before
> proceeding, so please leave this bug open until a dev has had a chance to look
> at it.

Thank you for the solution, adding that option allowed the module to be built for me too.

I guess the check should consider even the kernel version, so :

if kernel_version >= 2.6.30 and kernel_version<2.6.31
   linux_chkconfig_present COMPAT_NET_DEV_OPS

then check


cheers


Comment 4 Alessio Cassibba (X-Drum) 2009-09-10 16:12:08 UTC
This bug should be closed since this release is 
not available in portage (see bug #260331).