Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274282 - sci-libs/mathgl: fails to build with glibc-2.10
Summary: sci-libs/mathgl: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Andrey Grozin
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-15 20:28 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-09 13:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (mathgl-1.8.1:20090615-175112.log,112.45 KB, text/plain)
2009-06-15 20:29 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 20:28:50 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 20:29:58 UTC
Created attachment 194832 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-09 13:35:34 UTC
fixed thanks