Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274275 - gnome-extra/nm-applet-0.7.1-r2 emerge fails while patching
Summary: gnome-extra/nm-applet-0.7.1-r2 emerge fails while patching
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-15 19:44 UTC by Flo Gravo
Modified: 2009-06-23 22:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
01_all_nm-applet-0.7.1-confchanges.patch-7927.out (01_all_nm-applet-0.7.1-confchanges.patch-7927.out,6.80 KB, text/plain)
2009-06-15 19:46 UTC, Flo Gravo
Details
emerge --info (emerge_info,5.96 KB, text/plain)
2009-06-15 20:25 UTC, Flo Gravo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Flo Gravo 2009-06-15 19:44:51 UTC
Emerging gnome-extra/nm-applet-0.7.1-r2 fails while patches are applied.

Reproducible: Always

Steps to Reproduce:
1. emerge --sync
2. emerge gnome-extra/nm-applet
Actual Results:  
>>> Emerging (1 of 1) gnome-extra/nm-applet-0.7.1-r2
 * network-manager-applet-0.7.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                      [ ok ]
 * nm-applet-0.7.1-gentoo-patches-1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                  [ ok ]
 * checking ebuild checksums ;-) ...                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                       [ ok ]
>>> Unpacking source...
>>> Unpacking network-manager-applet-0.7.1.tar.bz2 to /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/work
>>> Unpacking nm-applet-0.7.1-gentoo-patches-1.tar.bz2 to /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/work
 * Applying nm-applet-0.7.1-confchanges.patch ...                                                                             [ ok ]
>>> Source unpacked in /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/work
>>> Preparing source in /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/work/network-manager-applet-0.7.1 ...
 * Applying various patches (bugfixes/updates) ...
 *   01_all_nm-applet-0.7.1-confchanges.patch ...

 * Failed Patch: 01_all_nm-applet-0.7.1-confchanges.patch !
 *  ( /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/work/nm-applet-0.7.1-gentoo-patches-1/01_all_nm-applet-0.7.1-confchanges.patch )
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/temp/01_all_nm-applet-0.7.1-confchanges.patch-7927.out

 * 
 * ERROR: gnome-extra/nm-applet-0.7.1-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_prepare
 *             environment, line 3290:  Called epatch
 *             environment, line 1820:  Called die
 * The specific snippet of code:
 *                   die "Failed Patch: ${patchname}!";
 *  The die message:
 *   Failed Patch: 01_all_nm-applet-0.7.1-confchanges.patch!
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/temp/environment'.
 * 

>>> Failed to emerge gnome-extra/nm-applet-0.7.1-r2
Comment 1 Flo Gravo 2009-06-15 19:46:30 UTC
Created attachment 194820 [details]
01_all_nm-applet-0.7.1-confchanges.patch-7927.out

 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/gnome-extra/nm-applet-0.7.1-r2/temp/01_all_nm-applet-0.7.1-confchanges.patch-7927.out
Comment 2 Flo Gravo 2009-06-15 20:25:36 UTC
Created attachment 194829 [details]
emerge --info
Comment 3 Al 2009-06-20 16:47:31 UTC
(In reply to comment #2)
Same problem here however looking at the ebuild it tries to patch twice once in src_unpack and then in src_prepare.
So I removed the src_unpack one and redid the digest and it has compiled OK.



Comment 4 Flo Gravo 2009-06-21 13:53:00 UTC
(In reply to comment #3)
Confirmed!

Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-21 17:49:55 UTC
Re-sync your tree please. The package unpacks without any problems on my system...
Comment 6 Al 2009-06-23 20:58:40 UTC
I can confirm after --sync the ebuild has changed for the better.
Comment 7 Flo Gravo 2009-06-23 22:50:41 UTC
(In reply to comment #5)
> Re-sync your tree please. The package unpacks without any problems on my
> system...
> 

Works for me too.