Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274218 - x11-misc/gbdfed: fails to build with glibc-2.10
Summary: x11-misc/gbdfed: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Fonts Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-15 10:50 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 12:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (gbdfed-1.4:20090615-051819.log,13.17 KB, text/plain)
2009-06-15 10:54 UTC, Diego Elio Pettenò (RETIRED)
Details
Rename function getline to avoid redeclaration. (rename-getline.patch,1.01 KB, patch)
2009-07-18 17:01 UTC, Alexander Meinke
Details | Diff
Change ebuild to apply patch. (gbdfed-1.4.ebuild.patch,606 bytes, patch)
2009-07-18 17:04 UTC, Alexander Meinke
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 10:50:05 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 10:54:38 UTC
Created attachment 194771 [details]
Build log
Comment 2 Alexander Meinke 2009-07-18 17:01:55 UTC
Created attachment 198425 [details, diff]
Rename function getline to avoid redeclaration.

This patch rename the getline function in bdfgname.c because it is also declared in glibc-2.10.1.
Comment 3 Alexander Meinke 2009-07-18 17:04:24 UTC
Created attachment 198427 [details, diff]
Change ebuild to apply patch.
Comment 4 Samuli Suominen gentoo-dev 2009-08-08 12:55:45 UTC
+  08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> gbdfed-1.4.ebuild,
+  +files/gbdfed-1.4-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #274218, thanks to Alexander Meinke for
+  patch.