Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274214 - dev-db/sqlitebrowser: fails to build with glibc-2.10
Summary: dev-db/sqlitebrowser: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Timothy Redaelli (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-15 10:44 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-06 11:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (sqlitebrowser-1.3:20090615-012829.log,4.14 KB, text/plain)
2009-06-15 10:46 UTC, Diego Elio Pettenò (RETIRED)
Details
sqlitebrowser-1.3-getline.patch (sqlitebrowser-1.3-getline.patch,580 bytes, patch)
2009-06-18 07:19 UTC, Graham Whitted
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 10:44:27 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-15 10:46:21 UTC
Created attachment 194767 [details]
Build log
Comment 2 Graham Whitted 2009-06-18 07:19:00 UTC
Created attachment 195049 [details, diff]
sqlitebrowser-1.3-getline.patch

I ran into this as well. It almost looks like a partially applied patch as the sqlbrowser_util.h has a function declaration for 'char *sqlbrowser_getline(FILE *in)' but sqlbrowser_util.c defines 'char *getline(FILE *in)' which conflicts with the definition from stdio.h. Anyway attached is a pretty straightforward patch that updates sqlbrowser_util.c to define anduse sqlbrowser_getline() instead of conflicting getline().
Comment 3 Samuli Suominen gentoo-dev 2009-08-06 11:25:25 UTC
fixed thanks