Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274184 - No support for psb drivers (Intel GMA 500)
Summary: No support for psb drivers (Intel GMA 500)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-15 02:22 UTC by Julien TIERNY
Modified: 2011-02-23 20:08 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
poulsbo firmware (psb-firmware-0.30_p3.ebuild,581 bytes, text/plain)
2009-09-04 22:48 UTC, Konrad Campowsky
Details
psb kernel modules (psb-kmod-4.41.1_p8.ebuild,2.26 KB, text/plain)
2009-09-04 22:49 UTC, Konrad Campowsky
Details
poulsbo version of libdrm (libdrm-poulsbo-2.3.0_p9.ebuild,1021 bytes, text/plain)
2009-09-04 22:49 UTC, Konrad Campowsky
Details
poulsbo glx (xpsb-glx-0.18_p4.ebuild,771 bytes, text/plain)
2009-09-04 22:50 UTC, Konrad Campowsky
Details
poulsbo xorg driver (xf86-video-psb-0.31.0_p11.ebuild,1.07 KB, text/plain)
2009-09-04 22:50 UTC, Konrad Campowsky
Details
Failing error log with gcc-4.5.2, amd64 and gentoo-sources-2.6.37 (log_02.log,55.00 KB, text/plain)
2011-02-02 16:08 UTC, Sven Eden
Details
Now the right error log. Damn old mouse! (log_02.log,55.00 KB, text/plain)
2011-02-02 16:09 UTC, Sven Eden
Details
Okay, last try with this damn broken USB-stick (psb-kmod2.log,34.11 KB, text/plain)
2011-02-02 16:11 UTC, Sven Eden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien TIERNY 2009-06-15 02:22:19 UTC
Hi there,
I've just bought a new dell mini 12 and I can't get to make Xorg work with a descent resolution and accelerated graphics.
After a few research online, it seems the PSB drivers are needed, both DRM and Xorg drivers.

Could you guys work on xf86-video-psb and psb-kmd ebuilds? please....
it seems sources and firmwares can be found here:
- http://v1.moblin.org/build-results/projects/psb-kmd/lpia/
- http://v1.moblin.org/build-results/projects/xf86-video-psb/lpia/

thanks for your reactivity
julien



Reproducible: Always
Comment 1 Julien TIERNY 2009-06-16 15:30:41 UTC
hi,
it seems more up-to-date material can be found here:

https://edge.launchpad.net/~ubuntu-mobile/+archive/ppa/+index?field.name_filter=psb&field.status_filter=published&field.series_filter=any

it seems only ubuntu developpers (Ubuntu Mobile Team) are active on this piece of code now.
actually, the laptop was shipped with Ubuntu and working 3D graphics.

this might be the best starting point.
julien
Comment 2 Julien TIERNY 2009-06-29 01:11:46 UTC
Hi there,
I don't want to be pushy here but I would appreciate if this bug report could get a higher priority.
After some chats on the forums, it turns out I'm far from being the only gentoo user with this laptop.
 
such a notebook without even 2D acceleration is close to useless.
this bug is actually blocking!

distros like Ubuntu, Fedora and Mandriva already support this driver-set...

please don't get offended by that post. I just want to use my favorite distro on my laptop :)

good luck,
julien
Comment 3 Rémi Cardona gentoo-dev 2009-07-09 10:08:46 UTC
I'd be willing to proxy-maintain this, but since I don't have the hardware (nor am I willing to buy a GMA500 laptop, not in its current state), you'll have to come up with ebuilds.

I will help you get them in shape, but this has to come from you interested folks.

Thanks
Comment 4 Rémi Cardona gentoo-dev 2009-07-09 10:17:00 UTC
Let's contact sunrise folks too.

Thanks
Comment 5 Julien TIERNY 2009-07-09 14:17:58 UTC
if some of you guys write some functional ebuilds, I will test them right away and give feed back. 
also, I would advertise it with the people I found on the forums having the same graphic chipset.

with the few tests I made on the sources, I can tell this would be no ordinary ebuild and that the x11 guys would be the best people to make it happen.
Comment 6 Rémi Cardona gentoo-dev 2009-07-09 14:41:51 UTC
(In reply to comment #5)
> if some of you guys write some functional ebuilds, I will test them right away
> and give feed back. 
> also, I would advertise it with the people I found on the forums having the
> same graphic chipset.

To be perfectly honest, I have no interest whatsoever in Poulsbo. For me it's just another binary driver, one that sucks. A lot.

The procedure here is to find a developer willing to write the ebuilds and maintain them (I doubt you'll find anyone) or you write the ebuilds and one of us (X devs) proxy-maintains for you. The latter option that means, you get to do most of the work and we just make sure your ebuilds are up to portage standards.

As for me, I can't write ebuilds for applications I can't test. I have enough work with the rest of X11 as it is. If you do not know how to write ebuilds, head over to http://devmanual.gentoo.org/ to start learning, it's not as hard as it seems. :)

Thanks
Comment 7 Julien TIERNY 2009-07-09 15:15:00 UTC
writing ebuilds in itself is not an issue.
for the psb drivers however, it seems libdrm needs to be patched with some specific psb-compatible features and I doubt you guys would be happy if just a nobody came to touch it.
the best I could so far was lobbying for its support. I have absolutely no free time to contribute.

> To be perfectly honest, I have no interest whatsoever in Poulsbo. For me it's
> just another binary driver, one that sucks. A lot.
I guess that's clear enough.
you have your opinion on that driver, good for you.
the problem still is that several notebooks have that chipset and it's more likely that even more of them will in the future.
Comment 8 Rémi Cardona gentoo-dev 2009-07-09 15:32:47 UTC
(In reply to comment #7)
> for the psb drivers however, it seems libdrm needs to be patched with some
> specific psb-compatible features and I doubt you guys would be happy if just a
> nobody came to touch it.

Indeed I wouldn't be happy, but you can post the patches here for review as well. We can then decide how to handle poulsbo-specific patches.

> the best I could so far was lobbying for its support. I have absolutely no
> free time to contribute.

Then ask for contributions on the forums. I'm sure another Poulsbo owner can write the ebuild. I'll gladly help writing those ebuilds, but this has to start from one of you guys, since you are the ones with the hardware.

> I guess that's clear enough.
> you have your opinion on that driver, good for you.
> the problem still is that several notebooks have that chipset and it's more
> likely that even more of them will in the future.

What I think about the poulsbo driver still doesn't change the fundamental issue. I am not going to write an ebuild for a driver I can't even test, nor will the X11 herd.

I did say earlier that I was willing to proxy-maintain the driver. Again, feel free to send me ebuilds and patches, I _will_ review them and commit them if anyone steps up for proxy-maintenance. Or it can even live in the x11 overlay until bugs are sorted out.

Thanks
Comment 9 Julien TIERNY 2009-07-09 15:39:52 UTC
thanks. I cannot promise anything but I'll try to find time to make things work out. if I come up with interesting stuff, I'll let you know. thanks again.
Comment 10 James Peel 2009-08-19 22:01:19 UTC
(In reply to comment #9)
> thanks. I cannot promise anything but I'll try to find time to make things work
> out. if I come up with interesting stuff, I'll let you know. thanks again.
> 

I have time for testing, quite happy to help out but im no dev, I'll try to get some more intrest into this - dev wrangling :-)
Comment 11 Konrad Campowsky 2009-09-04 22:46:22 UTC
I'm attaching a set of ebuilds that are a straightforward adaption of the work done by Adam Williamson [1].

This works perfectly for my Sony Vaio P11 giving me a native resolution for both framebuffer and X. (Sidenote: can anybody point me to a doc on how to get the gps module in this thing working?)
Anyway, yes: 3D with direct rendering is working, giving me a mindblowing 180-200fps on glxgears. From what I read, the driver also supports Xrandr and VAAPI, intels new API for video acceleration. A patched version of mplayer to use that can also be found at [1].

The packages are:

x11-drivers/psb-firmware - firmware for the chipset
x11-drivers/psb-kmod - kernel modules. see notes below
x11-libs/libdrm-poulsbo - hacked libdrm. to be installed alongside original one
x11-libs/xpsb-glx - needed for 3D accelaration
x11-drivers/xf86-video-psb - the actual xorg driver

simply emerge xf86-video-psb and it will pull in everything else.

some notes on the kernel modules: this driver needs its own version of the drm.ko module, meaning that CONFIG_DRM must be disabled in the kernel.
The actual driver is the psb.ko module which also implementes a framebuffer.
Two problems come with this: 
- the driver needs three kernel options that can not be directly selected but will be pulled in when needed by other drivers. These are CONFIG_{FILLRECT,COPYAREA,IMAGEBLIT}. To enable these options you can either hack the Kconfig file to make them visible or simply select a driver that pulls them in, for example VESAFB.
- When the psb.ko module is loaded it will immediately switch to framebuffer console. This will give you a seriously messed up screen if you either have no support for framebuffer console (CONFIG_FRAMEBUFFER_CONSOLE) or already have another framebuffer console running. If you dont want a framebuffer at all, load the module with no_fb=1 as parameter.
Apart from that, all seems fine. The module even gets automatically detected and loaded at boot.

You will then have to adjust your xorg.conf manually with "psb" as driver.

One more note: At least on my machine, X refuses to start with "cannot mmap framebuffer". This can be resolved by pretending to have less ram than you actually have. For me, mem=2039MB as kernel parameter works.

[1] http://www.happyassassin.net/2009/05/13/native-poulsbo-gma-500-graphics-driver-for-fedora-10/
Comment 12 Konrad Campowsky 2009-09-04 22:48:32 UTC
Created attachment 203152 [details]
poulsbo firmware
Comment 13 Konrad Campowsky 2009-09-04 22:49:06 UTC
Created attachment 203154 [details]
psb kernel modules
Comment 14 Konrad Campowsky 2009-09-04 22:49:37 UTC
Created attachment 203155 [details]
poulsbo version of libdrm
Comment 15 Konrad Campowsky 2009-09-04 22:50:02 UTC
Created attachment 203157 [details]
poulsbo glx
Comment 16 Konrad Campowsky 2009-09-04 22:50:39 UTC
Created attachment 203158 [details]
poulsbo xorg driver
Comment 17 James Peel 2009-09-05 07:21:27 UTC
Great work - i'll find some time today to test on my lil dell mini 10, be nice if one of the devs step forward and take this up as a maintainer seeing as all the hard work has been done.
Will test then bug devs to get this in tree, it is BugDay today anyhow :D

J
Comment 18 Rémi Cardona gentoo-dev 2009-09-05 08:10:51 UTC
(In reply to comment #13)
> Created an attachment (id=203154) [edit]
> psb kernel modules

Please wrap pkg_config() at 80 columns/chars.

(In reply to comment #16)
> Created an attachment (id=203158) [edit]
> poulsbo xorg driver

RDEPEND should have one atom per line.

Other than that, the ebuilds look fine. I do suggest these packages go through sunrise first.

Thanks
Comment 19 James Peel 2009-09-05 09:38:40 UTC
(In reply to comment #17)
> Great work - i'll find some time today to test on my lil dell mini 10, be nice
> if one of the devs step forward and take this up as a maintainer seeing as all
> the hard work has been done.
> Will test then bug devs to get this in tree, it is BugDay today anyhow :D
> 
> J
> 

I got lazy and dropped the ebuilds into my current local sunrise overlay - all came in fine and X worked right away after modprobing psb and changing Xorg.conf to use psb. 
Will test throughout the day.

J
Comment 20 James Peel 2009-09-12 14:37:53 UTC
Had no issues since install, maybe the ebuild could be tarted up a little to me best practices but all in all this driver is stable.

Someone to bump to tree?
Comment 21 Patrick Lauer gentoo-dev 2009-09-12 17:04:36 UTC
So...

Apart from the missing dependencies (xf86-video-* tends to depend on xorg-server and a few other bits :D ) the ebuilds are mostly working.

Big issue is libdrm-poulsbo, which tries to overwrite large parts of libdrm. If you avoid the collisions you get nice failures because xf86-video-psb gets "bad" files. This sucks a lot :) And it means that with default settings (FEATURES="collision-protect") it's currently uninstallable. If anyone finds a clean workaround for that ... patches welcome. Until then No Go.
Comment 22 Konrad Campowsky 2009-09-13 09:06:55 UTC
> Big issue is libdrm-poulsbo, which tries to overwrite large parts of libdrm. 

actually, libdrm-poulbo is meant to be installed completely into /usr/lib/psb and thus surely cannot overwrite any original libdrm stuff.
If this happens for you anyway, something is worng. Either with the ebuild or your system. At least for me, the situation is as follows:


#equery f libdrm-poulsbo
 * Searching for libdrm-poulsbo ...
 * Contents of x11-libs/libdrm-poulsbo-2.3.0_p9:
/etc
/etc/env.d
/etc/env.d/02psb
/usr
/usr/include
/usr/include/psb
/usr/include/psb/drm
/usr/include/psb/drm/drm.h
/usr/include/psb/drm/drm_sarea.h
/usr/include/psb/drm/i915_drm.h
/usr/include/psb/drm/mach64_drm.h
/usr/include/psb/drm/mga_drm.h
/usr/include/psb/drm/nouveau_drm.h
/usr/include/psb/drm/psb_drm.h
/usr/include/psb/drm/psb_drv.h
/usr/include/psb/drm/psb_reg.h
/usr/include/psb/drm/psb_schedule.h
/usr/include/psb/drm/r128_drm.h
/usr/include/psb/drm/r300_reg.h
/usr/include/psb/drm/radeon_drm.h
/usr/include/psb/drm/savage_drm.h
/usr/include/psb/drm/sis_drm.h
/usr/include/psb/drm/via_3d_reg.h
/usr/include/psb/drm/via_drm.h
/usr/include/psb/xf86drm.h
/usr/include/psb/xf86drmMode.h
/usr/include/psb/xf86mm.h
/usr/lib
/usr/lib/pkgconfig
/usr/lib/pkgconfig/libdrm-poulsbo.pc
/usr/lib/psb
/usr/lib/psb/libdrm.la
/usr/lib/psb/libdrm.so -> libdrm.so.2.3.0
/usr/lib/psb/libdrm.so.2 -> libdrm.so.2.3.0
/usr/lib/psb/libdrm.so.2.3.0
/usr/lib/psb/pkgconfig

This was done by the attached ebuilds and looks fine to me. Definitly no collisions here.
Comment 23 Patrick Lauer gentoo-dev 2009-09-13 20:14:14 UTC
Using commit message:
------------------------------------------------------------------------------
Initial import of the intel poulsbo graphics driver and support libs. Fixes #274184. Thanks to Konrad Campowsky for the ebuilds and all the people who tested them.
(Portage version: 2.2_rc40/cvs/Linux x86_64)                                                                                                                       
------------------------------------------------------------------------------ 

It took me some time to get the ebuilds into a mostly good shape. Still some rough corners, but for a first version that should be good enough.
The libdrm failure was a naughty autotools issue :)

Since I don't have the hardware I'll have to rely on your testing to find any issues. As far as I can tell the kernel module won't compile against 2.6.31 kernels ...

@x11 herd: I haven't added you to metadata. I would appreciate it if you'd add yourself to that package. 
Comment 24 Ray 2009-09-17 08:36:27 UTC
xf86-video-psb won't compile.

see my bug  report: 

http://bugs.gentoo.org/show_bug.cgi?id=285274
Comment 25 Ray 2009-09-17 09:23:49 UTC
xf86-video-psb won't compile.

see my bug  report: 

http://bugs.gentoo.org/show_bug.cgi?id=285274
Comment 26 mike 2009-09-17 09:32:48 UTC
(In reply to comment #23)
> Using commit message:
> ------------------------------------------------------------------------------
> Initial import of the intel poulsbo graphics driver and support libs. Fixes
> #274184. Thanks to Konrad Campowsky for the ebuilds and all the people who
> tested them.
> (Portage version: 2.2_rc40/cvs/Linux x86_64)                                    
> ------------------------------------------------------------------------------ 
> 
> It took me some time to get the ebuilds into a mostly good shape. Still some
> rough corners, but for a first version that should be good enough.
> The libdrm failure was a naughty autotools issue :)
> 
> Since I don't have the hardware I'll have to rely on your testing to find any
> issues. As far as I can tell the kernel module won't compile against 2.6.31
> kernels ...
> 
> @x11 herd: I haven't added you to metadata. I would appreciate it if you'd add
> yourself to that package. 
> 

Patrick,

I'm having the same problem when emerging libdrm-poulsbo, lots of package
collisions with libdrm.

How did you fix this issue? "A naughty autotools issue" is a bit vague to me :)

Either way, nice work everyone on this driver! I've been wanting this for quite
some time.
Comment 27 Patrick Lauer gentoo-dev 2009-09-17 10:23:01 UTC
> I'm having the same problem when emerging libdrm-poulsbo, lots of package
> collisions with libdrm.
> How did you fix this issue? "A naughty autotools issue" is a bit vague to me 

It was depending on automake-1.9 iirc, and I had only 1.10 and 1.11 installed (or something very similar. I don't have eidetic memory :) )
Adding WANT_AUTOMAKE="1.9" to the ebuild made the autotools eclass do The Right Thing. If it fails for you I presume the eautoreconf call isn't run. 

Best thing to do is file a new bug with the whole build log and emerge --info and any extra info you think is relevant (better than spamming this closed bug)
Comment 28 mike 2009-09-17 11:51:48 UTC
(In reply to comment #27)
> It was depending on automake-1.9 iirc, and I had only 1.10 and 1.11 installed
> (or something very similar. I don't have eidetic memory :) )
> Adding WANT_AUTOMAKE="1.9" to the ebuild made the autotools eclass do The Right
> Thing. If it fails for you I presume the eautoreconf call isn't run. 
> 
> Best thing to do is file a new bug with the whole build log and emerge --info
> and any extra info you think is relevant (better than spamming this closed bug)
> 

Adding that worked perfectly, thanks!

Will post the next problem in #285274
Comment 29 Sebastian Günther 2010-09-13 16:26:35 UTC
Since all the ebuilds are useless with new kernels and xorg-server, i pledge to reopen this bug, as gentoo clearly does not have support for this video-cards. I  did try to use the source from Ubuntu, but exept for the kernel module, everything else fails.
Comment 30 Rémi Cardona gentoo-dev 2010-09-15 20:46:20 UTC
(In reply to comment #29)
> Since all the ebuilds are useless with new kernels and xorg-server, i pledge to
> reopen this bug, as gentoo clearly does not have support for this video-cards.
> I  did try to use the source from Ubuntu, but exept for the kernel module,
> everything else fails.

Are there *any* new sources/drivers to support newer kernels and Xorg versions?

If not, there's nothing else to do.

Cheers
Comment 31 Sebastian Günther 2010-09-16 08:01:20 UTC
Since Ubuntu 10.04 uses xorg 1.7.6 these should be new Drivers:
https://wiki.ubuntu.com/HardwareSupportComponentsVideoCardsPoulsbo/
http://ppa.launchpad.net/gma500/

I did try to make ebuilds from the ppa tree. The Kernel-Module build fine with
kernel 2.6.34 and the framebuffer works but X fails.

I did not try the fix tree, since I wanted a working X and just did retrieve all 1.6.5 dependecies from the attic.

Maybe we could try this later on. I could upload my ebuild tries if this is wanted.
Comment 32 Lukas Elsner 2010-12-04 11:46:34 UTC
Hi,
I am working on getting the gma500 aka poulsbo card running onto my gentoo ~x86.
I created a layman overlay wich will be public the next days.
Codebase is the cutting edge code from ubuntu.

For now, it is not working. 
But i think we can handle soon. ;)

regards,
Lukas
Comment 33 Lukas Elsner 2010-12-06 22:31:30 UTC
Damn, it is working!!!

xserver 1.9 + psb (glxgears ~200fps)


There is one problem left with the -fvisibility CFLAG.
I cannot change it automatically, so we have to activate it manually for now.

Perhaps someone can help out with this.

overlay is coming soon.

shall i post my ebuilds here?


regards :)
Comment 34 Luca Barbato gentoo-dev 2010-12-07 12:11:17 UTC
Please do
Comment 35 Lukas Elsner 2010-12-08 16:08:11 UTC
(In reply to comment #34)
> Please do
> 

Of course i will do. But please be patient. Most of my time I am in University, and I want to fix some glitches in that ebuilds first, so that everyone can use it without getting too much trouble! ;)

Ill post here if my overlay is online.

Comment 36 Lukas Elsner 2010-12-08 23:12:21 UTC
The overlay is called "luman".

It should contain everything you need.
It is only tested with 2.6.36, 2.6.37 and newest xserver unter gentoo ~x86.

Maybe you can test with ~amd64 x86 and amd64 also.
Comment 37 peter john hartman 2010-12-14 01:51:06 UTC
We already had it working in x86 with 2.6.36: https://bugs.gentoo.org/274184 (and the associated one).  Curious if you want to try the EMGD option.  I'm about to engineer the SUSE version of 1.5 over to an ebuild, but at the moment there's too many steps.

(In reply to comment #36)
> The overlay is called "luman".
> 
> It should contain everything you need.
> It is only tested with 2.6.36, 2.6.37 and newest xserver unter gentoo ~x86.
> 
> Maybe you can test with ~amd64 x86 and amd64 also.
> 
Comment 38 Lukas Elsner 2010-12-14 10:36:40 UTC
I had some problems compiling it for xorg 1.9. I hat to change little things.
Maybe we can merge our work and try to get this one upstream into the official gentoo tree!

(In reply to comment #37)
> We already had it working in x86 with 2.6.36: https://bugs.gentoo.org/274184
> (and the associated one).  Curious if you want to try the EMGD option.  I'm
> about to engineer the SUSE version of 1.5 over to an ebuild, but at the moment
> there's too many steps.
> 
> (In reply to comment #36)
> > The overlay is called "luman".
> > 
> > It should contain everything you need.
> > It is only tested with 2.6.36, 2.6.37 and newest xserver unter gentoo ~x86.
> > 
> > Maybe you can test with ~amd64 x86 and amd64 also.
> > 
> 
Comment 39 Andrea Zampieri 2010-12-15 13:15:31 UTC
(In reply to comment #38)
> I had some problems compiling it for xorg 1.9. I hat to change little things.
> Maybe we can merge our work and try to get this one upstream into the official
> gentoo tree!
> 

with xorg 1.7.7-r1 and kernel 2.6.36-r5, using luman overlay, everything compile fine except xf86-video-psb. Has you got the same trouble in your tests?
Comment 40 Lukas Elsner 2010-12-15 16:54:07 UTC
(In reply to comment #39)
> (In reply to comment #38)
> > I had some problems compiling it for xorg 1.9. I hat to change little things.
> > Maybe we can merge our work and try to get this one upstream into the official
> > gentoo tree!
> > 
> 
> with xorg 1.7.7-r1 and kernel 2.6.36-r5, using luman overlay, everything
> compile fine except xf86-video-psb. Has you got the same trouble in your tests?
> 

Please post the build log
Comment 41 strites 2011-01-07 19:14:35 UTC
I got this problem:


# X

X.Org X Server 1.9.2
Release Date: 2010-10-30
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.34-gentoo-r6 i686 Gentoo
Current Operating System: Linux Serenity 2.6.34-gentoo-r6 #2 SMP Thu Oct 7 22:22:43 CEST 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz
Build Date: 07 January 2011  06:49:36AM

Current version of pixman: 0.20.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  7 19:56:35 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
X: symbol lookup error: /usr/lib/xorg/modules/drivers/Xpsb.so: undefined symbol: xf86AddModuleInfo


[I] x11-drivers/psb-firmware (0.31[1]@12/08/10): firmware for the intel gma500 (poulsbo)
[I] x11-drivers/psb-kmod (4.42.0[1]@01/07/11): kernel module for the intel gma500 (poulsbo)
[I] x11-drivers/xf86-video-psb (0.36.0-r0[1]@01/07/11): xorg driver for the intel gma500 (poulsbo)
[I] x11-libs/xpsb-glx (0.19-r0[1]@12/08/10): glx for the intel gma500 (poulsbo)
[1] "luman" /var/lib/layman/luman
Comment 42 Lukas Elsner 2011-01-13 10:35:22 UTC
(In reply to comment #41)
> I got this problem:
> 
> 
> # X
> 
> X.Org X Server 1.9.2
> Release Date: 2010-10-30
> X Protocol Version 11, Revision 0
> Build Operating System: Linux 2.6.34-gentoo-r6 i686 Gentoo
> Current Operating System: Linux Serenity 2.6.34-gentoo-r6 #2 SMP Thu Oct 7
> 22:22:43 CEST 2010 i686
> Kernel command line: BOOT_IMAGE=/boot/vmlinuz
> Build Date: 07 January 2011  06:49:36AM
> 
> Current version of pixman: 0.20.0
>         Before reporting problems, check http://wiki.x.org
>         to make sure that you have the latest version.
> Markers: (--) probed, (**) from config file, (==) default setting,
>         (++) from command line, (!!) notice, (II) informational,
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan  7 19:56:35 2011
> (==) Using config file: "/etc/X11/xorg.conf"
> (==) Using system config directory "/usr/share/X11/xorg.conf.d"
> X: symbol lookup error: /usr/lib/xorg/modules/drivers/Xpsb.so: undefined
> symbol: xf86AddModuleInfo
> 
> 
> [I] x11-drivers/psb-firmware (0.31[1]@12/08/10): firmware for the intel gma500
> (poulsbo)
> [I] x11-drivers/psb-kmod (4.42.0[1]@01/07/11): kernel module for the intel
> gma500 (poulsbo)
> [I] x11-drivers/xf86-video-psb (0.36.0-r0[1]@01/07/11): xorg driver for the
> intel gma500 (poulsbo)
> [I] x11-libs/xpsb-glx (0.19-r0[1]@12/08/10): glx for the intel gma500 (poulsbo)
> [1] "luman" /var/lib/layman/luman
> 

This should already be fixed in my overlay.
Can you please post the build log of x11-drivers/xf86-video-psb
Comment 43 Akytarus 2011-01-24 16:13:16 UTC
Please see http://pastebin.com/rJHqJNHC for the build log of xf86-video-psb failing to compile
Comment 44 Thomas Stein 2011-01-31 12:37:56 UTC
Hello.

Thanks for the overlay. Works on my eee 1101ha. Are there any special xorg configurations i have to make? Some tuning things? 

cheers
t.
Comment 45 Sven Eden 2011-02-02 16:05:54 UTC
(In reply to comment #36)
> The overlay is called "luman".
> 
> It should contain everything you need.
> It is only tested with 2.6.36, 2.6.37 and newest xserver unter gentoo ~x86.
> 
> Maybe you can test with ~amd64 x86 and amd64 also.
> 

I just tried on amd64 with kernel 2.6.37, and the first try ended like in bug 353514 :

Makefile:546: /usr/src/linux-2.6.37-gentoo/arch/amd64/Makefile: File or directory not found

There is no amd64 folder in arch, it has been merged with x86 folder a while ago.

So I created a symlink from x86 to amd64, but it fails again, this time with a lot of errors.

I'll attach the error log, this time from a manual invocation of make, so the messages are in english. (The logs from the above mentioned bug had to be translated with google from german.)
Comment 46 Sven Eden 2011-02-02 16:08:04 UTC
Created attachment 261353 [details]
Failing error log with gcc-4.5.2, amd64 and gentoo-sources-2.6.37

The promised error log.
Comment 47 Sven Eden 2011-02-02 16:09:22 UTC
Created attachment 261355 [details]
Now the right error log. Damn old mouse!

It was the wrong log, sorry.
Comment 48 Lukas Elsner 2011-02-02 16:11:05 UTC
Hi folks!
I sold my GMA500 Netbook, so i am unable to make any useful changes!
I am very sorry for that, but it was a mess working with it! :(

regards,
Lukas
Comment 49 Sven Eden 2011-02-02 16:11:16 UTC
Created attachment 261358 [details]
Okay, last try with this damn broken USB-stick

Sorry, sorry, sorry! My USB-Ports, or the drive is mad. This is the third and last try. I tripple checked the right file is selected and checked it by hand. If it fails again, I give up.
Comment 50 Sven Eden 2011-02-02 16:13:16 UTC
(In reply to comment #48)
> Hi folks!
> I sold my GMA500 Netbook, so i am unable to make any useful changes!
> I am very sorry for that, but it was a mess working with it! :(
> 
> regards,
> Lukas
> 

Oh no. I daresay I am doomed. I can't sell mine, it's a company laptop. :-(
Comment 51 Lukas Elsner 2011-02-02 16:15:14 UTC
(In reply to comment #50)
> (In reply to comment #48)
> > Hi folks!
> > I sold my GMA500 Netbook, so i am unable to make any useful changes!
> > I am very sorry for that, but it was a mess working with it! :(
> > 
> > regards,
> > Lukas
> > 
> 
> Oh no. I daresay I am doomed. I can't sell mine, it's a company laptop. :-(
> 

Well, very sorry!

Try selling the company instead of the netbook! :D
Comment 52 peter john hartman 2011-02-02 16:19:18 UTC
you should now use the emgd driver available from intel.  1.5.2 works with xorg 1.9 and 2.6.36; 1.5 works with xorg 1.8 and 2.6.34.  as soon as things stabilize a little, I'll post an ebuild, but until then look at launchpad.net/emgd
Comment 53 peter john hartman 2011-02-02 16:26:22 UTC
you should now use the emgd driver available from intel.  1.5.2 works with xorg 1.9 and 2.6.36; 1.5 works with xorg 1.8 and 2.6.34.  as soon as things stabilize a little, I'll post an ebuild, but until then look at launchpad.net/emgd
Comment 54 Sven Eden 2011-02-02 21:39:32 UTC
(In reply to comment #53)
> you should now use the emgd driver available from intel.  1.5.2 works with xorg
> 1.9 and 2.6.36; 1.5 works with xorg 1.8 and 2.6.34.  as soon as things
> stabilize a little, I'll post an ebuild, but until then look at
> launchpad.net/emgd
> 

nicely enough I can use KMS and start KDE-4.6.0 with compositing enabled in full resolution (and 1400 FPS in glxgears) by using mesa-7.10, libdrm-2.4.23 and xf86-video-intel-2.14.0. But after 5 to ten minutes the laptop freezes and I have to power it off. :-(

But I have to say: Sorry, sorry, sorry for hijacking this bug. (And two others. *cough* A wonder I am not banned already.)

I have written a new ebuild, based on the ebuilds from the luman overlay, and a compatibility patch. On my old dev machine, it now compiles fine. I'll see tomorrow whether the module actually works.

To track that I have opened a new bug 353514
Comment 55 Lukas Elsner 2011-02-03 12:43:42 UTC
(In reply to comment #54)
> (In reply to comment #53)
> > you should now use the emgd driver available from intel.  1.5.2 works with xorg
> > 1.9 and 2.6.36; 1.5 works with xorg 1.8 and 2.6.34.  as soon as things
> > stabilize a little, I'll post an ebuild, but until then look at
> > launchpad.net/emgd
> > 
> 
> nicely enough I can use KMS and start KDE-4.6.0 with compositing enabled in
> full resolution (and 1400 FPS in glxgears) by using mesa-7.10, libdrm-2.4.23
> and xf86-video-intel-2.14.0. But after 5 to ten minutes the laptop freezes and
> I have to power it off. :-(
> 
> But I have to say: Sorry, sorry, sorry for hijacking this bug. (And two others.
> *cough* A wonder I am not banned already.)
> 
> I have written a new ebuild, based on the ebuilds from the luman overlay, and a
> compatibility patch. On my old dev machine, it now compiles fine. I'll see
> tomorrow whether the module actually works.
> 
> To track that I have opened a new bug 353514
> 

If this is working properly, I can update my overlay.
Just send me your ebuild pls ;)