Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 274077 - sys-apps/fakechroot: fails to build with glibc-2.10
Summary: sys-apps/fakechroot: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Michal Januszewski (RETIRED)
URL:
Whiteboard:
Keywords:
: 301797 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-13 23:56 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-07-15 13:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (fakechroot-2.9:20090613-212005.log,12.64 KB, text/plain)
2009-06-13 23:58 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-13 23:56:47 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-13 23:58:18 UTC
Created attachment 194597 [details]
Build log
Comment 2 Michal Januszewski (RETIRED) gentoo-dev 2009-06-22 21:54:16 UTC
Fixed in CVS.  Thanks for reporting the problem!
Comment 3 Jeroen Roovers gentoo-dev 2010-01-26 06:06:10 UTC
*** Bug 301797 has been marked as a duplicate of this bug. ***