Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273978 - net-irc/ircservices: fails to build with glibc-2.10
Summary: net-irc/ircservices: fails to build with glibc-2.10
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Packages in net-irc
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-13 11:30 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2011-06-16 04:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (ircservices-5.1.14:20090612-233557.log,42.70 KB, text/plain)
2009-06-13 11:32 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-13 11:30:54 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-13 11:32:02 UTC
Created attachment 194511 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-08 14:33:34 UTC
Intresting. I didn't manage to get so far with this one,

sockets.c:492: Error: Incorrect register `%edx' used with `q' suffix
sockets.c:470: Error: Incorrect register `%edx' used with `q' suffix
sockets.c:2159: Error: Incorrect register `%eax' used with `q' suffix
sockets.c:2160: Error: Incorrect register `%eax' used with `q' suffix
sockets.c:1746: Error: Incorrect register `%eax' used with `q' suffix
sockets.c:1748: Error: Incorrect register `%eax' used with `q' suffix
sockets.c:2099: Error: Incorrect register `%eax' used with `q' suffix
sockets.c:2040: Error: Incorrect register `%eax' used with `q' suffix
Comment 3 Andrew Church 2009-08-09 00:35:55 UTC
This is fixed in ircservices-5.1.20 (just released).
Comment 4 Andrew Church 2009-08-09 00:38:51 UTC
(The getline error, that is.  The sockets.c errors are all in FD_SET and FD_CLR macro calls, so that looks like a glibc bug.)
Comment 5 Víctor Ostorga (RETIRED) gentoo-dev 2009-08-10 17:25:30 UTC
Fixed in portage
Comment 6 Samuli Suominen gentoo-dev 2009-08-10 17:32:05 UTC
(In reply to comment #3)
> This is fixed in ircservices-5.1.20 (just released).
> 

Please open a new bug for the version bump (if you want)
Comment 7 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2011-06-16 04:22:51 UTC
(In reply to comment #4)
> (The getline error, that is.  The sockets.c errors are all in FD_SET and FD_CLR
> macro calls, so that looks like a glibc bug.)

These sockets.c errors are actually caused by:

defs.h
/* Make sizeof() return an int regardless of compiler (avoids printf
 * argument type warnings). */
#define sizeof(v)       ((int)sizeof(v))
You've just got to live with sizeof() returning size_t like it should. Removing this line fixes those asm compilation errors on amd64 systems. Just FYI ;-).