Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273977 - dev-embedded/gpsim-lcd: fails to build with gcc-4.4
Summary: dev-embedded/gpsim-lcd: fails to build with gcc-4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Embedded Team (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 277758 (view as bug list)
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-06-13 11:26 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-07-24 00:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (gpsim-lcd-0.2.9:20090612-204317.log,14.43 KB, text/plain)
2009-06-13 11:27 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-13 11:26:10 UTC
As per summary, check attached build log.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-13 11:27:56 UTC
Created attachment 194510 [details]
Build log
Comment 2 Thomas Capricelli 2009-07-01 00:04:15 UTC
(using gcc4.4 on ~amd64)

I don't know if that's related to gcc4.4. But i have the same compilation error: 

....
libtool: compile:  x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -march=native -O3 -pipe -msse3 -c lcd.cc  -fPIC -DPIC -o .libs/lcd.o
In file included from module_manager.cc:52:
lcd.h: In constructor ‘LcdTraceType::LcdTraceType(LcdDisplay*, unsigned int)’:
lcd.h:89: error: no matching function for call to ‘TraceType::TraceType(unsigned int&)’
/usr/include/gpsim/trace.h:192: note: candidates are: TraceType::TraceType(unsigned int, const char*)
/usr/include/gpsim/trace.h:188: note:                 TraceType::TraceType(const TraceType&)
make[2]: *** [module_manager.lo] Error 1
Comment 3 Thomas Capricelli 2009-07-01 00:08:06 UTC
if i do "CC=gcc-4.3.3 emerge dev-embedded/gpsim-lcd" i have the same error. I'm not allowed to change the subject, but i think it should be "fails to build" only. I think gcc-4.3.3 was actually used since the configure says :

checking if gcc-4.3.3 supports -fno-rtti -fno-exceptions... no                                                                                                                              
checking for gcc-4.3.3 option to produce PIC... -fPIC -DPIC                                                                                                                                 
checking if gcc-4.3.3 PIC flag -fPIC -DPIC works... yes                                                                                                                                     
checking if gcc-4.3.3 static flag -static works... yes                                                                                                                                      
checking if gcc-4.3.3 supports -c -o file.o... yes                                                                                                                                          
checking if gcc-4.3.3 supports -c -o file.o... (cached) yes   
Comment 4 Thomas Capricelli 2009-07-01 00:20:28 UTC
I've found the 0.2.10 on sf: just renaming the ebuild to gpsim-lcd-0.2.10.ebuild, computing digest and emerging it.... works! For you info.
Comment 5 Samuli Suominen gentoo-dev 2009-07-18 15:45:25 UTC
*** Bug 277758 has been marked as a duplicate of this bug. ***
Comment 6 Samuli Suominen gentoo-dev 2009-07-18 15:47:09 UTC
(In reply to comment #3)
> if i do "CC=gcc-4.3.3 emerge dev-embedded/gpsim-lcd" i have the same error. 

That's totally wrong way to "change" compiler; no suprise. It was likely using 4.4.

Use "gcc-config".
Comment 7 Samuli Suominen gentoo-dev 2009-07-18 16:01:22 UTC
Fixed,

+*gpsim-lcd-0.2.10 (18 Jul 2009)
+
+  18 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+  +gpsim-lcd-0.2.10.ebuild:
+  Version bump.
Comment 8 Thomas Capricelli 2009-07-24 00:51:34 UTC
to #6, as i said :

"I think gcc-4.3.3 was actually used since the configure says :

checking if gcc-4.3.3 supports -fno-rtti -fno-exceptions... no                  
checking for gcc-4.3.3 option to produce PIC... -fPIC -DPIC                     
checking if gcc-4.3.3 PIC flag -fPIC -DPIC works... yes                         
checking if gcc-4.3.3 static flag -static works... yes                          
checking if gcc-4.3.3 supports -c -o file.o... yes                              
checking if gcc-4.3.3 supports -c -o file.o... (cached) yes   
"