Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273856 - net-p2p/mutella: fails to build with glibc-2.10
Summary: net-p2p/mutella: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo net-p2p team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-12 11:53 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-09 15:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (mutella-0.4.5:20090612-114812.log,37.37 KB, text/plain)
2009-06-12 11:54 UTC, Diego Elio Pettenò (RETIRED)
Details
adds couple strategic consts to allow compilation with gcc44/glibc210 (mutella-0.4.5-gcc44.patch,1.05 KB, patch)
2009-07-08 17:48 UTC, Arttu Valo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-12 11:53:37 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-12 11:54:05 UTC
Created attachment 194399 [details]
Build log
Comment 2 Arttu Valo 2009-07-08 17:48:45 UTC
Created attachment 197223 [details, diff]
adds couple strategic consts to allow compilation with gcc44/glibc210
Comment 3 Samuli Suominen gentoo-dev 2009-08-09 15:28:45 UTC
+  09 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mutella-0.4.5.ebuild,
+  +files/mutella-0.4.5-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #273856, thanks to Arttu Valo for patch.