Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273731 - x11-misc/gmrun-0.9.2 fails to build
Summary: x11-misc/gmrun-0.9.2 fails to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
: 280902 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-11 14:50 UTC by Sebastian Günther
Modified: 2009-08-09 18:51 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.33 KB, text/plain)
2009-06-11 14:50 UTC, Sebastian Günther
Details
emerge --info (emerge --info,5.06 KB, text/plain)
2009-06-19 18:25 UTC, Simeon Maryasin
Details
build.log (build.log,7.70 KB, text/plain)
2009-06-19 18:25 UTC, Simeon Maryasin
Details
Quick fix. (gtkcompletionline.cc.patch,421 bytes, patch)
2009-06-19 18:42 UTC, Simeon Maryasin
Details | Diff
fixed (gmrun-0.9.2.ebuild,1005 bytes, text/plain)
2009-08-08 08:51 UTC, Simeon Maryasin
Details
for ~arch (gmrun-0.9.2-r1.ebuild,1.02 KB, text/plain)
2009-08-08 08:51 UTC, Simeon Maryasin
Details
for arch (gmrun-0.9.2.ebuild,1005 bytes, text/plain)
2009-08-08 21:14 UTC, Simeon Maryasin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Günther 2009-06-11 14:50:03 UTC
make -j1 
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/x11-misc/gmrun-0.9.2/work/gmrun-0.9.2'
Making all in src
make[2]: Entering directory `/var/tmp/portage/x11-misc/gmrun-0.9.2/work/gmrun-0.9.2/src'
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -D_REENTRANT -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12       -march=prescott -msse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer -MT gtkcompletionline.o -MD -MP -MF .deps/gtkcompletionline.Tpo -c -o gtkcompletionline.o gtkcompletionline.cc
gtkcompletionline.cc: In function ‘guint gtk_completion_line_get_type()’:
gtkcompletionline.cc:94: warning: deprecated conversion from string constant to ‘gchar*’
gtkcompletionline.cc: In function ‘void generate_execs()’:
gtkcompletionline.cc:411: error: invalid conversion from ‘int (*)(const void*, const void*)’ to ‘int (*)(const dirent**, const dirent**)’
gtkcompletionline.cc:411: error:   initializing argument 4 of ‘int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const dirent**, const dirent**))’
gtkcompletionline.cc: In function ‘int generate_dirlist(const char*)’:
gtkcompletionline.cc:511: error: invalid conversion from ‘int (*)(const void*, const void*)’ to ‘int (*)(const dirent**, const dirent**)’
gtkcompletionline.cc:511: error:   initializing argument 4 of ‘int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const dirent**, const dirent**))’
make[2]: *** [gtkcompletionline.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-misc/gmrun-0.9.2/work/gmrun-0.9.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-misc/gmrun-0.9.2/work/gmrun-0.9.2'
make: *** [all] Error 2
 * 
 * ERROR: x11-misc/gmrun-0.9.2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2653:  Called _eapi0_src_compile
 *               ebuild.sh, line  600:  Called _eapi2_src_compile
 *               ebuild.sh, line  634:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-misc/gmrun-0.9.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/gmrun-0.9.2/temp/environment'.
 * 

Reproducible: Always

Steps to Reproduce:




Portage 2.2_rc33 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-tuxonice-r3 i686)
=================================================================
System uname: Linux-2.6.29-tuxonice-r3-i686-Intel-R-_Core-TM-_Duo_CPU_T2300_@_1.66GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 11 Jun 2009 10:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -msse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -msse3 -mfpmath=sse -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildsyspkg ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://de-mirror.org/distro/gentoo/ http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://mirror.muntinternet.net/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="de fr nl en en_GB en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/x11 /usr/local/portage/layman/sunrise /usr/local/portage/local-overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac abiword abook ace acl acpi alsa applet audacious audiofile bash-completion battery berkdb bluetooth branding bzip2 cairo caps cdda cddb cdparanoia cdr cgi chipcard cli compress consolekit context cpio cpufreq cracklib crypt cups curl cursors dbus device-mapper dga directfb divx dri dv dvd dvdr dvdread dvi dvipdfm emacs emboss emerald encode epydoc examples exif expat extra fam fastcgi fat fbcon fbcondecor fbsplash ffmpeg flac fontconfig fortran ftp fuse gcj gd gdbm gdm gedit gif gimp git glib glitz gmedia gnutls gpgme gpm grammar graphics graphviz gs gsf gtk gzip hal hbci hdaps hddtemp http humanities hybrid-auth ibmacpi ical icecast icons iconv icq icu id3 id3tag imagemagick imap imlib imlib2 iproute2 ipv6 ipw3945 irc isdnlog jabber java java6 javascript jpeg kerberos kpathsea ladspa lame laptop latex latex3 lcms ldap libnotify libsamplerate libwww lm_sensors logrotate logwatch lua mad midi mikmod milter mime mjpeg mmx mmxext mng motif mp3 mpeg mplayer mudflap musepack musicbrainz nano-syntax ncurses network-cron nls nntp nptl nptlonly nsplugin ntfs ntp obex offensive ofx ogg omega opengl openmp oscar otr ots pam pcmcia pcre pda pdf perl php pmu png policykit pop posix postgres ppds pppd prediction print pstricks publishers python quicktime quotes rar rdesktop readline realmedia reflection replaygain replytolist resolvconf rss samba sasl science screenshot sdl session skey slang slit smapi smime smp snmp sockets socks5 sound soundtouch speex spell spl sqlite sqlite3 sse sse2 ssh ssl startup-notification subtitles subversion svg swig sysfs syslog sysvipc t1lib taglib tcpd tetex tex4ht theora thesaurus thinkpad threads tiff tk toolbar tools transcode trayicon truetype twolame unicode unzip usb utils uuencode v4l v4l2 vamp vcd vhosts video vnc vncviewer vorbis wavpack wifi win32codecs wireshark wma wmf wmp x86 xattr xcb xcomposite xetex xface xfce xft xine xinerama xinetd xml xorg xosd xpm xscreensaver xskatcards xspf xulrunner xv xvid yv12 zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr nl en en_GB en_US" USERLAND="GNU" VIDEO_CARDS="vesa intel v4l vga i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Sebastian Günther 2009-06-11 14:50:40 UTC
Created attachment 194252 [details]
build.log
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-14 00:58:53 UTC
Most likely another glibc-2.10.1 regression...
Comment 3 Simeon Maryasin 2009-06-19 18:25:40 UTC
Created attachment 195188 [details]
emerge --info
Comment 4 Simeon Maryasin 2009-06-19 18:25:59 UTC
Created attachment 195189 [details]
build.log
Comment 5 Simeon Maryasin 2009-06-19 18:42:56 UTC
Created attachment 195194 [details, diff]
Quick fix.
Comment 6 Simeon Maryasin 2009-06-19 18:51:24 UTC
Also, there is an error in default config file:
URL_http = firefox -remote "openURL(%u, new-wendow)"
instead of
URL_http = firefox -remote "openURL(%u, new-window)"

(I don't know, must I say about it here, or open a new bug, of forget...)
Comment 7 tman 2009-07-25 05:37:56 UTC
its a pitty thats this app i realy out of date. cod some one fix this as soon as to make it useable in muticore, 64 bit systems.

thx a lot
Comment 8 Samuli Suominen gentoo-dev 2009-07-25 07:20:48 UTC
(In reply to comment #6)
> Also, there is an error in default config file:
> URL_http = firefox -remote "openURL(%u, new-wendow)"
> instead of
> URL_http = firefox -remote "openURL(%u, new-window)"

There's no such typo in the default config file... Must be your owns :-)
Comment 9 Samuli Suominen gentoo-dev 2009-07-25 07:21:06 UTC
Applied the glibc-2.10+ patch, thanks for reporting.
Comment 10 Peter Avramucz 2009-08-08 07:06:44 UTC
Hi!
I tried to compile gmrun on a amd64 arch, but I get these errors with the gcc and glibc patches applied:
gtkcompletionline.cc: In function ‘void generate_execs()’:
gtkcompletionline.cc:411: error: invalid conversion from ‘int (*)(const dirent**, const dirent**)’ to ‘int (*)(const void*, const void*)’
gtkcompletionline.cc:411: error:   initializing argument 4 of ‘int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const void*, const void*))’
gtkcompletionline.cc: In function ‘int generate_dirlist(const char*)’:
gtkcompletionline.cc:511: error: invalid conversion from ‘int (*)(const dirent**, const dirent**)’ to ‘int (*)(const void*, const void*)’
gtkcompletionline.cc:511: error:   initializing argument 4 of ‘int scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const void*, const void*))’

Here comes the interesting part: I found /gentoo/usr/portage/x11-libs/fltk/files/fltk2-glibc2.10-scandir.patch, however, if I write 
(int(*)(const void*,const void*))
before "my_alphasort" in line 411 and 511, it compiles fine. The strange thing, that writing
(int(*)(const dirent **,const dirent **))
generates an error again (the latter line is used in the fltk2 patch)...
Comment 11 Simeon Maryasin 2009-08-08 08:37:41 UTC
(In reply to comment #10)
> I tried to compile gmrun on a amd64 arch
Hm... Do you have amd64 or ~amd64? Which version of glibc?

> gtkcompletionline.cc: In function ‘void generate_execs()’:
> gtkcompletionline.cc:411: error: invalid conversion from ‘int (*)(const
> dirent**, const dirent**)’ to ‘int (*)(const void*, const void*)’
> gtkcompletionline.cc:411: error:   initializing argument 4 of ‘int
> scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const void*,
> const void*))’
> gtkcompletionline.cc: In function ‘int generate_dirlist(const char*)’:
> gtkcompletionline.cc:511: error: invalid conversion from ‘int (*)(const
> dirent**, const dirent**)’ to ‘int (*)(const void*, const void*)’
> gtkcompletionline.cc:511: error:   initializing argument 4 of ‘int
> scandir(const char*, dirent***, int (*)(const dirent*), int (*)(const void*,
> const void*))’
It seems that you have pre-2.10 glibc, and don't need this patch at all...

Maybe we should check version of glibc before applying patch?
Comment 12 Simeon Maryasin 2009-08-08 08:40:12 UTC
Or else, we can remove patch from 0.9.2 ebuild and add a
gmrun-0.9.2-r1 ebuild with this patch, and mark it as ~arch:
on 'stable' systems 0.9.2 (without patch) will install OK, and on ~arch - 0.9.2-r1 will be taken.
Comment 13 Peter Avramucz 2009-08-08 08:41:13 UTC
(In reply to comment #11)
> Hm... Do you have amd64 or ~amd64? Which version of glibc?
I have stable amd64, only some ~amd64 packages.My glibc version is: 2.9_p20081201-r2 .

> It seems that you have pre-2.10 glibc, and don't need this patch at all...
> 
> Maybe we should check version of glibc before applying patch?
I think so. 

Comment 14 Simeon Maryasin 2009-08-08 08:46:55 UTC
BTW, fltk uses this method:

(in fltk-2.0_pre6786.ebuild)
KEYWORDS="amd64"
DEPEND="<sys-libs/glibc-2.10"   # glibc-2.10 patch breaks with 2.9, bug 276695

(in fltk-2.0_pre6786-r1.ebuild)
KEYWORDS="~amd64"
DEPEND=">=sys-libs/glibc-2.10"   # glibc-2.10 patch breaks with 2.9, bug 276695
epatch "${FILESDIR}"/fltk2-glibc2.10-scandir.patch  # bug 270487
Comment 15 Simeon Maryasin 2009-08-08 08:51:31 UTC
Created attachment 200558 [details]
fixed
Comment 16 Simeon Maryasin 2009-08-08 08:51:45 UTC
Created attachment 200560 [details]
for ~arch
Comment 17 Peter Avramucz 2009-08-08 21:10:31 UTC
(In reply to comment #15)
> Created an attachment (id=200558) [edit]
> fixed
> 

<dev-libc/glibc-2.10 ???
You mean:
<sys-libs/glibc-2.10
don't you?
Comment 18 Simeon Maryasin 2009-08-08 21:13:11 UTC
(In reply to comment #17)
> <dev-libc/glibc-2.10 ???
> You mean:
> <sys-libs/glibc-2.10
> don't you?
Yes, of course. Sorry.
Comment 19 Simeon Maryasin 2009-08-08 21:14:39 UTC
Created attachment 200624 [details]
for arch
Comment 20 James Earl Spahlinger 2009-08-09 18:51:57 UTC
*** Bug 280902 has been marked as a duplicate of this bug. ***