Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273652 - games-puzzle/gemhun removal request (was: fails to build with glibc-2.10)
Summary: games-puzzle/gemhun removal request (was: fails to build with glibc-2.10)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 239561 glibc-2.10
  Show dependency tree
 
Reported: 2009-06-10 20:37 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-23 08:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (gemhun-20040529:20090610-203520.log,56.32 KB, text/plain)
2009-06-10 20:38 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-10 20:37:24 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-10 20:38:44 UTC
Created attachment 194193 [details]
Build log
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2009-07-29 22:01:02 UTC
utils.cpp: In function 'char* basename(char*)':
utils.cpp:349: error: declaration of 'char* basename(char*)' throws different exceptions
../include/utils.h:45: error: from previous declaration 'char* basename(char*) throw ()'
make[2]: *** [utils.o] Error 1
Comment 3 Samuli Suominen gentoo-dev 2009-08-09 14:52:45 UTC
Don't know how you guys managed to get so far with this package as it's deps won't build (kyra) but this seems like a fine candidate for removal.. 20040529
Comment 4 Viktor S 2009-08-31 22:19:26 UTC
Upstream is dead and any means of contact seems to be too. Mask and clean it out asap?
Comment 5 Samuli Suominen gentoo-dev 2009-09-04 08:48:01 UTC
I've added new kyra (with huge patchset) in tree so it's usable again, but unfortunately I found out Kyra changed ABI in a way gemhun isn't compatible anymore in version 2.1.0 and we have 2.1.3+snapshot. Proposed package.mask entry:

# Developer Zero <developerzero@gentoo.org> (04 Sep 2009)
# Old Kyra ABI and unfunctionality with recent toolchain.
games-puzzle/gemhun
<dev-games/kyra-2.1.0
Comment 6 Samuli Suominen gentoo-dev 2009-09-23 08:56:38 UTC
Gone.