Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273557 - games-arcade/xevil: fails to build with glibc-2.10
Summary: games-arcade/xevil: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-10 13:19 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-04 09:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (xevil-2.02_p2-r1:20090610-101933.log.bz2,11.03 KB, application/x-bzip2)
2009-06-10 13:20 UTC, Diego Elio Pettenò (RETIRED)
Details
a crude patch with const_casts which enabled the compilation with glibc210 (xevil-2.02_p2-glibc210.patch,645 bytes, patch)
2009-08-22 00:29 UTC, Arttu Valo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-10 13:19:21 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-10 13:20:59 UTC
Created attachment 194155 [details]
Build log
Comment 2 Arttu Valo 2009-08-22 00:29:22 UTC
Created attachment 201906 [details, diff]
a crude patch with const_casts which enabled the compilation with glibc210

Only tested compilation.
Comment 3 Samuli Suominen gentoo-dev 2009-09-04 09:32:33 UTC
+  04 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+  xevil-2.02_p2-r1.ebuild, +files/xevil-2.02_p2-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #273557 by Arttu Valo.
+