Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273407 - games-emulation/mupen64-glide64: fails to build with glibc-2.10
Summary: games-emulation/mupen64-glide64: fails to build with glibc-2.10
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
: 301386 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-09 18:23 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2010-01-24 18:50 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (mupen64-glide64-0.7:20090609-171955.log,22.35 KB, text/plain)
2009-06-09 18:23 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 18:23:00 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 18:23:23 UTC
Created attachment 194025 [details]
Build log
Comment 2 Arttu Valo 2009-08-22 23:37:51 UTC
The first error (visible in the attached log here) was just a single missing const qualifier in Main.cpp, but next you'll hit some assembler problems with the asm labels in TexLoad8b.h.

As the upstream of mupen64 appears pretty dead and activity seems to have moved over to mupen64plus fork (and they have made some modifications to the assembler portions as well), I wonder if these old mupen64-packages should be queued to the treecleaners? The "replacing" mupen64plus fork has made it into sunrise just a few weeks ago ( bug #215426 ).
Comment 3 Samuli Suominen gentoo-dev 2009-09-04 09:34:56 UTC
@games: Should we lastrite mupen64 in favour of mupen64plus?
Comment 4 Samuli Suominen gentoo-dev 2009-09-04 10:54:01 UTC
joker, see last comment
Comment 5 Mr. Bones. (RETIRED) gentoo-dev 2009-09-04 15:16:14 UTC
I vote yes but it's up to joker.
Comment 6 Tristan Heaven (RETIRED) gentoo-dev 2009-09-22 22:50:41 UTC
No response means yes?

I've added ~x86 to mupen64plus now, so it should be okay...
Comment 7 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-12-23 23:25:47 UTC
Tristan do you feel like doing the last-rites now?
Comment 8 Samuli Suominen gentoo-dev 2009-12-30 20:40:28 UTC
Joker, ping?

Suggested p.mask entry

# Samuli Suominen <ssuominen@gentoo.org> (30 Dec 2009)
# Doesn't compile (#273407)
# Crashes (#124767)
# Has qt3 deps (#283429)
#
# Replaced by games-emulation/mupen64plus
#
# Removal in 30 days
games-emulation/mupen64
games-emulation/mupen64-alsasnd
games-emulation/mupen64-blight-tr64gl
games-emulation/mupen64-blight-uhleaudio
games-emulation/mupen64-glide64
games-emulation/mupen64-riceplugin
Comment 9 Samuli Suominen gentoo-dev 2009-12-30 20:50:08 UTC
Masked. O.K's by Joker on IRC.
Comment 10 Christian Birchinger (RETIRED) gentoo-dev 2009-12-30 21:05:58 UTC
Sorry, i failed here. Didn't notice the bug. But i'm at least fast at responding in IRC.
Comment 11 Samuli Suominen gentoo-dev 2010-01-18 16:50:55 UTC
*** Bug 301386 has been marked as a duplicate of this bug. ***
Comment 12 Samuli Suominen gentoo-dev 2010-01-24 18:50:56 UTC
History. Replaced by mupen64plus.