Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273370 - sci-electronics/gnucap: fails to build with glibc-2.10
Summary: sci-electronics/gnucap: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-09 15:26 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-07-11 19:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (gnucap-0.35.20090202:20090609-152525.log,9.99 KB, text/plain)
2009-06-09 15:27 UTC, Diego Elio Pettenò (RETIRED)
Details
fixes the constness of char pointers (gnucap-0.35.20090202-glibc210.patch,908 bytes, patch)
2009-07-06 08:58 UTC, Arttu Valo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 15:26:48 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 15:27:01 UTC
Created attachment 194004 [details]
Build log
Comment 2 Arttu Valo 2009-07-06 08:58:14 UTC
Created attachment 196866 [details, diff]
fixes the constness of char pointers

Fixes the two spots that needed char pointers constified with glibc210.
Comment 3 Denis Dupeyron gentoo-dev 2009-07-11 19:34:25 UTC
Fixed in gnucap-0.35.20090611, thanks for the patch.

Denis.