Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273274 - x11-themes/baghira fails to build with glibc-2.10
Summary: x11-themes/baghira fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-09 00:29 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-04 08:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (baghira-0.8:20090609-001649.log,88.67 KB, text/plain)
2009-06-09 00:29 UTC, Diego Elio Pettenò (RETIRED)
Details
patch for glibc 2.10 compatibility (baghira-0.8-glibc210.patch,389 bytes, patch)
2009-08-14 15:31 UTC, Petr Behan
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 00:29:38 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 00:29:52 UTC
Created attachment 193954 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-08 09:05:34 UTC
kde3 theme... seriously, not fixing
Comment 3 Joël 2009-08-08 12:36:55 UTC
Not to start an argument but (imho) Baghira is one of the best KDE 3 themes ever made and... what's wrong about KDE 3 ?

Personally I like QT4 and KDE4, but I still use KDE 3 exclusively, and so do *all* my colleagues at work. Maybe we're conservative but... we're perfectly happy with KDE 3.

I think fixing this package to work with the newer glibc would be worth it :-)
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-08-08 12:38:39 UTC
KDE3 is bitrotting by the day, and most KDE3 packages that fail to build for whatever reasons will just be removed soon.

Among other things, they don't seem to play nice with autoconf 2.64.
Comment 5 Samuli Suominen gentoo-dev 2009-08-08 12:40:01 UTC
I advise anyone wondering in this bug copying the theme to your local overlay *now*, if you want to keep using it.
Comment 6 Petr Behan 2009-08-14 15:31:02 UTC
Created attachment 201245 [details, diff]
patch for glibc 2.10 compatibility

(In reply to comment #5)
> I advise anyone wondering in this bug copying the theme to your local overlay
> *now*, if you want to keep using it.

And if you add this patch, it will continue to work for a little while longer...

(add PATCHES="${FILESDIR}/${P}-glibc210.patch" line to the ebuild itself)
Comment 7 Andreas Thalhammer 2009-08-25 19:57:16 UTC
Tested x11-themes/baghira-0.8 with the glibc210.patch and it compiles again. Tested and working great.

DON'T REMOVE. Still a great theme for KDE3 users.
UNMASK. Compiles and works.
STABILIZE. Tested on x86.
Comment 8 Samuli Suominen gentoo-dev 2009-09-04 08:24:21 UTC
Applied the patch in portage... let this be for a while then