Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273111 - sys-apps/hal - hald: [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0 but all addons are already ready!
Summary: sys-apps/hal - hald: [E] device.c:1705: In hal_device_inc_num_ready_addons fo...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Daniel Gryniewicz (RETIRED)
URL:
Whiteboard:
Keywords:
: 285835 (view as bug list)
Depends on: 313389
Blocks:
  Show dependency tree
 
Reported: 2009-06-07 20:56 UTC by ipse
Modified: 2011-09-18 09:29 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
STDERR output (hal.log.tar.gz,93.05 KB, text/plain)
2009-06-11 20:44 UTC, ipse
Details
STDERR output (hal.log.tar.gz,93.05 KB, application/x-gzip)
2009-06-11 20:45 UTC, ipse
Details
hald.log (hald.txt,464.48 KB, text/plain)
2009-07-17 19:51 UTC, Conrad Kostecki
Details
hald-strace2.txt (hald-strace2.txt,1.70 MB, text/plain)
2009-07-18 20:50 UTC, Conrad Kostecki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ipse 2009-06-07 20:56:17 UTC
Jun  7 23:30:20 localhost hald[9699]: 23:30:20.893 [E] acpi.c:762: Couldn't open /proc/acpi/battery: Error opening directory '/proc/acpi/battery': No such file or directory                                                                                                                                        
Jun  7 23:30:20 localhost hald[9699]: 23:30:20.893 [E] acpi.c:762: Couldn't open /proc/acpi/button/lid: Error opening directory '/proc/acpi/button/lid': No such file or directory                                                                                                                                  
Jun  7 23:30:21 localhost hald-probe-serial: [11723]: 23:30:21.431 [E] probe-serial.c:84: serial port /dev/ttyS1 seems not to exist
Jun  7 23:30:21 localhost hald-probe-serial: [11724]: 23:30:21.431 [E] probe-serial.c:84: serial port /dev/ttyS2 seems not to exist
Jun  7 23:30:21 localhost hald-probe-serial: [11727]: 23:30:21.431 [E] probe-serial.c:84: serial port /dev/ttyS3 seems not to exist
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.384 [E] acpi.c:762: Couldn't open /proc/acpi/battery: Error opening directory '/proc/acpi/battery': No such file or directory                                                                                                                                        
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.384 [E] acpi.c:762: Couldn't open /proc/acpi/fan: Error opening directory '/proc/acpi/fan': No such file or directory                                                                                                                                                
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.384 [E] acpi.c:762: Couldn't open /proc/acpi/ac_adapter: Error opening directory '/proc/acpi/ac_adapter': No such file or directory                                                                                                                                  
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.384 [E] acpi.c:762: Couldn't open /proc/acpi/button/lid: Error opening directory '/proc/acpi/button/lid': No such file or directory                                                                                                                                  
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.384 [E] acpi.c:762: Couldn't open /proc/acpi/button/sleep: Error opening directory '/proc/acpi/button/sleep': No such file or directory                                                                                                                              
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.434 [E] hald_runner.c:671: Error running 'hald-addon-storage': org.freedesktop.DBus.Error.Disconnected: Connection was disconnected before a reply was received                                                                                                      
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.434 [E] hald.c:124: Cannot start addon hald-addon-storage for udi /org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0                                                                                                                   
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.436 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_MS_000022272228_0_1 but all addons are already ready!                                                                                 
Jun  7 23:30:22 localhost hald-addon-acpi: [13069]: 23:30:22.439 [E] addon-acpi.c:52: Cannot open /proc/acpi/event: No such file or directory
Jun  7 23:30:22 localhost hald-addon-acpi: [13069]: 23:30:22.440 [E] addon-acpi.c:77: Cannot connect to acpid socket: No such file or directory
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.442 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0 but all addons are already ready!                                                                                 
Jun  7 23:30:22 localhost hald[9699]: 23:30:22.442 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0 but all addons are already ready!                                                                                 
Jun  7 23:30:22 localhost hald-addon-storage: [13085]: 23:30:22.445 [E] addon-storage.c:813: Cannot claim interface 'org.freedesktop.Hal.Device.Storage.Removable'                                                                                                                                                  
Jun  7 23:30:27 localhost hald-addon-acpi: [13069]: 23:30:27.444 [E] addon-acpi.c:77: Cannot connect to acpid socket: No such file or directory

Reproducible: Always
Comment 1 ipse 2009-06-07 20:57:01 UTC
localhost gajim # emerge --info 
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.4.0, glibc-2.10.1-r0, 2.6.30-rc7-git4 x86_64)
=================================================================                                
System uname: Linux-2.6.30-rc7-git4-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 30 May 2009 03:20:01 +0000                                                      
app-shells/bash:     4.0_p24                                                                            
dev-java/java-config: 2.1.8                                                                             
dev-lang/python:     2.4.6, 2.6.2-r1                                                                    
dev-util/cmake:      2.6.3-r1                                                                           
sys-apps/baselayout: 2.0.1                                                                              
sys-apps/openrc:     0.4.3-r2                                                                           
sys-apps/sandbox:    1.9                                                                                
sys-devel/autoconf:  2.13, 2.63-r1                                                                      
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                  
sys-devel/binutils:  2.19.1-r1                                                                          
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6a                                                                             
virtual/os-headers:  2.6.29                                                                             
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://mirror.yandex.ru/gentoo-distfiles/ http://ftp.klid.dk/ftp/gentoo/ ftp://ftp.klid.dk/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ ftp://trumpetti.atm.tut.fi/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ http://ftp.vectranet.pl/gentoo/ ftp://ftp.vectranet.pl/gentoo/ http://gentoo.prz.rzeszow.pl http://gentoo.zie.pg.gda.pl http://gentoo.po.opole.pl ftp://gentoo.po.opole.pl ftp://mirror.icis.pcz.pl/gentoo/ http://gentoo.mirror.pw.edu.pl/ http://mirror.yandex.ru/gentoo-distfiles/ "
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bluetooth bzip2 cli cracklib crypt cups dbus dri fortran gdbm gnome gpm gtk hal iconv ipv6 isdnlog midi mmx mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python qt4 readline reflection samba session spl sse sse2 ssl sysfs tcpd unicode vorbis xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="dav dav_fs dir authn_file auth_digest authz_groupfile authz_host mime" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 hubertstar 2009-06-08 04:21:54 UTC
I have same problem.

the main error is:

Jun  7 23:30:22 localhost hald[9699]: 23:30:22.442 [E] device.c:1705: In
hal_device_inc_num_ready_addons for
udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0
but all addons are already ready!     
Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-06-11 13:54:54 UTC
What's the actual symptoms of the problem?  Does hal stop?  Does something fail to mount?  What?

The ACPI errors are all because you don't have ACPI enabled properly in your kernel, specifically CONFIG_ACPI_PROCFS.

hubertstar: are you also running a git-sources-2.6.30 kernel?
Comment 4 ipse 2009-06-11 16:00:39 UTC
HAL it is not started. It began to be started only after removal of files
* 10-cpufreq.fdi
* 10-input-policy.fdi
* 10-power-mgmt-policy.fdi
* 20-storage-methods.fdi
In/usr/share/hal/fdi/policy/10osvendor
Thus automounting does not work.
CONFIG_ACPI_PROCFS deprecated, therefore has been disconnected in a kernel.
Comment 5 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-06-11 16:12:10 UTC
Turn it back on.  Sorry, hal needs deprecated kernel settings, and it won't be fixed, since it's on it's way out.

You cannot always just turn off deprecated kernel settings, and expect to have a working system.
Comment 6 ipse 2009-06-11 17:00:17 UTC
I've disabled acpi use flag in the hal, leaving only the flags X crypt
Updated kernel to release
uname -a
Linux localhost 2.6.30 #1 SMP Thu Jun 11 19:18:59 EEST 2009 x86_64 Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz GenuineIntel GNU/Linux

still hal does not start because of other errors
cat /var/log/messages | grep '\[E\]'
Jun 11 19:44:49 localhost hald[4345]: 19:44:49.706 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_MS_000022272228_0_1 but all addons are already ready!
Jun 11 19:44:49 localhost hald[4345]: 19:44:49.706 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_SM_000022272228_0_2 but all addons are already ready!
Jun 11 19:44:49 localhost hald[4345]: 19:44:49.707 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0 but all addons are already ready!
Jun 11 19:44:49 localhost hald[4345]: 19:44:49.708 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_SD_MMC_000022272228_0_3 but all addons are already ready!
Jun 11 19:44:49 localhost hald[4345]: 19:44:49.708 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_model_DVD_RW_AD_7173S but all addons are already ready!
Comment 7 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-06-11 17:30:00 UTC
Okay, I've looked at the code, and those are not fatal errors anywhere.  Your hal must be stopping for some other reason.  Are there by any chance core files in / ?

The "Cannot claim interface" error in the first post is, in face, a fatal error.  Is that persisting?
Comment 8 ipse 2009-06-11 18:19:40 UTC
Now hal at start produces errors only the enumerated.
Where still it is possible to look?
localhost ipse # rm /var/log/messages
localhost ipse # /etc/init.d/syslog-ng restart
* Stopping syslog-ng...                                                                                                                             [ ok ]
* Starting syslog-ng...                                                                                                                             [ ok ]
localhost ipse # /etc/init.d/hald start
* Starting Hardware Abstraction Layer daemon...                                                                                                     [ !! ]
* ERROR: hald failed to start
localhost ipse # cat /var/log/messages | grep '\[E\]'
Jun 11 21:16:30 localhost hald[5045]: 21:16:30.228 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_SM_000022272228_0_2 but all addons are already ready!
Jun 11 21:16:30 localhost hald[5045]: 21:16:30.229 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_model_DVD_RW_AD_7173S but all addons are already ready!
Jun 11 21:16:30 localhost hald[5045]: 21:16:30.229 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_SD_MMC_000022272228_0_3 but all addons are already ready!
Jun 11 21:16:30 localhost hald[5045]: 21:16:30.229 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_MS_000022272228_0_1 but all addons are already ready!
Jun 11 21:16:30 localhost hald[5045]: 21:16:30.230 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_serial_Generic_Flash_HS_CF_000022272228_0_0 but all addons are already ready!
localhost ipse #
Comment 9 ipse 2009-06-11 19:38:27 UTC
(In reply to comment #7)
> Okay, I've looked at the code, and those are not fatal errors anywhere.  Your
> hal must be stopping for some other reason.  Are there by any chance core files
> in / ?
> 
> The "Cannot claim interface" error in the first post is, in face, a fatal
> error.  Is that persisting?
> 

Jun 11 22:28:46 localhost hald-addon-storage: [32262]: 22:28:46.403 [E] addon-storage.c:813: Cannot claim interface 'org.freedesktop.Hal.Device.Storage.Removable'
Jun 11 22:28:46 localhost hald-addon-storage: [32268]: 22:28:46.403 [E] addon-storage.c:813: Cannot claim interface 'org.freedesktop.Hal.Device.Storage.Removable'
Jun 11 22:28:46 localhost hald-addon-storage: [32264]: 22:28:46.403 [E] addon-storage.c:813: Cannot claim interface 'org.freedesktop.Hal.Device.Storage.Removable'
Jun 11 22:28:46 localhost hald-addon-storage: [32263]: 22:28:46.404 [E] addon-storage.c:813: Cannot claim interface 'org.freedesktop.Hal.Device.Storage.Removable'
Comment 10 Doug Goldstein (RETIRED) gentoo-dev 2009-06-11 19:58:24 UTC
First thing's first. Stop running it via the init script.

hald --verbose=yes --daemon=no --retain-privileges
Comment 11 ipse 2009-06-11 20:44:30 UTC
Created attachment 194289 [details]
STDERR output

hald --verbose=yes --daemon=no --retain-privileges 
STDERR output
Comment 12 ipse 2009-06-11 20:45:47 UTC
Created attachment 194290 [details]
STDERR output

hald --verbose=yes --daemon=no --retain-privileges 
STDERR output
Comment 13 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-06-12 01:51:56 UTC
Comment on attachment 194289 [details]
STDERR output

The file was attached as the wrong type - look at the following attachment
Comment 14 Conrad Kostecki gentoo-dev 2009-06-29 15:36:34 UTC
Hi!
I have also the same problem here :(
My hal runner just dies...
Comment 15 Conrad Kostecki gentoo-dev 2009-07-17 17:45:11 UTC
Any news on this?
Comment 16 ipse 2009-07-17 19:17:13 UTC
(In reply to comment #15)
> Any news on this?
> 

Unfortunately, no
For you too it is installed cardreader?
Comment 17 Conrad Kostecki gentoo-dev 2009-07-17 19:51:40 UTC
Created attachment 198355 [details]
hald.log

Yep, I've an internal card reader...

I am also attaching my hald.log...
Comment 18 Conrad Kostecki gentoo-dev 2009-07-18 20:50:53 UTC
Created attachment 198431 [details]
hald-strace2.txt

Attaching my strace hald output...
Comment 19 Conrad Kostecki gentoo-dev 2009-07-24 10:59:28 UTC
I've some news!
The problem is GCC 4.4!

When I compile my whole system with GCC 4.3.x, HAL works perfectly fine.
When I use GCC 4.4, hald does not start and fails.

But I don't know, which packages causes this. Hal itself can be compiles with gcc 4.4, if the system is compiled with gcc 4.3. so where could be the problem? o.O
Comment 20 Mark Anders 2009-07-25 20:30:24 UTC
(In reply to comment #19)
> I've some news!
> The problem is GCC 4.4!
> 
> When I compile my whole system with GCC 4.3.x, HAL works perfectly fine.
> When I use GCC 4.4, hald does not start and fails.
> 
> But I don't know, which packages causes this. Hal itself can be compiles with
> gcc 4.4, if the system is compiled with gcc 4.3. so where could be the problem?
> o.O
> 

I was getting a similar error - I recompiled glib-2.20.4 with default CFLAGS using gcc 4.4.1 and that fixed it.
Comment 21 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-07-26 02:14:48 UTC
You absolutely cannot compile glib (or gtk+) with any even remotely exotic CFLAGS.  Anything beyond -O2 (and even -Os sometimes) will cause you problem.  This has been known for years, and upstream has no interest in trying to fix it.

I thought we were stripping flags in gtk+ and glib already?
Comment 22 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-07-26 16:03:23 UTC
(In reply to comment #21)
> You absolutely cannot compile glib (or gtk+) with any even remotely exotic
> CFLAGS.  Anything beyond -O2 (and even -Os sometimes) will cause you problem. 
> This has been known for years, and upstream has no interest in trying to fix
> it.
> 
> I thought we were stripping flags in gtk+ and glib already?
> 

We strip flags in gtk+, but not in glib. In glib, we replace -O3 with -O2 on ppc64, and hardened. Maybe we should make that unconditional...

@reporter: Can you confirm that building HAL with -O2 instead of -O3 fixes the problem?
Comment 23 Rémi Cardona gentoo-dev 2009-07-26 17:31:19 UTC
glib should probably be have CFLAGS stripped too. With GSlice and all...
Comment 24 marbacz 2009-09-26 20:29:40 UTC
Building glib with -O2 fixed HAL for me. HAL itself works fine with -O3. I'm using gcc-4.4.1 on ~amd64.
Comment 25 Peter Gustafson 2009-09-30 20:59:52 UTC
I'll add another occurrence.  glib with -O2 fixed HAL for me.  gcc-4.4.1 on ~amd64.
Comment 26 David Abbott gentoo-dev 2009-10-06 17:43:44 UTC
*** Bug 285835 has been marked as a duplicate of this bug. ***
Comment 27 Gürkan 2009-11-03 16:44:32 UTC
i can confirm too, emerging glib-2.22.2 with -O2 fixed hal crashes..
hal version 0.5.13-r2, ~amd64
thanks for the tip btw..
Comment 28 Vladimir 2009-11-08 11:19:49 UTC
  Hello, everyone!
  I must say, that in my case reemerging of dev-libs/glib-2.20.5 with "-O2" flag instead of "-O3" does nothing. The problem remains.
  But I must also notice, that /etc/init.d/hald doesn't start at boot time, but it perfectly starts after I log-in as root and give the command "/etc/init.d/hald start" by hand.
  I don't understand the mechanism of such behaviour. I always thought that if the program works - it doesn't matter when to start it: as a boot script or immediately after root logins. But maybe I'm wrong.
  By the way, I am using gcc-4.4.2 on ~amd64 machine.
  P.S. I am not sure I'm talking about the same bug you guys are talking about. But I guess, this one is the most similar to mine.

  Thanks for any help!
Comment 29 gpiez 2010-01-07 16:26:30 UTC
I was bitten by this bug, too. Reemering glib with pure "-O2" fixed everything. CFLAGS at glib should really be filtered.

Fixing this bug was easy, not so finding it: From an hald error to dbus to glib is a long way^^
Comment 30 gpiez 2010-01-07 16:48:20 UTC
Edit: On x86_64, CFLAGS before were "-O3 -march=core2", gcc was 4.4.1.
Comment 31 Samuli Suominen (RETIRED) gentoo-dev 2011-09-18 09:29:02 UTC
sys-apps/hal was removed from tree wrt #313389, closing as OBSOLETE