Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 273031 - gnome-base/orbit-2.14.16 parallel make failure
Summary: gnome-base/orbit-2.14.16 parallel make failure
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High QA with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords: Inclusion, PATCH, UPSTREAM
Depends on:
Blocks:
 
Reported: 2009-06-07 13:12 UTC by craven
Modified: 2014-07-08 07:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log for failing build (build.log,148.48 KB, text/plain)
2009-06-07 13:14 UTC, craven
Details
current build.log (build.log,152.30 KB, text/plain)
2010-09-01 21:33 UTC, James Broadhead
Details
emerge --info (file,4.46 KB, text/plain)
2010-09-01 21:35 UTC, James Broadhead
Details

Note You need to log in before you can comment on or make changes to this bug.
Description craven 2009-06-07 13:12:00 UTC
When using several make jobs to build gnome-base/orbit-2.14.16, the application fails to link, as the library libname-server-2.a is not yet present when needed.

Reproducible: Always

Steps to Reproduce:
1. set MAKEOPTS="-j3 -l 1.5" in /etc/make.conf
2. run emerge -1 =gnome-base/orbit-2.14.16
3. wait for build to fail




setting MAKEOPTS="-j1 -l 1.5" fixes the problem. I suggest to filter the MAKEOPTS in the ebuild or to patch the Makefile to correctly include all dependencies.
Comment 1 craven 2009-06-07 13:14:29 UTC
Created attachment 193798 [details]
build log for failing build
Comment 2 Malte Starostik 2010-01-13 11:43:53 UTC
Same error also applies to gnome-base/orbit-2.14.17
Comment 3 David J Cozatt 2010-04-19 02:36:45 UTC
also encoubtered this and64 the -j1 got by the issue
Comment 4 Andreas Philipp 2010-05-05 13:28:53 UTC
Same error also applies to gnome-base/orbit-2.14.18 on amd64


Comment 5 James Broadhead 2010-08-31 12:35:33 UTC
(In reply to comment #4)
> Same error also applies to gnome-base/orbit-2.14.18 on amd64
> 

Confirmed.
Comment 6 Pacho Ramos gentoo-dev 2010-09-01 19:27:38 UTC
Are you able to reproduce this? I have never suffered it. Please also provide a new build.log in that case
Comment 7 James Broadhead 2010-09-01 21:33:56 UTC
Created attachment 245684 [details]
current build.log
Comment 8 James Broadhead 2010-09-01 21:35:16 UTC
Created attachment 245685 [details]
emerge --info
Comment 9 Pacho Ramos gentoo-dev 2010-09-02 09:18:23 UTC
Can you try disabling ccache?
Comment 10 James Broadhead 2010-09-07 13:27:34 UTC
(In reply to comment #9)
> Can you try disabling ccache?

Sorry, should have tested that. Same build failure without ccache
Comment 11 James Broadhead 2010-09-07 13:38:34 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Can you try disabling ccache?
> Sorry, should have tested that. Same build failure without ccache

Incidentally, this only affects one of my two amd64 machines; on the other, it works with -j5 (on the non-building machine, only -j1 works) 

Comment 12 Pacho Ramos gentoo-dev 2010-09-07 13:42:22 UTC
+  07 Sep 2010; Pacho Ramos <pacho@gentoo.org> orbit-2.14.18.ebuild:
+  Set MAKEOPTS to -j1 since parallel build fails from time to time, bug
+  #273031
Comment 13 Pacho Ramos gentoo-dev 2011-06-19 10:08:39 UTC
As this is no longer developer by upstream, a patch for fixing this would be nice
Comment 14 Michael Haubenwallner gentoo-dev 2014-06-25 13:22:50 UTC
This patch seems to fix it:

--- src/services/name/Makefile.am
+++ src/services/name/Makefile.am
@@ -68,7 +68,7 @@ libname_server_2_a_DEPENDENCIES = $(DEPS) CosNaming.h
 
 orbit_name_server_2_SOURCES = boot.c
 orbit_name_server_2_LDFLAGS = $(FLAGS)
-orbit_name_server_2_DEPENDENCIES = $(DEPS) CosNaming.h
+orbit_name_server_2_DEPENDENCIES = $(DEPS) CosNaming.h libname-server-2.a
 orbit_name_server_2_LDADD = libname-server-2.a $(LDADDS)
 
 $(libname_server_2_a_OBJECTS) $(name_client_2_OBJECTS) $(orbit_name_server_2_OBJECTS) : CosNaming.h
Comment 15 Pacho Ramos gentoo-dev 2014-06-25 19:41:58 UTC
I am unsure if we should simply kill static-libs and always build with --disable-static :/
Comment 16 Michael Haubenwallner gentoo-dev 2014-06-26 10:31:17 UTC
libname-server-2.a is not built with libtool, so --disable-static has no influence here.
Comment 17 Michael Haubenwallner gentoo-dev 2014-07-08 07:17:48 UTC
Fixed in orbit-2.14.19-r4.