Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272770 - dev-util/synopsis: fails to build with gcc-4.4
Summary: dev-util/synopsis: fails to build with gcc-4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-06-05 13:01 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-20 16:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (synopsis-0.10:20090605-105941.log,40.79 KB, text/plain)
2009-06-05 13:02 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-05 13:01:13 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore

P.S.: this is my third bug for this package, maybe we should just reap it out?
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-05 13:02:21 UTC
Created attachment 193627 [details]
Build log
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2009-06-09 06:32:55 UTC
looks like gcc-4.4, not glibc-2.10.
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2009-06-09 06:33:37 UTC
/var/tmp/portage/dev-util/synopsis-0.10/work/synopsis-0.10/src/Synopsis/PTree/Encoding.hh: In static member function 'static long unsigned int Synopsis::PTree::Encoding::char_traits::eof()':
/var/tmp/portage/dev-util/synopsis-0.10/work/synopsis-0.10/src/Synopsis/PTree/Encoding.hh:93: error: 'EOF' was not declared in this scope
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-09 09:49:31 UTC
Yes good call Ryan!
Comment 5 Samuli Suominen gentoo-dev 2009-06-20 16:18:42 UTC
(In reply to comment #0)
> P.S.: this is my third bug for this package, maybe we should just reap it out?

Was.. there's only the possible usage of system ombiORB left. Fixed others, including this one in 0.12.