Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272732 - media-sound/lltag-0.14.2 man page contains some command-line options in a wrong case (lower instead of upper).
Summary: media-sound/lltag-0.14.2 man page contains some command-line options in a wro...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-05 07:00 UTC by Vladimir
Modified: 2010-03-21 13:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Corrected MAN page for lltag. (lltag.1.bz2,6.41 KB, application/x-troff-man)
2009-06-05 13:38 UTC, Vladimir
Details
A patch fixing lower case letters in the man page. (lltag-0.14.2-manpage.patch,1.88 KB, patch)
2009-06-05 16:04 UTC, Vladimir
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2009-06-05 07:00:15 UTC
The media-sound/lltag-0.14.2 man page contains the description of some options is lower case while these options must be passed to program using upper case letters in a command line. 
These are the options mentioned:
  "--artist" instead of "--ARTIST"
  "--title" instead of "--TITLE"
  "--album" instead of "--ALBUM"
  "--number" instead of "--NUMBER"
  "--genre" instead of "--GENRE"
  "--date" instead of "--DATE"
  "--comment" instead of "--COMMENT"

Reproducible: Always

Steps to Reproduce:
1. emerge media-sound/lltag-0.14.2
2. run "man lltag"
3. run "lltag --help"
4. compare.

Actual Results:  
One can easily see, that command-line options described wrong in a man page while "--help" option gives a correct information.

Expected Results:  
Man page should describe the options correctly - i.e. put the appropriate options in upper case.
Comment 1 Samuli Suominen gentoo-dev 2009-06-05 09:29:43 UTC
Feel free to provide a patch attached here, ..
Comment 2 Vladimir 2009-06-05 13:38:10 UTC
Created attachment 193631 [details]
Corrected MAN page for lltag.

(In reply to comment #1)
> Feel free to provide a patch attached here, ..
> 

Unfortunately, I cannot. I have never made any patches. Maybe it's simple, but I don't know that. The only thing I can do is to put a corrected man page here, if I may do so...
Comment 3 Samuli Suominen gentoo-dev 2009-06-05 14:54:22 UTC
I'll help you if you don't mind,

1) First you open the tarball of lltag: tar xf lltag-0.14.2.tar.bz2

2) Then you copy the lltag directory to .orig directory: cp -a lltag-0.14.2 lltag-0.14.2.orig

3) Then you switch to the original directory you just extracted: cd lltag-0.14.2

4) Then you edit what you want from the directory, like the manpage with your favourite editor..

5) Then you move away from the directory: cd ..

6) Then you do the patch: diff -ur lltag-0.14.2.orig lltag-0.14.2 > /tmp/lltag-0.14.2-manpage.patch

Now you have lltag-0.14.2-manpage.patch saved in /tmp. :-)

The -u means it'll be unified diff and the -r means it'll be recursive (take directories into account)
Comment 4 Vladimir 2009-06-05 16:04:58 UTC
Created attachment 193640 [details, diff]
A patch fixing lower case letters in the man page.

(In reply to comment #3)
Thanks a lot for you instructions! :)
I did everything just like you wrote and I hope that this patch will be useful. :)
Comment 5 Samuli Suominen gentoo-dev 2009-06-05 16:28:42 UTC
+  05 Jun 2009; Samuli Suominen <ssuominen@gentoo.org> lltag-0.14.2.ebuild,
+  +files/lltag-0.14.2-manpage.patch:
+  Apply a manpage patch wrt #272732, thanks to Vladimir <v_2e at ukr.net>.


Thanks, good job :)

Applied without revbump cause it's so minor..
Comment 6 Brice Goglin 2009-06-11 11:04:52 UTC
Please forward your patches upstream next time.
I applied this one to the upstream lltag repo.

thanks,
Brice (upstream lltag maintainer)
Comment 7 Vladimir 2009-06-11 20:44:59 UTC
(In reply to comment #6)
> Please forward your patches upstream next time.
> I applied this one to the upstream lltag repo.
> 
> thanks,
> Brice (upstream lltag maintainer)
> 
  I'd like to, but unfortunately, I don't know how to do that. In fact, I'm not quite sure what "upstream" means. I am a kind of newbie here. But I really want to help and to be useful.
  Would somebody explain to me, what does this mean and how can I "forward my patches upstream"?
  Thanks in advacne!
Comment 8 Brice Goglin 2010-03-20 23:29:56 UTC
Vladimir, "upstream" is where the actual software is developed, contrary to "downstream" which is where it is packaged in distributions. So "forward your patches upstream" means "send them to the actual llgal maintainer", which is the llgal-devel mailing list (see the homepage).

Brice
Comment 9 Vladimir 2010-03-21 13:20:17 UTC
  Hello!
(In reply to comment #8)
> Vladimir, "upstream" is where the actual software is developed, contrary to
> "downstream" which is where it is packaged in distributions. So "forward your
> patches upstream" means "send them to the actual llgal maintainer", which is
> the llgal-devel mailing list (see the homepage).
> 
> Brice
> 
  Thank you for the explanation. I'll do that next time if I encounter any lltag bugs.
  And what about this one? It seems there is no need to send this patch "upstream". Or am I wrong?
Comment 10 Samuli Suominen gentoo-dev 2010-03-21 13:47:01 UTC
(In reply to comment #6)
> Please forward your patches upstream next time.
> I applied this one to the upstream lltag repo.
> 
> thanks,
> Brice (upstream lltag maintainer)
> 

Yeah, we *try* to do that, sometimes the workflow is so overwhelming something slips through... this was one of those cases, sorry

(In reply to comment #9)
>   And what about this one? It seems there is no need to send this patch
> "upstream". Or am I wrong?

Not anymore since the upstream author grabbed the patch from here.