Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272705 - net-misc/omniORB: fails to build with glibc-2.10
Summary: net-misc/omniORB: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Vlastimil Babka (Caster) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-04 22:36 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-20 15:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (omniORB-4.1.3:20090604-220221.log,13.11 KB, text/plain)
2009-06-04 22:37 UTC, Diego Elio Pettenò (RETIRED)
Details
Patch allowing net-misc/omniORB-4.1.3 to build against glibc 2.10 (omniORB-4.1.3-glibc210.patch,3.07 KB, patch)
2009-06-11 15:37 UTC, Víctor Ostorga (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 22:36:51 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 22:37:43 UTC
Created attachment 193581 [details]
Build log
Comment 2 Víctor Ostorga (RETIRED) gentoo-dev 2009-06-11 15:37:59 UTC
Created attachment 194259 [details, diff]
Patch allowing net-misc/omniORB-4.1.3 to build against glibc 2.10

Fixes getline definition and non POSIX EOF in getopt()
Comment 3 Víctor Ostorga (RETIRED) gentoo-dev 2009-06-11 15:42:05 UTC
Also omniORB-4.0.5 and omniORB-4.1.2 have the same issue
Comment 4 Samuli Suominen gentoo-dev 2009-06-20 15:37:29 UTC
Using commit message:
------------------------------------------------------------------------------
Fix building with GLIBC 2.10+ wrt #272705, thanks to Diego E. Pettenò and Victor Ostorga.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
------------------------------------------------------------------------------