Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272678 - kde-base/kopete-3.5.10-r4 compilation failer
Summary: kde-base/kopete-3.5.10-r4 compilation failer
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-04 18:56 UTC by Andreis Vinogradovs ( slepnoga )
Modified: 2010-07-15 12:51 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,721.15 KB, text/plain)
2009-06-04 18:57 UTC, Andreis Vinogradovs ( slepnoga )
Details
build.log MAKEOPTS=-j1 (build.log,726.06 KB, text/plain)
2009-06-05 10:26 UTC, Andreis Vinogradovs ( slepnoga )
Details
build.log (build.log,723.89 KB, text/plain)
2009-06-05 11:59 UTC, Andreis Vinogradovs ( slepnoga )
Details
environment file (environment,184.97 KB, text/plain)
2009-06-05 12:01 UTC, Andreis Vinogradovs ( slepnoga )
Details
build.log (build.log,91.41 KB, text/plain)
2009-06-12 10:01 UTC, DICR_GENTOO
Details
build environment (env.log,186.46 KB, text/plain)
2009-06-12 10:02 UTC, DICR_GENTOO
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreis Vinogradovs ( slepnoga ) 2009-06-04 18:56:17 UTC
kde-base/kopete-3.5.10-r4  compilation failer in error:
No rule to make target `../../../kopete/protocols/msn/libkopete_msn_shared.la', needed by `kopete_netmeeting.la'

Reproducible: Always

Steps to Reproduce:
1.unmask kopete:3.5 and it depend
2.emerge -av kopete
3.

Actual Results:  
fail


my emerge info:
Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.30-rc7-mini-test-GEM-002-usbip i686)
=================================================================
System uname: Linux-2.6.30-rc7-mini-test-GEM-002-usbip-i686-Intel-R-_Atom-TM-_CPU_330_@_1.60GHz-with-glibc2.0
Timestamp of tree: Thu, 04 Jun 2009 06:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native       -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe "
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersync"
GENTOO_MIRRORS="http://gentoo.tups.lv/source"
LANG=""
LC_ALL="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru lv en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="lzma"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/fds /usr/portage/local/layman/sunrise /usr/portage/local/my"
SYNC="rsync://10.0.0.1/gentoo-portage"
USE="X aac acl acpi alsa amr arts avascript bash-completion berkdb bluetooth branding bzip2 caps cleartype cli cracklib crypt cups dbus dga djvu dmx dri dvd encode fam fbcon ffmpeg flac fontconfig fortran gdbm ggi gif gmp gnutls gpm gs gsm gstreamer hal iconv imagemagick ipv6 isdnlog jbig jpeg jpeg2k kde kerberos kqemu lcms ldap lm_sensors lvm midi mikmod mmap mmx mmxext mng mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg openexr opengl openmp pam parted pch pcre perl png ppds pppd profile python qemu qt3 qt3support qt4 rdesktop readline reflection rle samba sasl session speex spell spl sqlite sqlite3 sse sse2 ssl ssse3 svg symlink sysfs tcpd theora threads tiff truetype unicode usb vcd vim-syntax vorbis wavpack webkit x264 x86 xattr xcb xcomposite xine xinerama xinetd xml xorg xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="ncurses text" LINGUAS="ru lv en" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andreis Vinogradovs ( slepnoga ) 2009-06-04 18:57:20 UTC
Created attachment 193570 [details]
build.log

build.log
Comment 2 Andreis Vinogradovs ( slepnoga ) 2009-06-04 18:59:10 UTC
Yes,I`m run revdep-rebuild and lafilefixer before before compilation
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-04 19:18:01 UTC
could you please try with MAKEOPTS="-j1" ? thanks
Comment 4 Andreis Vinogradovs ( slepnoga ) 2009-06-05 10:26:13 UTC
Created attachment 193614 [details]
build.log MAKEOPTS=-j1

 MAKEOPTS="-j1" build log, compile failed
Comment 5 Andreis Vinogradovs ( slepnoga ) 2009-06-05 10:28:42 UTC
Comment on attachment 193614 [details]
build.log MAKEOPTS=-j1

Sorry, not english lesson
Comment 6 Andreis Vinogradovs ( slepnoga ) 2009-06-05 11:59:46 UTC
Created attachment 193621 [details]
build.log

English build.log
Comment 7 Andreis Vinogradovs ( slepnoga ) 2009-06-05 12:00:23 UTC
Comment on attachment 193621 [details]
build.log

MAKEOPTS="-j1"
Comment 8 Andreis Vinogradovs ( slepnoga ) 2009-06-05 12:01:28 UTC
Created attachment 193623 [details]
environment file

environment file
Comment 9 Remy Blank 2009-06-07 17:36:12 UTC
Same issue here. Setting USE="-netmeeting" allows the build to complete.
Comment 10 Andreis Vinogradovs ( slepnoga ) 2009-06-08 19:40:07 UTC
Thanks, it`s works for me in USE="-netmeeting"
I have recompile kopete witch USE="netmeeting"
This is circular dependencis ?
Comment 11 Denilson Sá Maia 2009-06-09 17:32:56 UTC
Now kopete-3.5.10-r4 is marked stable, could someone please take a look at this bug? Version 3.5.9 didn't have this compilation issue.

As I understand, the netmeeting plugin has been removed from upstream and is not supported anymore.
http://bugs.kde.org/show_bug.cgi?id=142465
kopete-4* ebuilds also don't have netmeeting plugin.

I'm suggesting to drop the netmeeting useflag from kopete-3.
Comment 12 Andreis Vinogradovs ( slepnoga ) 2009-06-09 21:57:55 UTC
latest stable kopete also compile fails witch USE="netmeeting".
please, drop USE "netmeeting" and close this bug.
Comment 13 DICR_GENTOO 2009-06-12 09:57:16 UTC
I can't emerge kopete too. Without "netmeeting" flag, I'm afraid...


gentoo-t500 ~ # emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29.4 i686)
=================================================================
System uname: Linux-2.6.29.4-i686-Intel-R-_Core-TM-2_Duo_CPU_P8400_@_2.26GHz-with-glibc2.0
Timestamp of tree: Fri, 12 Jun 2009 08:45:02 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirror.dkm.cz/pub/gentoo/ http://gentoo.supp.name/ http://distfiles.gentoo.org"
LANG="cs_CZ.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="cs en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amr berkdb bluetooth branding bzip2 cli cracklib crypt cups dbus dri dv dvd encode ffmpeg flac fortran gdbm hal iconv icu ieee1394 isdnlog kde lame laptop mad midi mp3 mudflap musepack ncurses nls nptl nptlonly ogg pam pcre pppd qt3 readline reflection session spl ssl ssse3 svg sysfs syslog tcpd theora unicode usb vorbis win32codecs x264 x86 xorg xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en" USERLAND="GNU" VIDEO_CARDS="intel vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 14 DICR_GENTOO 2009-06-12 10:01:43 UTC
Created attachment 194379 [details]
build.log
Comment 15 DICR_GENTOO 2009-06-12 10:02:43 UTC
Created attachment 194380 [details]
build environment
Comment 16 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-12 11:46:23 UTC
FYI USE="netmeeting -msn" caused this, but dropping the netmeeting flag was also tempting :)
Fixed, thanks
Comment 17 Paulo da Silva 2009-06-12 18:28:37 UTC
(In reply to comment #13)
> I can't emerge kopete too. Without "netmeeting" flag, I'm afraid...
> 
I have exactly the same problem here!
Can't get kopete compiled.
Comment 18 Denilson Sá Maia 2009-06-12 19:44:33 UTC
(In reply to comment #17)
> (In reply to comment #13)
> > I can't emerge kopete too. Without "netmeeting" flag, I'm afraid...
> > 
> I have exactly the same problem here!
> Can't get kopete compiled.

Run "emerge --sync" and try again. The 'netmeeting' useflag has been dropped a few hours ago (as per comment #16).
Comment 19 Gordon Malm (RETIRED) gentoo-dev 2009-06-13 00:17:07 UTC
http://sources.gentoo.org/viewcvs.py/gentoo-x86/kde-base/kopete/kopete-3.5.10-r4.ebuild?r1=1.7&r2=1.8

use netmeeting || kopete_disable plugin netmeeting

Removing that line also removed all hope of anyone working around this via USE="-netmeeting". Just need to remove the use check. ;)

The netmeeting plugin is for the MSN module, so its only natural that one requires the other.  It just happened to compile prior to us getting rid of .la's (bugs #266016, #272977). Thus:
USE="-netmeeting -msn" = valid
USE="-netmeeting msn" = valid
USE="netmeeting msn" = valid
USE="netmeeting -msn" = invalid

The fact that it is deprecated/unsupported upstream doesn't mean we have to completely disable the feature for our users.  KDE 3.5.10 is deprecated/unsupported upstream too and we don't remove it.  Kopete 3.5.10-r4 can still launch ekiga fine afaict (but I don't use netmeeting or MSN).  I see no reason for unsuspecting users to wonder where their netmeeting tie-in in Kopete went for a minor upgrade from 3.5.9->3.5.10.  As such, I've added back the netmeeting USE flag.

These are a few options for handling the invalid USE flag combination as I see it:
1. Disable/deny netmeeting support completely (as was attempted earlier).
2. Check for the invalid USE flag combination and fail the ebuild.
3. Silently disable netmeeting if USE="msn" is not enabled.
4. Silently enable MSN module if USE="netmeeting" is enabled.
5. Just let USE="msn" control it all (USE="msn" you get it all, w/o you get nothing).

I've elected for #2 because the netmeeting USE flag is local to kopete only and not enabled by default.  So most people will never see an error, only those who explicitly enabled "netmeeting" but not "msn".  In this case the error-out option is probably the most desireable in order to bring the users' attention to the oversight.

#3 - misleads users into thinking they're getting something they're not and then they have to investigate why.
#4 - portage will still think USE="-msn" which would be incorrect.
#5 - Not my package to make that call, but probably not a bad idea since 'netmeeting' is useless without 'msn'.
Comment 21 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-13 09:10:45 UTC
Thanks gengor
Just FYI kde-3 is open to the public, you can do whatever you want unless it works