Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 27264 - emerge: Inclusion of proper long options
Summary: emerge: Inclusion of proper long options
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-08-24 21:05 UTC by Alexander Winston
Modified: 2011-10-30 22:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for emerge itself. (emerge-long-options.patch,18.93 KB, patch)
2003-08-27 01:19 UTC, Alexander Winston
Details | Diff
Patch for emergehelp.py. (emergehelp.py-long-options.patch,93.19 KB, patch)
2003-08-27 01:20 UTC, Alexander Winston
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Winston 2003-08-24 21:05:14 UTC
Right now, emerge has awkward long options. It would be best to rewrite them so
that they are displayed in a clear, concise manner; abbreviated options are for
short options. e.g.:

--buildpkg      ->  --build-package
--buildpkgonly  ->  --build-package-only
--emptytree     ->  --empty-tree
--fetchonly     ->  --fetch-only
--getbinpkg     ->  --get-binary-package
--noconfmem     ->  --forget-configuration
--nodeps        ->  --no-dependencies
--noreplace     ->  --no-replace
--nospinner     ->  --no-spinner
--oneshot       ->  --once-only
--onlydeps      ->  --only-dependencies
--searchdesc    ->  --search-description
--skipfirst     ->  --skip-first
--upgradeonly   ->  --upgrade-only
--usepkg        ->  --use-package
--usepkgonly    ->  --use-package-only

I think everyone would agree that this change would make everything much easier
to both read and understand to outsiders and insiders to emerge alike.
Comment 1 Alexander Winston 2003-08-26 23:05:31 UTC
I was looking more for feedback
Comment 2 Alexander Winston 2003-08-26 23:05:31 UTC
I was looking more for feedback I guess Ill post a patch instead. :)
Comment 3 Alexander Winston 2003-08-27 01:19:55 UTC
Created attachment 16671 [details, diff]
Patch for emerge itself.
Comment 4 Alexander Winston 2003-08-27 01:20:31 UTC
Created attachment 16672 [details, diff]
Patch for emergehelp.py.
Comment 5 SpanKY gentoo-dev 2003-08-27 17:15:21 UTC

*** This bug has been marked as a duplicate of 2365 ***