Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272602 - media-sound/sidplay: fails to build with glibc-2.10
Summary: media-sound/sidplay: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-04 12:11 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-07-22 21:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (sidplay-2.0.9:20090604-073619.log,25.32 KB, text/plain)
2009-06-04 12:12 UTC, Diego Elio Pettenò (RETIRED)
Details
Fix compilation with glibc-2.10.1 and also remove some warnings (sidplay-glibc-2.10.patch,3.64 KB, patch)
2009-07-20 19:33 UTC, Martin Väth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 12:11:09 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 12:12:09 UTC
Created attachment 193514 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-07-19 13:20:18 UTC
# Samuli Suominen <ssuominen@gentoo.org> (19 Jul 2009)
# Doesn't compile wrt #272602. ALSA support broken wrt #98769.
# No upstream. Masked for removal.
Comment 3 Martin Väth 2009-07-20 19:33:08 UTC
Created attachment 198634 [details, diff]
Fix compilation with glibc-2.10.1 and also remove some warnings

It would be a pity to see this nice package die just because a few lines
need to be patched. The attached patch is a bit longer since it also fixes
the "obsolete conversion" warnings.

I do not know what should be wrong w.r.t. autotools - here it compiles fine
and shows no strange warnings.
Moreover, although alsa output from bug 98769 would be nice, it works fine
with oss (also with oss emulation of alsa): Also many other packages have
problems with alsa (e.g. mplayer is on my system unusable with alsa).
Comment 4 Samuli Suominen gentoo-dev 2009-07-20 19:54:33 UTC
Try to eautoreconf it for example; it's a prereq to get the ALSA bug fixed... since it modifies configure.in, IIRC.
Comment 5 Samuli Suominen gentoo-dev 2009-07-22 21:01:50 UTC
+  22 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> sidplay-2.0.9.ebuild,
+  +files/sidplay-2.0.9-gcc44.patch:
+  Fix building with glibc-2.10+ wrt #272602, thanks to Martin Väth and
+  Diego E. Pettenò.

ALSA support fixing left.