Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 2726 - emerge fails with !!! Invalid token (not "=")
Summary: emerge fails with !!! Invalid token (not "=")
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Daniel Robbins (RETIRED)
Depends on:
Reported: 2002-05-14 11:01 UTC by Mark Bainter
Modified: 2011-10-30 22:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mark Bainter 2002-05-14 11:01:07 UTC
I've received numerous good suggestions from the list on this problem.  However,
none of them have panned out into a fix.  To date, I have:

1) Picked through make.conf and make.globals, looking for stray or missing "'s.
2) Compared make.conf and make.globals to the ones in the portage package
3) sourced the make.conf and make.globals files to check for shell errors
4) Followed the directions in README.RESCUE for portage, and installed the
   portage rescue package.  (to no effect)
5) Pulled down a CVS copy of hoping the "blank USE_ORDER" fix was
   what I was looking for.  

Note that it really doesn't matter what you try to emerge, they all give
the same response.  Even if it's not a package (ala emerge rsync)

Some other potentially relevant information.  When I tried to emerge rsync
the first time it failed with the code 10 error.  Before checking the 
mailing list my first act was to try updating rsync.  I did an emerge
net-misc/rsync.  When that didn't work I fixed my SYNC= and tried again.
I got most of the way through but then it hung up on me, and since then I
haven't been able to emerge anything.

Since I posted about this on the user and then later the dev lists, I've
had one other person confirm that after updating rsync, he has run into
the same problem.  I'm going to try to return to the orginal 1.1 rsync 
package in the near future, but I don't expect to have that fix the 
problem either.

# emerge portage                                                               
!!! Invalid token (not "=")                                                    
Traceback (most recent call last):                                             
  File "/usr/bin/emerge", line 6, in ?                                         
    import output                                                              
  File "/usr/lib/python2.2/site-packages/", line 4, in ?              
    import portage;                                                            
  File "/usr/lib/python2.2/site-packages/", line 3331, in ?          
  File "/usr/lib/python2.2/site-packages/", line 2461, in __init__   
  File "/usr/lib/python2.2/site-packages/", line 678, in __getitem__ 
  File "/usr/lib/python2.2/site-packages/", line 664, in populate    
  File "/usr/lib/python2.2/site-packages/", line 685, in __getitem__ 
    if x.has_key(mykey):                                                       
AttributeError: 'NoneType' object has no attribute 'has_key'
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-06-27 23:22:26 UTC
You need to update your make.globals.