Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272594 - sys-devel/binutils-2.19.1-r1: fails tests phase with glibc-2.10
Summary: sys-devel/binutils-2.19.1-r1: fails tests phase with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-04 12:04 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-06 16:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (binutils-2.19.1-r1:20090604-034344.log,388.79 KB, text/plain)
2009-06-04 12:05 UTC, Diego Elio Pettenò (RETIRED)
Details
Rename getline to get_line to avoid collision with >=glibc-2.10 (binutils-2.19.1-getline.patch,1.04 KB, patch)
2009-08-12 00:05 UTC, Samuli Suominen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 12:04:31 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 12:05:18 UTC
Created attachment 193505 [details]
Build log
Comment 2 SpanKY gentoo-dev 2009-06-04 19:26:54 UTC
except your build log doesnt show any failures
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 19:42:37 UTC
Except this, you mean?

WARNING: could not find `runtest'
make[4]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/ld'
make[3]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/ld'
make[2]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/ld'
make[2]: Entering directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/libiberty'
make[3]: Entering directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/libiberty/testsuite'
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -O2 -pipe -I.. -I/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/libiberty/testsuite/../../include  -o test-demangle \
		/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/libiberty/testsuite/test-demangle.c ../libiberty.a
/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/binutils-2.19.1/libiberty/testsuite/test-demangle.c:49: error: conflicting types for 'getline'
/usr/include/stdio.h:651: note: previous declaration of 'getline' was here
make[3]: *** [test-demangle] Error 1
make[3]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/libiberty/testsuite'
make[2]: *** [check-subdir] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build/libiberty'
make[1]: *** [check-libiberty] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/binutils-2.19.1-r1/work/build'
make: *** [do-check] Error 2
 [31;01m*[0m 
 [31;01m*[0m ERROR: sys-devel/binutils-2.19.1-r1 failed.
 [31;01m*[0m Call stack:
 [31;01m*[0m               ebuild.sh, line   49:  Called src_test
 [31;01m*[0m             environment, line 3351:  Called toolchain-binutils_src_test
 [31;01m*[0m             environment, line 4063:  Called die
 [31;01m*[0m The specific snippet of code:
 [31;01m*[0m       make check || die "check failed :("
 [31;01m*[0m  The die message:
 [31;01m*[0m   check failed :(
 [31;01m*[0m 
 [31;01m*[0m If you need support, post the topmost build error, and the call stack if relevant.
 [31;01m*[0m A complete build log is located at '/var/log/portage/sys-devel/binutils-2.19.1-r1:20090604-034344.log'.
 [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/sys-devel/binutils-2.19.1-r1/temp/environment'.
 [31;01m*[0m 

>>> Install binutils-2.19.1-r1 into /var/tmp/portage/sys-devel/binutils-2.19.1-r1/image/ category sys-devel
make -j14 DESTDIR=/var/tmp/portage/sys-devel/binutils-2.19.1-r1/image/ tooldir=/usr/lib/binutils/i686-pc-linux-gnu/2.19.1 install 
Comment 4 SpanKY gentoo-dev 2009-06-05 03:43:34 UTC
you arent using normal package install steps.  a test failure in binutils should not end with:
>>> Completed installing binutils-2.19.1-r1 into /var/tmp/portage/sys-devel/binutils-2.19.1-r1/image/
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-05 11:54:36 UTC
FEATURES=test-fail-continue

or do you think I can afford to reject all the ebuilds failing tests when running the tinderbox?
Comment 6 Samuli Suominen gentoo-dev 2009-08-12 00:05:11 UTC
Created attachment 200973 [details, diff]
Rename getline to get_line to avoid collision with >=glibc-2.10

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39752
Comment 7 SpanKY gentoo-dev 2009-09-06 16:58:29 UTC
since patching is a losing battle (we have tons of older versions of binutils), ive added a sed to the eclass

http://sources.gentoo.org/eclass/toolchain-binutils.eclass?r1=1.84&r2=1.85