Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272578 - media-sound/phasex: fails to build with glibc-2.10
Summary: media-sound/phasex: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-04 11:59 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-05 12:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (phasex-0.11.1:20090604-032422.log,19.21 KB, text/plain)
2009-06-04 12:01 UTC, Diego Elio Pettenò (RETIRED)
Details
tries to bump ebuild to EAPI=2 while also renames the clashing float_t type (phasex-0.11.1.ebuild.patch,849 bytes, patch)
2009-07-08 21:36 UTC, Arttu Valo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 11:59:41 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-04 12:01:25 UTC
Created attachment 193501 [details]
Build log
Comment 2 Arttu Valo 2009-07-08 21:36:57 UTC
Created attachment 197265 [details, diff]
tries to bump ebuild to EAPI=2 while also renames the clashing float_t type

Only tested that this compiles with glibc210/gcc44 on ~amd64. Somebody wiser with the shell wizardry can probably conjure up a one-liner to do the same thing.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 22:34:02 UTC
Comment on attachment 197265 [details, diff]
tries to bump ebuild to EAPI=2 while also renames the clashing float_t type

At a minimum you should use proper find syntax, but it still does not look like a good idead.
Comment 4 Samuli Suominen gentoo-dev 2009-08-05 12:40:01 UTC
0.12.0_beta3 in tree ( and it builds with gcc 4.4 and glibc 2.10+ )