Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272362 - app-text/ispell-3.3.02-r1 wont compile with glibc 2.10
Summary: app-text/ispell-3.3.02-r1 wont compile with glibc 2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Spell checking utilities and dictionaries -- related bugs (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 273180 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-03 05:24 UTC by 白川間瀬流
Modified: 2009-08-06 15:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
new ebuild to include the getline-patch (ispell-3.3.02-r2.ebuild,1.68 KB, text/plain)
2009-06-04 15:58 UTC, Andreas Schäfer
Details
replaces getline() with my_getline() (getline-hack.diff,1.77 KB, patch)
2009-06-04 15:59 UTC, Andreas Schäfer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description 白川間瀬流 2009-06-03 05:24:46 UTC
>>> Compiling source in /var/tmp/portage/app-text/ispell-3.2.06-r6/work/ispell-3.2.06 ...
set +vx; \
	for var in BINDIR CC CFLAGS COUNTSUFFIX DEFDICT DEFHASH DEFLANG \
	  HASHSUFFIX INSTALL \
	  LANGUAGES LIBDIR LIBES LINT LINTFLAGS \
	  MAKE_SORTTMP MAN1DIR MAN1EXT MAN4DIR MAN4EXT MASTERHASH \
	  MSGLANG REGLIB STATSUFFIX \
	  TERMLIB YACC \
	  ; do \
	    cat config.X local.h \
	      | sed -n -e "s/^#define[ 	]*$var[ 	]*"'"'"/$var=/p" \
	      | sed -e 's/".*$/'"'/" -e "s/=/='/" \
	      | tail -n 1; \
	  done > config.sh; \
	echo 'case "$MAKE_SORTTMP" in "") \
	  SORTTMP="-e /!!SORTTMP!!/s/=.*$/=/";; *) SORTTMP=;; esac' \
	  >> config.sh
cp config.X config.h
chmod u+w config.h
echo '' >> config.h
echo '/* AUTOMATICALLY-GENERATED SYMBOLS */' >> config.h
cat local.h config.X \
	  | egrep '^#define[ 	]*SIGNAL_TYPE' \
	  | sed -e 's/TYPE[ 	]*/TYPE_STRING "/' -e 's/$/"/' -e 1q \
	  >> config.h
cat local.h config.X \
	  | egrep '^#define[ 	]*MASKTYPE' \
	  | sed -e 's/TYPE[ 	]*/TYPE_STRING "/' -e 's/$/"/' -e 1q \
	  >> config.h
+ rm -f msgs.h
+ ln languages/english/msgs.h msgs.h
+ gcc -O -c buildhash.c
buildhash.c: In Funktion »output«:
buildhash.c:256: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:269: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:276: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:292: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:299: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:317: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:320: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:327: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:347: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:379: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:382: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:385: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
buildhash.c:391: Warnung: Der Rückgabewert von »fwrite«, der mit dem Attribut warn_unused_result deklariert wurde, wird ignoriert
+ gcc -O -c hash.c
+ gcc -O -c makedent.c
+ bison -y parse.y
+ gcc -O -c y.tab.c
parse.y: In Funktion »yyparse«:
parse.y:462: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:479: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:525: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y:569: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:577: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y:591: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:610: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y:630: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:667: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:669: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bcopy«
parse.y:677: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:679: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bcopy«
parse.y:705: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:735: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:772: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bzero«
parse.y:775: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:781: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:906: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:938: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:1145: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bzero«
parse.y:1165: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bzero«
parse.y: In Funktion »kwanalyze«:
parse.y:1376: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:1382: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y: In Funktion »getqstring«:
parse.y:1423: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y: In Funktion »getrange«:
parse.y:1445: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bzero«
parse.y: In Funktion »yyopen«:
parse.y:1641: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:1647: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y: In Funktion »yyinit«:
parse.y:1689: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bcopy«
parse.y: In Funktion »addstringchar«:
parse.y:1784: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
parse.y:1834: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
parse.y:1857: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
+ mv y.tab.o parse.o
+ rm -f y.tab.c
+ gcc -O -o buildhash buildhash.o hash.o makedent.o parse.o
make[1]: Entering directory `/var/tmp/portage/app-text/ispell-3.2.06-r6/work/ispell-3.2.06'
. ./config.sh; \
	  sed -e "s@!!LIBDIR!!@$LIBDIR@" -e "s@!!DEFDICT!!@$DEFDICT@" \
	    -e "s@!!DEFHASH!!@$DEFHASH@" -e "s@!!DEFLANG!!@$DEFLANG@" \
	    -e "s@!!COUNTSUFFIX!!@$COUNTSUFFIX@g" \
	    -e "s@!!HASHSUFFIX!!@$HASHSUFFIX@g" \
	    -e "s@!!STATSUFFIX!!@$STATSUFFIX@g" \
	    $SORTTMP < findaffix.X > findaffix
make[1]: Leaving directory `/var/tmp/portage/app-text/ispell-3.2.06-r6/work/ispell-3.2.06'
chmod +x findaffix
make[1]: Entering directory `/var/tmp/portage/app-text/ispell-3.2.06-r6/work/ispell-3.2.06'
. ./config.sh; \
	  sed -e "s@!!LIBDIR!!@$LIBDIR@" -e "s@!!DEFDICT!!@$DEFDICT@" \
	    -e "s@!!DEFHASH!!@$DEFHASH@" -e "s@!!DEFLANG!!@$DEFLANG@" \
	    -e "s@!!COUNTSUFFIX!!@$COUNTSUFFIX@g" \
	    -e "s@!!HASHSUFFIX!!@$HASHSUFFIX@g" \
	    -e "s@!!STATSUFFIX!!@$STATSUFFIX@g" \
	    $SORTTMP < tryaffix.X > tryaffix
make[1]: Leaving directory `/var/tmp/portage/app-text/ispell-3.2.06-r6/work/ispell-3.2.06'
chmod +x tryaffix
+ gcc -O -c term.c
+ gcc -O -c ispell.c
+ gcc -O -c correct.c
correct.c:235: Fehler: In Konflikt stehende Typen für »getline«
/usr/include/stdio.h:651: Fehler: Vorherige Deklaration von »getline« war hier
correct.c: In Funktion »checkfile«:
correct.c:317: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
correct.c:350: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
correct.c: In Funktion »correct«:
correct.c:402: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
correct.c:615: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
correct.c: In Funktion »inserttoken«:
correct.c:798: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
correct.c: In Funktion »insert«:
correct.c:944: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
correct.c:945: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
correct.c: In Funktion »save_root_cap«:
correct.c:1442: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »bcopy«
correct.c: In Funktion »askmode«:
correct.c:1584: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcpy«
correct.c:1592: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strlen«
correct.c: In Funktion »lookharder«:
correct.c:1796: Warnung: Unverträgliche implizite Deklaration der eingebauten Funktion »strcat«
make: *** [correct.o] Fehler 1

Reproducible: Always

Steps to Reproduce:
Comment 1 Sebastian Luther (few) 2009-06-03 19:02:07 UTC
@reporter: for your next bug report: Please use LC_ALL=C emerge ... to get english error messages and attach emerge --info.

@maintainer: correct.c:235: Fehler: In Konflikt stehende Typen für »getline«

The usual getline thing...
Comment 2 Andreas Schäfer 2009-06-04 15:58:20 UTC
Created attachment 193538 [details]
new ebuild to include the getline-patch
Comment 3 Andreas Schäfer 2009-06-04 15:59:09 UTC
Created attachment 193540 [details, diff]
replaces getline() with my_getline()
Comment 4 Andreas Schäfer 2009-06-04 15:59:48 UTC
the new patch works fine for me, hope it helps you, too :-)
Comment 5 白川間瀬流 2009-06-05 03:58:42 UTC
When does this get into an overlay or portage tree?
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2009-06-10 17:50:48 UTC
*** Bug 273180 has been marked as a duplicate of this bug. ***
Comment 7 白川間瀬流 2009-06-27 15:24:12 UTC
>>> Emerging (1 of 1) app-text/ispell-3.3.02-r99 from finnish
 * ispell-3.3.02.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                               [ ok ]
 * ispell-3.3.02-gentoo-0.2.diff.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                  [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                [ ok ]
>>> Unpacking source...
>>> Unpacking ispell-3.3.02-gentoo-0.2.diff.bz2 to /var/tmp/portage/app-text/ispell-3.3.02-r99/work
>>> Unpacking ispell-3.3.02.tar.gz to /var/tmp/portage/app-text/ispell-3.3.02-r99/work
 * Applying ispell-3.3.02-gentoo-0.2.diff ...                                                                                                          [ ok ]
>>> Source unpacked in /var/tmp/portage/app-text/ispell-3.3.02-r99/work
>>> Compiling source in /var/tmp/portage/app-text/ispell-3.3.02-r99/work/ispell-3.3.02 ...
make -j1 config.sh 
set +vx; \
	MASTERHASH=`cat config.X local.h \
	  | sed -n -e \
	    's/^#define[ 	]*LANGUAGES[ 	][^}]*HASHFILES=\([^,}]*\).*$/\1/p' \
	  | sed -n -e '$p'`; \
	HASHSUFFIX=`cat config.X local.h \
	  | sed -n -e \
	    's/^#define[ 	]*HASHSUFFIX[ 	]*"\(.*\)"/\1/p' \
	  | sed -n -e '$p'`; \
	case "$MASTERHASH" in \
	    american*|british*) DEFHASH="english$HASHSUFFIX";; \
	    *) DEFHASH="$MASTERHASH";; \
	esac; \
	DEFLANG=`expr "$DEFHASH" : '\(.*\)\..*$'`.aff; \
	echo "/* This file is generated by the Makefile.  Don't edit it! */" \
	  > defhash.h; \
	echo '' >> defhash.h; \
	echo '#ifndef MASTERHASH' >> defhash.h; \
	echo '#define MASTERHASH "'"$MASTERHASH"'"' >> defhash.h; \
	echo '#endif' >> defhash.h; \
	echo '#ifndef DEFHASH' >> defhash.h; \
	echo '#define DEFHASH "'"$DEFHASH"'"' >> defhash.h; \
	echo '#endif' >> defhash.h; \
	echo '#ifndef DEFLANG' >> defhash.h; \
	echo '#define DEFLANG "'"$DEFLANG"'"' >> defhash.h; \
	echo '#endif' >> defhash.h
set +vx; \
	for var in BAKEXT BINDIR CC CFLAGS COUNTSUFFIX DEFDICT DEFHASH \
	  DEFLANG EXEEXT HASHSUFFIX INSTALL \
	  LANGUAGES LIBDIR LIBES LINK LINT LINTFLAGS LOOK_XREF \
	  MAKE_SORTTMP MAN1DIR MAN1EXT MAN45DIR MAN45EXT MAN45SECT MASTERHASH \
	  MSGLANG POUNDBANG REGLIB STATSUFFIX \
	  SPELL_XREF TERMLIB TIB_XREF WORDS YACC \
	  ; do \
	    cat config.X defhash.h local.h \
	      | sed -n -e "s/^#define[ 	]*$var[ 	]*"'"'"/$var=/p" \
	      | sed -e 's/"[^"]*$/'"'/" -e "s/=/='/" -e 's/\\"/"/g' \
	      | sed -n -e '$p'; \
	  done > config.sh; \
	echo 'case "$MAKE_SORTTMP" in "") \
	  SORTTMP="-e /!!SORTTMP!!/s/=.*$/=/";; *) SORTTMP=;; esac' \
	  >> config.sh
cp config.X config.h
chmod u+w config.h
echo '' >> config.h
echo '/* AUTOMATICALLY-GENERATED SYMBOLS */' >> config.h
cat local.h config.X \
	  | egrep '^#define[ 	]*SIGNAL_TYPE' \
	  | sed -e 's/TYPE[ 	]*/TYPE_STRING "/' -e 's/$/"/' -e 1q \
	  >> config.h
cat local.h config.X \
	  | egrep '^#define[ 	]*MASKTYPE' \
	  | sed -e 's/TYPE[ 	]*/TYPE_STRING "/' -e 's/$/"/' -e 1q \
	  >> config.h
+ rm -f msgs.h
+ ln languages/english/msgs.h msgs.h
+ gcc -O -c buildhash.c
buildhash.c: In function 'output':
buildhash.c:267: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:282: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:289: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:305: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:312: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:330: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:333: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:340: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:360: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:392: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:395: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:398: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
buildhash.c:404: warning: ignoring return value of 'fwrite', declared with attribute warn_unused_result
+ gcc -O -c hash.c
+ gcc -O -c makedent.c
+ bison -y parse.y
+ '[' -f y_tab.c ']'
+ mv y.tab.c y_tab.c
+ gcc -O -c y_tab.c
+ mv y_tab.o parse.o
+ rm -f y_tab.c
+ gcc -O -o buildhash buildhash.o hash.o makedent.o parse.o
make[1]: Entering directory `/var/tmp/portage/app-text/ispell-3.3.02-r99/work/ispell-3.3.02'
. ./config.sh; \
	  set +vx; \
	  sed \
	    -e "s@!!BAKEXT!!@$BAKEXT@g" \
	    -e "s@!!COUNTSUFFIX!!@$COUNTSUFFIX@g" \
	    -e "s@!!DEFHASH!!@$DEFHASH@" -e "s@!!DEFLANG!!@$DEFLANG@" \
	    -e "s@!!HASHSUFFIX!!@$HASHSUFFIX@g" \
	    -e "s@!!LIBDIR!!@$LIBDIR@" -e "s@!!DEFDICT!!@$DEFDICT@" \
	    -e "s@!!LOOK_XREF!!@$LOOK_XREF@g" \
	    -e "s@!!MAN45SECT!!@$MAN45SECT@g" \
	    -e "s@!!POUNDBANG!!@$POUNDBANG@g" \
	    -e "s@!!SPELL_XREF!!@$SPELL_XREF@g" \
	    -e "s@!!STATSUFFIX!!@$STATSUFFIX@g" \
	    -e "s@!!TIB_XREF!!@$TIB_XREF@g" \
	    -e "s@!!WORDS!!@$WORDS@g" \
	    $SORTTMP < findaffix.X > findaffix
make[1]: Leaving directory `/var/tmp/portage/app-text/ispell-3.3.02-r99/work/ispell-3.3.02'
chmod +x findaffix
make[1]: Entering directory `/var/tmp/portage/app-text/ispell-3.3.02-r99/work/ispell-3.3.02'
. ./config.sh; \
	  set +vx; \
	  sed \
	    -e "s@!!BAKEXT!!@$BAKEXT@g" \
	    -e "s@!!COUNTSUFFIX!!@$COUNTSUFFIX@g" \
	    -e "s@!!DEFHASH!!@$DEFHASH@" -e "s@!!DEFLANG!!@$DEFLANG@" \
	    -e "s@!!HASHSUFFIX!!@$HASHSUFFIX@g" \
	    -e "s@!!LIBDIR!!@$LIBDIR@" -e "s@!!DEFDICT!!@$DEFDICT@" \
	    -e "s@!!LOOK_XREF!!@$LOOK_XREF@g" \
	    -e "s@!!MAN45SECT!!@$MAN45SECT@g" \
	    -e "s@!!POUNDBANG!!@$POUNDBANG@g" \
	    -e "s@!!SPELL_XREF!!@$SPELL_XREF@g" \
	    -e "s@!!STATSUFFIX!!@$STATSUFFIX@g" \
	    -e "s@!!TIB_XREF!!@$TIB_XREF@g" \
	    -e "s@!!WORDS!!@$WORDS@g" \
	    $SORTTMP < tryaffix.X > tryaffix
make[1]: Leaving directory `/var/tmp/portage/app-text/ispell-3.3.02-r99/work/ispell-3.3.02'
chmod +x tryaffix
gcc -O -c term.c
+ gcc -O -c ispell.c
+ gcc -O -c correct.c
correct.c:250: error: conflicting types for 'getline'
/usr/include/stdio.h:651: error: previous declaration of 'getline' was here
make: *** [correct.o] Error 1
>>> Source compiled.
>>> Test phase [not enabled]: app-text/ispell-3.3.02-r99

>>> Install ispell-3.3.02-r99 into /var/tmp/portage/app-text/ispell-3.3.02-r99/image/ category app-text
make -j1 install 
+ gcc -O -c correct.c
correct.c:250: error: conflicting types for 'getline'
/usr/include/stdio.h:651: error: previous declaration of 'getline' was here
make: *** [correct.o] Error 1


Same error with the version of the Portage Tree (stable and unstable)
Comment 8 Samuli Suominen gentoo-dev 2009-08-06 15:31:52 UTC
fixed, thanks