Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272358 - media-tv/mythtv-0.21_p19961-r2 fails to compile with glibc-2.10
Summary: media-tv/mythtv-0.21_p19961-r2 fails to compile with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-03 04:17 UTC by Timothy Knoll
Modified: 2009-08-03 00:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
changes strchr to (char *)strchr for gcc-4.4 (gcc-4.4.patch,13.12 KB, patch)
2009-06-03 04:20 UTC, Timothy Knoll
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Knoll 2009-06-03 04:17:00 UTC
Do to the change in strchr in gcc-4.4 mythtv does not compile

Reproducible: Always

Steps to Reproduce:
1.emerge mythtv
2.
3.
Comment 1 Timothy Knoll 2009-06-03 04:20:31 UTC
Created attachment 193360 [details, diff]
changes strchr  to (char *)strchr  for gcc-4.4
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-05 12:56:52 UTC
Not GCC 4.4, it's glibc 2.10, see http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-05 12:57:35 UTC
And the patch is wrong, it should probably change the type of the variable where the return value is stored instead of casting it away.
Comment 4 Timothy Knoll 2009-06-05 13:04:10 UTC
either way works.  I chose this method solely because it should work with previous gcc/glib versions
Comment 5 Timothy Knoll 2009-06-05 13:28:57 UTC
Just because it is not the way you would have done it, does not mean its wrong.  Does it compile -- yes.  Therefore its good enough for me.

I said it was the gcc because the gcc porting guide ( http://gcc.gnu.org/gcc-4.4/porting_to.html ) mentions it.  Whether its the gcc or glibc, I don't know.  All I know is that it needs to fixed.
Comment 6 Timothy Knoll 2009-06-05 14:20:17 UTC
fixed in http://svn.mythtv.org/trac/changeset/20671
so a simple upgrade would work
Comment 7 Doug Goldstein gentoo-dev 2009-08-03 00:52:27 UTC
glibc 2.10.x and higher users should be using at least mythtv-0.21_p20877 or newer