Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272316 - ERROR: app-admin/fam-2.7.0-r4 failed. NFSFileSystem.c++:105: error: invalid conversion from 'const char*' to 'char*'
Summary: ERROR: app-admin/fam-2.7.0-r4 failed. NFSFileSystem.c++:105: error: invalid c...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-06-02 22:31 UTC by ipse
Modified: 2009-06-08 03:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch fixes a problem (fam-2.7.0-huita.patch,309 bytes, patch)
2009-06-03 16:32 UTC, ipse
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ipse 2009-06-02 22:31:24 UTC
localhost haiq # MAKEOPTS="-j1" LC_ALL=C emerge -1 app-admin/fam

...
           
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I../include -DFAM_CONF=\"/etc/fam.conf\" -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE    -march=core2 -O3 -pipe -fomit-frame-pointer -MT Log.o -MD -MP -MF .deps/Log.Tpo -c -o Log.o Log.c++                                                                  
Log.c++: In static member function 'static void Log::vfglog(const char*, __va_list_tag*)':                                                              
Log.c++:238: warning: deprecated conversion from string constant to 'char*'                                                                             
Log.c++:241: warning: deprecated conversion from string constant to 'char*'                                                                             
mv -f .deps/Log.Tpo .deps/Log.Po                                                                                                                        
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I../include -DFAM_CONF=\"/etc/fam.conf\" -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE    -march=core2 -O3 -pipe -fomit-frame-pointer -MT MxClient.o -MD -MP -MF .deps/MxClient.Tpo -c -o MxClient.o MxClient.c++                                              
mv -f .deps/MxClient.Tpo .deps/MxClient.Po                                                                                                              
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I../include -DFAM_CONF=\"/etc/fam.conf\" -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE    -march=core2 -O3 -pipe -fomit-frame-pointer -MT NFSFileSystem.o -MD -MP -MF .deps/NFSFileSystem.Tpo -c -o NFSFileSystem.o NFSFileSystem.c++                          
NFSFileSystem.c++: In constructor 'NFSFileSystem::NFSFileSystem(const mntent&)':                                                                        
NFSFileSystem.c++:105: error: invalid conversion from 'const char*' to 'char*'                                                                          
NFSFileSystem.c++:112: error: invalid conversion from 'const char*' to 'char*'                                                                          
NFSFileSystem.c++:118: error: invalid conversion from 'const char*' to 'char*'                                                                          
make[2]: *** [NFSFileSystem.o] Error 1                                                                                                                  
make[2]: Leaving directory `/var/tmp/portage/app-admin/fam-2.7.0-r4/work/fam-2.7.0/src'                                                                 
make[1]: *** [all-recursive] Error 1                                                                                                                    
make[1]: Leaving directory `/var/tmp/portage/app-admin/fam-2.7.0-r4/work/fam-2.7.0'                                                                     
make: *** [all] Error 2                                                                                                                                 
 *                                                                                                                                                      
 * ERROR: app-admin/fam-2.7.0-r4 failed.                                                                                                                
 * Call stack:                                                                                                                                          
 *               ebuild.sh, line   49:  Called src_compile                                                                                              
 *             environment, line 2769:  Called _eapi0_src_compile                                                                                       
 *               ebuild.sh, line  600:  Called _eapi2_src_compile                                                                                       
 *               ebuild.sh, line  634:  Called die                                                                                                      
 * The specific snippet of code:
 *              emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-admin/fam-2.7.0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-admin/fam-2.7.0-r4/temp/environment'.
 *

>>> Failed to emerge app-admin/fam-2.7.0-r4, Log file:

>>>  '/var/tmp/portage/app-admin/fam-2.7.0-r4/temp/build.log'

 * Messages for package app-admin/fam-2.7.0-r4:

 *
 * ERROR: app-admin/fam-2.7.0-r4 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2769:  Called _eapi0_src_compile
 *               ebuild.sh, line  600:  Called _eapi2_src_compile
 *               ebuild.sh, line  634:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-admin/fam-2.7.0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-admin/fam-2.7.0-r4/temp/environment'.

localhost haiq # emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.4.0, glibc-2.10.1-r0, 2.6.30-rc7-git4 x86_64)
=================================================================                                
System uname: Linux-2.6.30-rc7-git4-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 30 May 2009 03:20:01 +0000                                                      
app-shells/bash:     4.0_p24                                                                            
dev-java/java-config: 2.1.8                                                                             
dev-lang/python:     2.4.4-r15, 2.6.2-r1                                                                
dev-util/cmake:      2.6.3-r1                                                                           
sys-apps/baselayout: 2.0.1                                                                              
sys-apps/openrc:     0.4.3-r2                                                                           
sys-apps/sandbox:    1.9                                                                                
sys-devel/autoconf:  2.13, 2.63-r1                                                                      
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                  
sys-devel/binutils:  2.19.1-r1                                                                          
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6a                                                                             
virtual/os-headers:  2.6.29                                                                             
ACCEPT_KEYWORDS="amd64 ~x86"                                                                            
CBUILD="x86_64-pc-linux-gnu"                                                                            
CFLAGS="-march=core2 -O3 -pipe -fomit-frame-pointer"                                                    
CHOST="x86_64-pc-linux-gnu"                                                                             
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ ftp://mirror.yandex.ru/gentoo-distfiles/ http://ftp.klid.dk/ftp/gentoo/ ftp://ftp.klid.dk/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ ftp://trumpetti.atm.tut.fi/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ http://ftp.vectranet.pl/gentoo/ ftp://ftp.vectranet.pl/gentoo/ http://gentoo.prz.rzeszow.pl http://gentoo.zie.pg.gda.pl http://gentoo.po.opole.pl ftp://gentoo.po.opole.pl ftp://mirror.icis.pcz.pl/gentoo/ http://gentoo.mirror.pw.edu.pl/ http://mirror.yandex.ru/gentoo-distfiles/ "
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bluetooth bzip2 cli cracklib crypt cups dbus dri fortran gdbm gnome gpm gtk hal iconv ipv6 isdnlog midi mmx mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python qt4 readline reflection samba session spl sse sse2 ssl sysfs tcpd unicode vorbis xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Reproducible: Always
Comment 1 ipse 2009-06-03 16:32:42 UTC
Created attachment 193417 [details, diff]
patch fixes a problem

now compiles
Comment 2 Jeroen Roovers gentoo-dev 2009-06-08 03:31:13 UTC
Thanks for the patch! It's in the tree now in -r5. Seems to be GCC 4.4 related, so the -r5 revision should go stable when or before gcc-4.4.0 does.