Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272272 - net-fs/openafs: fails to build with glibc-2.10
Summary: net-fs/openafs: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefaan De Roeck (RETIRED)
URL:
Whiteboard:
Keywords:
: 273025 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-02 14:49 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-11 19:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (openafs-1.4.9:20090601-083421.log,223.28 KB, text/plain)
2009-06-02 14:49 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-02 14:49:07 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-02 14:49:36 UTC
Created attachment 193297 [details]
Build log
Comment 2 Dan Johnson 2009-06-11 01:52:48 UTC
This issue has been mentioned on an openafs mailing list, a proposed patch is here: http://www.openafs.org/pipermail/openafs-devel/2009-April/016587.html

I'm not sure what the plan is for this type of code to get merged upstream.
Comment 3 Jeroen Roovers gentoo-dev 2009-06-11 06:28:42 UTC
*** Bug 273025 has been marked as a duplicate of this bug. ***
Comment 4 Stefaan De Roeck (RETIRED) gentoo-dev 2009-06-11 19:57:46 UTC
This should be fixed in net-fs/openafs-1.4.10, in which the patch mentioned in comment #2 has been included.  
Thanks for reporting!