Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 272019 - [patch] media-gfx/inkscape-0.46-r5 does not build with sys-devel/gcc-4.4
Summary: [patch] media-gfx/inkscape-0.46-r5 does not build with sys-devel/gcc-4.4
Status: RESOLVED DUPLICATE of bug 270720
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-05-31 21:07 UTC by Bernd Buschinski
Modified: 2009-06-01 09:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to fix build (inkscape-const.diff,1.25 KB, text/plain)
2009-05-31 21:08 UTC, Bernd Buschinski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Buschinski 2009-05-31 21:07:41 UTC
emerge =inkscape-0.46-r5

fails because of

        x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I..   -I/usr/include/freetype2    -I/usr/include/libwpg-0.1 -I/usr/include/libwpd-0.8   -I/usr/include/freetype2   -I/usr/include/poppler   -I/usr/include/poppler/glib -I/usr/include/poppler -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -DPOTRACE=\"potrace\" -pthread -I/usr/include/gdkmm-2.4 -I/usr/lib64/gdkmm-2.4/include -I/usr/include/glibmm-2.4 -I/usr/lib64/glibmm-2.4/include -I/usr/include/pangomm-1.4 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/cairomm-1.0 -I/usr/include/sigc++-2.0 -I/usr/lib64/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/gtkmm-2.4 -I/usr/lib64/gtkmm-2.4/include -I/usr/include/giomm-2.4 -I/usr/lib64/giomm-2.4/include -I/usr/include/atkmm-1.6 -I/usr/include/atk-1.0 -I/usr/include/libxml2 -I/usr/include/gtkspell-2.0   -I../cxxtest    -Wall -Wformat-security -W -Wpointer-arith -Wcast-align -Wsign-compare -Woverloaded-virtual -Wswitch -D_FORTIFY_SOURCE=2 -Wno-unused-parameter -march=amdfam10 -O2 -pipe -fomit-frame-pointer -ftree-vectorize -MT print.o -MD -MP -MF $depbase.Tpo -c -o print.o print.cpp &&\
        mv -f $depbase.Tpo $depbase.Po
prefix.cpp: In function 'char* br_extract_dir(const char*)':
prefix.cpp:362: error: invalid conversion from 'const char*' to 'char*'
prefix.cpp: In function 'char* br_extract_prefix(const char*)':
prefix.cpp:398: error: invalid conversion from 'const char*' to 'char*'
make[2]: *** [prefix.o] Error 1
make[2]: *** Waiting for unfinished jobs....

with gcc-4.4

Reproducible: Always




Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.10.1-r0, 2.6.29.3 x86_64)
=================================================================                                 
System uname: Linux-2.6.29.3-x86_64-AMD_Phenom-tm-_9600_Quad-Core_Processor-with-gentoo-2.0.1     
Timestamp of tree: Sun, 31 May 2009 20:00:17 +0000                                                
ccache version 2.4 [enabled]                                                                      
app-shells/bash:     4.0_p24                                                                      
dev-java/java-config: 2.1.8                                                                       
dev-lang/python:     2.6.2-r1                                                                     
dev-util/ccache:     2.4-r8                                                                       
dev-util/cmake:      2.6.4                                                                        
sys-apps/baselayout: 2.0.1                                                                        
sys-apps/openrc:     0.4.3-r2                                                                     
sys-apps/sandbox:    1.9                                                                          
sys-devel/autoconf:  2.63-r1                                                                      
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                   
sys-devel/binutils:  2.19.1-r1                                                                    
sys-devel/gcc-config: 1.4.1                                                                       
sys-devel/libtool:   2.2.6a                                                                       
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe -fomit-frame-pointer -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=amdfam10 -O2 -pipe -fomit-frame-pointer -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en en_GB"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/beandog"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac acl acpi alias alisp alsa amd64 amr amrnb amrwb aoss aspell async audiofile avi bash-completion berkdb bitmap-fonts bl blender-game browserplugin bzip2 cairo cddb cdparanoia cdr cli connectionstatus consolekit contactnotes cracklib crypt cups curl dbus dga dia djbfft dlloader dot dri dts dtslive dv dvb dvd dvdnav dvdread enca encode evo exif expat faac faad fame ffmpeg fftw file flac fluidsynth font-server fontconfig fontforge foomaticdb fortran ftp gadu gd gdbm geoip ggi gif gimp glib glut gmp gnutls gpm graphite graphviz groupwise hal hash hdri highlight history html iconv icu id3tag ieee1394 imagemagick imlib ipod ipv6 irc isdnlog java jingle joystick jpeg jpeg2k kde kdehiddenvisibility lame latex lcms libnotify libsamplerate lm_sensors logitech-mouse lua lzma lzo mad maps matroska md5sum mhash midi mikmod mjpeg mmap mmx mmxext mng modplug moonlight mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql mysqli nas ncurses nemesi netmeeting network nfsv4 nis nowin nowlistening nptl nptlonly nsplugin nuv nvidia ogg oggvorbis openal openexr opengl openmp oscar oss otr pam pascal pch pcre pdf png pnm policykit postgres ppds pppd pth qt qt3 qt3support qt4 quicktime radio rar readline redland reflection rtc rtf samba sametime sasl sasl2 sdl semantic-desktop session slang slp smp sms sndfile soundex speex spell spl sql sqlite sqlite3 srt sse sse2 sse3 ssl ssse3 startup-notification statistics stats svg sysfs tcpd teamarena teletext texteffect tga theora threads thumbnail tiff timidity translator truetype tunepimp twolame udev unicode upnp usb userlocales utempter v4l v4l2 vamp vcd vdpau vdr vorbis webkit webpresence wmf x264 xanim xcb xchatdccserver xine xml xml2 xorg xpm xulrunner xv xvid xvmc yv12 zeroconf zlib zoran zvbi" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en en_GB" LIRC_DEVICES="hauppauge hauppauge_dvb" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa v4l none"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Bernd Buschinski 2009-05-31 21:08:19 UTC
Created attachment 193090 [details]
patch to fix build
Comment 2 Markus Meier gentoo-dev 2009-06-01 09:08:45 UTC

*** This bug has been marked as a duplicate of bug 270720 ***