Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271942 - dev-libs/glib-2.20.2 fails to build, "/usr/bin: file not recognized: Is a directory"
Summary: dev-libs/glib-2.20.2 fails to build, "/usr/bin: file not recognized: Is a dir...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 275983 284480 294742 310281 399733 410375 413019 444036 460914 484114 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-31 06:13 UTC by brent
Modified: 2014-07-18 16:33 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,322.48 KB, text/plain)
2009-05-31 06:14 UTC, brent
Details
build environment file (environment,109.96 KB, text/plain)
2009-05-31 06:28 UTC, brent
Details
new build.log (build.log,358.00 KB, text/plain)
2009-05-31 16:38 UTC, brent
Details
new environment build file (environment,109.33 KB, text/plain)
2009-05-31 16:39 UTC, brent
Details
config.log from reproduction (config.log,243.11 KB, text/plain)
2009-05-31 16:40 UTC, brent
Details
emerge.log for both unsuccessful and successful emerges; dependency reference (emerge.log,165.44 KB, text/plain)
2009-06-02 06:41 UTC, brent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brent 2009-05-31 06:13:27 UTC
working on a new install and i keep running into this problem with about 1 in every 10 packages i'm trying to emerge, i think, but most notably it occurs on glib.


/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -g -O2 -pipe -mtune=core2 -Wall  -Wl,-O1 -o scannerapi scannerapi.o  ../glib/libglib-2.0.la  
libtool: link: x86_64-pc-linux-gnu-gcc -g -O2 -pipe -mtune=core2 -Wall -Wl,-O1 -o .libs/scannerapi scannerapi.o  ../glib/.libs/libglib-2.0.so
/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -g -O2 -pipe -mtune=core2 -Wall  -Wl,-O1 -o testglib testglib.o ../glib/libglib-2.0.la 
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/libmoduletestplugin_b.o   -Wl,-rpath -Wl,/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/gmodule/.libs -Wl,-rpath -Wl,/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/glib/.libs -L/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/glib/.libs ../gmodule/.libs/libgmodule-2.0.so /usr/bin /usr/sbin /bin /sbin -ldl /var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/glib/.libs/libglib-2.0.so ../glib/.libs/libglib-2.0.so  -mtune=core2 -Wl,--export-dynamic -Wl,-O1   -Wl,-soname -Wl,libmoduletestplugin_b.so -o .libs/libmoduletestplugin_b.so
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/libmoduletestplugin_a.o   -Wl,-rpath -Wl,/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/gmodule/.libs -Wl,-rpath -Wl,/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/glib/.libs -L/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/glib/.libs ../gmodule/.libs/libgmodule-2.0.so /usr/bin /usr/sbin /bin /sbin -ldl /var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/glib/.libs/libglib-2.0.so ../glib/.libs/libglib-2.0.so  -mtune=core2 -Wl,--export-dynamic -Wl,-O1   -Wl,-soname -Wl,libmoduletestplugin_a.so -o .libs/libmoduletestplugin_a.so
/usr/bin: file not recognized: Is a directory
collect2: ld returned 1 exit status
make[3]: *** [libmoduletestplugin_b.la] Error 1
make[3]: *** Waiting for unfinished jobs....
/usr/bin: file not recognized: Is a directory
collect2: ld returned 1 exit status
make[3]: *** [libmoduletestplugin_a.la] Error 1
libtool: link: x86_64-pc-linux-gnu-gcc -g -O2 -pipe -mtune=core2 -Wall -Wl,-O1 -o .libs/testglib testglib.o  ../glib/.libs/libglib-2.0.so
make[3]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/tests'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2/tests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/glib-2.20.2/work/glib-2.20.2'
make: *** [all] Error 2
 * 
 * ERROR: dev-libs/glib-2.20.2 failed.
 * Call stack:
 *               ebuild.sh, line   48:  Called src_compile
 *             environment, line 2859:  Called _eapi2_src_compile
 *               ebuild.sh, line  625:  Called die
 * The specific snippet of code:
 *   		emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-libs/glib-2.20.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/glib-2.20.2/temp/environment'.
 * 






Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.8_p20080602-r1, 2.6.29.04-std120-amd64 x86_64)
=================================================================
System uname: Linux-2.6.29.04-std120-amd64-x86_64-Intel-R-_Core-TM-2_Extreme_CPU_X9100_@_3.06GHz-with-glibc2.2.5
Timestamp of tree: Sun, 31 May 2009 04:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mtune=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mtune=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cleartype cli cracklib crypt cups dbus dga directfb dri dvd dvdr dvdread eds emboss encode esd evo fam fbcon firefox fortran gdbm ggi gif glitz gnome gnutls gpm gstreamer gtk hal iconv ipv6 isdnlog java jbig jpeg jpeg2k justify kde kerberos ldap libcaca libnotify lzo mad midi mikmod mmx mp3 mpeg mudflap multilib multislot mysql nas ncurses nls nptl nptlonly nsplugin offensive ogg opengl openmp pam pcre pdf perl php png postgresql ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session smbkrb5passwd spell spl sse sse2 ssl startup-notification svg sysfs tcpd toolbar tools truetype unicode usb utils vim-syntax vorbis xattr xinetd xml xorg xulrunner xv zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="radeon fglrx radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 brent 2009-05-31 06:14:17 UTC
Created attachment 193038 [details]
build log
Comment 2 Sebastian Luther (few) 2009-05-31 06:19:20 UTC
Please attach /var/tmp/portage/dev-libs/glib-2.20.2/temp/environment.
Comment 3 brent 2009-05-31 06:28:29 UTC
Created attachment 193042 [details]
build environment file

(In reply to comment #2)
> Please attach /var/tmp/portage/dev-libs/glib-2.20.2/temp/environment.
> 

you know, i was debating with myself whether you'd need it or not. :)
didn't want to clutter the report if it was unnecessary.

here ya go!
Comment 4 brent 2009-05-31 08:35:16 UTC
hey sebastian and the rest of the bug team, i think i may have figured it out for you.

i'm 90% positive it's somewhere in the USE flags and/or the /etc/make.profile i had set (../usr/portage/profiles/default/linux/amd64/2008.0).

i tried a pristine install, same repos, etc. but this time i used a vanilla make.conf and i never set an /etc/make.profile symlink.... and wouldn't you know it? it emerged FINE.

however, i still want to leave this as "ASSIGNED" so whomever wants to look through it can.. i'm going to do some more testing, see if it breaks later on when i re-set the make.profile smylink. i'll keep you posted if it does.
Comment 5 brent 2009-05-31 08:39:41 UTC
whoops- quick correction.

profile was ../usr/portage/profiles/default/linux/amd64/2008.0/desktop (however, the parent file exists so it'd link upwards, if i'm not mistaken)...

so i'm pretty sure it's somewhere in the USE flags i set in the make.conf:

avahi bash-completion cleartype dga directfb fbcon ggi glitz gnutls ibm java jbig jpeg2k justify kerberos libcaca lzo multislot mysql nas nsplugin php postgresql samba smbkrb5passwd toolbar tools utils vim-syntax xinetd zeroconf
Comment 6 Rafał Mużyło 2009-05-31 14:57:45 UTC
It's probably something in your env,
but I doubt it's useflags/profile.

Attach config.log.
Comment 7 brent 2009-05-31 16:14:30 UTC
(In reply to comment #6)
> It's probably something in your env,
> but I doubt it's useflags/profile.
> 
> Attach config.log.
> 

ahh darn it. i scrapped the install and started over, i'm afraid.

anyways, i'm assuming user error on this part because i cen't seem to duplicate it now, even after switching to the desktop profile as i suspected.

Since i no longer have the associated build logs, et. al. i'm marking this as "RESOLVED: NEEDINFO" in case someone else bumps into it.
Comment 8 brent 2009-05-31 16:37:21 UTC
well, good(?) news. i got it to reproduce on a vanilla install now.

i'll attach the new build.log, environment, and config.log
Comment 9 brent 2009-05-31 16:38:20 UTC
Created attachment 193072 [details]
new build.log
Comment 10 brent 2009-05-31 16:39:32 UTC
Created attachment 193074 [details]
new environment build file
Comment 11 brent 2009-05-31 16:40:44 UTC
Created attachment 193076 [details]
config.log from reproduction
Comment 12 brent 2009-05-31 22:07:49 UTC
hey, a thought just occurred- i'm using ext4 for my /, would that have any impact? i wouldn't think it would, but the fact that glib has an xattr USE flag AND it spits out:

/usr/bin: file not recognized: Is a directory

makes me suspicious.
Comment 13 brent 2009-06-01 00:59:07 UTC
....yeah. it builds fine in a fresh chroot environment on another host using ext3. it makes no sense, and i don't think it's really ext4 that's causing it, but at this point who knows?
Comment 14 Lars Wendler (Polynomial-C) gentoo-dev 2009-06-02 06:22:39 UTC
Out of curiosity, what's the content of your root user's PATH variable?
Comment 15 brent 2009-06-02 06:40:37 UTC
(In reply to comment #14)
> Out of curiosity, what's the content of your root user's PATH variable?
> 

hmm, didn't append or remove from it, and i always env-update and source /etc/profile after i chroot in.

i use sysresccd for installs, though, not the gentoo disc..

i have the old, broken install tarred up at the moment and i'm about to leave for a couple days, but when i come back i'll untar it and chroot in and see if i can reproduce on the different host.

i was able to get it to compile (and can recompile it without fail, changing the use flags also doesn't break it) on the fresh install, however..

i'll attach my emerge.log just in case it's a dependency issue. you can see it fail on line 643, 1031, 1081, and then it exits/compiles successfully at line 1766 (i believe i killed that one before it started), 1778, and 1789. i THINK it was perhaps cairo or one of the dependencies it pulled in that "fixed" things, but it works fine now..
Comment 16 brent 2009-06-02 06:41:30 UTC
Created attachment 193239 [details]
emerge.log for both unsuccessful and successful emerges; dependency reference
Comment 17 Mike Auty gentoo-dev 2009-06-06 13:52:40 UTC
It appears as though you have a path variable set, and it's also set as a space separated variable, whereas PATH variables are in general a colon separated variable (for example PATH="/sbin:/usr/sbin:/bin:/usr/bin").  The errors you've posted are the reverse of your path variable, although I can't see why they're being included.  My guess is a libtool issue (given that they're not passed in to the libtool call), so it's probably from a different package that all your other packages try to include (using libtool).

Could you please run "grep -ir path /usr/lib/*.la" and "grep -ir path /etc/env.d/*", then post the results here?  Finally, please do attach your root user's environment, it will help us determine whether this bad path variable is present in just portage's environment, or also in the root user's...
Comment 18 Jeroen Roovers gentoo-dev 2009-06-11 05:54:58 UTC
Comment on attachment 193239 [details]
emerge.log for both unsuccessful and successful emerges; dependency reference

You were asked to post information about the failing system. Showing emerge.log really won't do, I'm afraid.
Comment 19 brent 2009-06-13 05:07:39 UTC
hey, sorry for the late reply.

i'm 100% sure i've narrowed it to a SystemRescueCD issue, as the error is unable to reproduced inside the actuall install or a chroot from another gentoo host.

which is a bit weird because i would always env-update and source /etc/profile after a chroot from the CD, but i guess there's some funniness there. using the beta arch of the cd, anyways, though, so.. no surprise. when i get the chance i'll forward this bug to them and reopen if after further investigation it turns out i'm wrong, but at this point it's the only constant difference.

thank you for your help, everyone.
Comment 20 Adrian Dannberg 2009-06-26 17:33:33 UTC
I can confirm this with glib-2.18.4-r1 on SystemRescueCd-1.2.1
Comment 21 Sebastian Luther (few) 2009-06-30 18:58:52 UTC
*** Bug 275983 has been marked as a duplicate of this bug. ***
Comment 22 fenril 2009-06-30 19:13:27 UTC
Hi,

I confirm, same problem with syrescd 1.2.1. So how can i install gentoo with amd64 and ext4 support ?
Comment 23 Andrew Gaffney (RETIRED) gentoo-dev 2009-07-01 02:35:52 UTC
The autobuild installcds have ext4 support. Try:

http://gentoo.osuosl.org/releases/amd64/autobuilds/20090625/install-amd64-minimal-20090625.iso
Comment 24 Uwe 2009-07-02 12:30:18 UTC
export path=

did it for me today while building a new system
Comment 25 Andrew Savchenko gentoo-dev 2009-07-04 03:14:34 UTC
(In reply to comment #24)
> export path=
> 
> did it for me today while building a new system
> 

Thanks,
$ unset path
helps me too.
Comment 26 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-08-25 20:47:14 UTC
I've hit this issue as well and it affects other packages as well.
I've noticed that sysrescuecd uses zsh by default and that even after chrooting, SHELL is set to zsh. I couldn't see anything obvious in PATH, but unsetting it allowed portage to merge each package that failed.
Comment 27 7335520f 2009-09-24 05:56:26 UTC
(In reply to comment #26)
> I've hit this issue as well and it affects other packages as well.
> I've noticed that sysrescuecd uses zsh by default and that even after
> chrooting, SHELL is set to zsh. I couldn't see anything obvious in PATH, but
> unsetting it allowed portage to merge each package that failed.
> 
Hey, I hit this issue just now too.
Another approach is to tweak the chroot command like this:

# SHELL=/bin/bash chroot /mnt/gentoo /bin/bash
Comment 28 Rafał Mużyło 2009-11-27 04:09:25 UTC
*** Bug 294742 has been marked as a duplicate of this bug. ***
Comment 29 Boyd Waters 2010-02-15 21:06:56 UTC
Many many thanks for this excellent bug report, which just saved me hours of frustration. I have posted a "heads-up" about this (admittedly odd) env bug on the Funtoo list; people who are bootstrapping a GPT-partitioned or btrfs-root system might run into it.
Comment 30 Michael Ralston 2010-03-19 20:34:54 UTC
*** Bug 310281 has been marked as a duplicate of this bug. ***
Comment 31 Dallas 2010-10-29 09:46:47 UTC
I too had this issue using sysrescuecd.  But using just SHELL=/bin/bash didn't solve it.  I used:

chroot /mnt/gentoo /usr/sbin/env -i /bin/bash

This wipes the environment before starting bash.
Comment 32 Dallas 2010-10-29 09:47:23 UTC
I too had this issue using sysrescuecd.  But using just SHELL=/bin/bash didn't solve it.  I used:

chroot /mnt/gentoo /usr/sbin/env -i /bin/bash

This wipes the environment before starting bash.
Comment 33 Jeroen Roovers gentoo-dev 2010-11-17 15:31:49 UTC
*** Bug 284480 has been marked as a duplicate of this bug. ***
Comment 34 Samuli Suominen gentoo-dev 2012-01-22 15:41:39 UTC
*** Bug 399733 has been marked as a duplicate of this bug. ***
Comment 35 Samuli Suominen gentoo-dev 2012-03-31 19:21:22 UTC
*** Bug 410375 has been marked as a duplicate of this bug. ***
Comment 36 Pacho Ramos gentoo-dev 2012-04-22 11:10:02 UTC
*** Bug 413019 has been marked as a duplicate of this bug. ***
Comment 37 Rafał Mużyło 2012-11-20 16:46:04 UTC
*** Bug 444036 has been marked as a duplicate of this bug. ***
Comment 38 Rafał Mużyło 2013-03-09 19:52:46 UTC
*** Bug 460914 has been marked as a duplicate of this bug. ***
Comment 39 Arfrever Frehtes Taifersar Arahesis 2013-09-08 11:23:11 UTC
*** Bug 484114 has been marked as a duplicate of this bug. ***