Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271814 - [patch] net-print/hplip-3.9.2 fails to build with sys-devel/gcc-4.4
Summary: [patch] net-print/hplip-3.9.2 fails to build with sys-devel/gcc-4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Denis Dupeyron
URL:
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-05-29 22:06 UTC by hirakendu
Modified: 2009-06-06 00:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for hplip to build with gcc-4.4 (hplip-3.9.2-gcc44.patch,1.50 KB, patch)
2009-05-29 22:07 UTC, hirakendu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hirakendu 2009-05-29 22:06:51 UTC
usual type conversion errors.

Reproducible: Always
Comment 1 hirakendu 2009-05-29 22:07:57 UTC
Created attachment 192935 [details, diff]
patch for hplip to build with gcc-4.4
Comment 2 hirakendu 2009-05-31 18:45:46 UTC
Update: Fixed with 3.9.4b. Thanks :). Btw, as mentioned in another bug, please change the libusb:0 dependency to virtual.
Comment 3 Denis Dupeyron gentoo-dev 2009-06-06 00:02:51 UTC
(In reply to comment #2)
> Btw, as mentioned in another bug, please
> change the libusb:0 dependency to virtual.

See comment 3 of that other bug.

Denis.