Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271640 - net-irc/telepathy-idle-0.1.2 fails to build with glibc-2.10
Summary: net-irc/telepathy-idle-0.1.2 fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Santiago M. Mola (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-29 08:26 UTC by hirakendu
Modified: 2009-08-10 05:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for telepathy-idle to build with glibc-2.10 (telepathy-idle-0.1.2-glibc210.patch,866 bytes, patch)
2009-05-29 08:26 UTC, hirakendu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hirakendu 2009-05-29 08:26:02 UTC
change in glibc-2.10: use #define __USE_XOPEN2K8 instead of #define __USE_GNU .

Reproducible: Always
Comment 1 hirakendu 2009-05-29 08:26:33 UTC
Created attachment 192821 [details, diff]
patch for telepathy-idle to build with glibc-2.10
Comment 2 Arttu Valo 2009-07-14 22:34:33 UTC
Should the __USE_GNU still be changed to _GNU_SOURCE? (This is way out of my gnu-c league, but everyone seems to be stating that __USE_GNU is somehow evil and _GNU_SOURCE should be used instead -- and that's what actually happens, e.g., in src/idle-muc-channel.c, but not elsewhere in the code.)
Comment 3 Patrik Huber 2009-07-15 15:25:53 UTC
Same problem here, still not fixed in the portage tree :\
Comment 4 hirakendu 2009-07-15 17:55:01 UTC
I just kept the __USE_GNU as it is, since it used to compile fine with < glibc-2.10. So this workaround (patch) should do with all glibc.
Comment 5 Arttu Valo 2009-07-15 19:43:33 UTC
Upstream(?) seems to have this kind of patch:

https://bugs.freedesktop.org/show_bug.cgi?id=22291
Comment 6 Samuli Suominen gentoo-dev 2009-08-07 12:29:37 UTC
fixed, thanks (not used the attached patch but the one from upstream bug)
Comment 7 imgvg 2009-08-10 05:08:42 UTC
The fix is also needed for 0.1.4. Upstream did not fix this bug until nearly a month after 0.1.4's release.

From http://git.collabora.co.uk/?p=telepathy-idle.git (and edited a bit)

2009-06-20
	Will Thompson
	Define _GNU_SOURCE not __USE_GNU to get strnlen(3).

2009-05-28
	Will Thompson
	version 0.1.4  telepathy-idle-0.1.4