Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 271611 - [patch] net-wireless/madwifi-ng fails to build with sys-devel/gcc-4.4
Summary: [patch] net-wireless/madwifi-ng fails to build with sys-devel/gcc-4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Steev Klimaszewski
URL: http://www.mail-archive.com/madwifi-t...
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-05-29 07:10 UTC by hirakendu
Modified: 2009-06-04 12:36 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for building madwifi svn (currently 4029) with gcc-4.4 (madwifi-ng-r4020-gcc44.patch,3.33 KB, text/plain)
2009-05-29 07:12 UTC, hirakendu
Details
a madwifi-ng svn ebuild (madwifi-ng-9999-r101.ebuild,2.95 KB, text/plain)
2009-05-29 07:18 UTC, hirakendu
Details
use along with madwifi-svn ebuild (madwifi-ng-injection.patch,889 bytes, text/plain)
2009-05-29 07:19 UTC, hirakendu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hirakendu 2009-05-29 07:10:55 UTC
madwifi-ng is in a mess in general. (ath5k/9k should instead suffice). gcc-4.4 complains that frame-size greater than 1024 bytes is used. may update to latest svn and use a patch for gcc-4.4

Reproducible: Always
Comment 1 hirakendu 2009-05-29 07:12:16 UTC
Created attachment 192793 [details]
patch for building madwifi svn (currently 4029) with gcc-4.4
Comment 2 hirakendu 2009-05-29 07:18:48 UTC
Created attachment 192795 [details]
a madwifi-ng svn ebuild 

currently 4029, supports kernel 2.6.29. use along with the patches.
Comment 3 hirakendu 2009-05-29 07:19:41 UTC
Created attachment 192797 [details]
use along with madwifi-svn ebuild
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2009-06-04 10:45:43 UTC
Thank you for report hirakendu. Looks like inability to build with gcc-4.4 was fixed in madwifi-ng-0.9.4.4030.20090529.ebuild. Please test it. If there are any further problems you'd like to address, please, open new bug(s).
Comment 5 hirakendu 2009-06-04 12:36:47 UTC
Thanks for the fixes :).