Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 271236 - media-gfx/hugin-0.7.0-r1 fails to build with gcc-4.4
Summary: media-gfx/hugin-0.7.0-r1 fails to build with gcc-4.4
Status: VERIFIED DUPLICATE of bug 270593
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-05-25 20:43 UTC by Mike Limansky
Modified: 2010-12-15 20:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
hugin-0.7.0-gcc-44.patch (hugin.gcc44,966 bytes, patch)
2009-05-25 20:54 UTC, Mike Limansky
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Limansky 2009-05-25 20:43:08 UTC
media-gfx/hugin-0.7.0-r1 cannot be built using gcc-4.4.

Reproducible: Always

Steps to Reproduce:
1. Install gcc-4.4, and set it as a active.
2. Emerge hugin

Actual Results:  
Application failed to compile.

Expected Results:  
Application is emerged successfully.

emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.10.1-r0, 2.6.29-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r4-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-gentoo-2.0.0
Timestamp of tree: Sun, 24 May 2009 08:45:03 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -pipe"
DISTDIR="/mnt/data/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://linuxarchive.nnov.ru/Unix/Gentoo ftp://ftp1.zxc.nnov.ru/gentoo/ http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.nnov.ru/gentoo-portage"
USE="3dnow X a52 aac aalib acpi alsa amd64 audiofile branding bzip2 cairo cdr clamav cli cracklib crypt cups dbus dri dts dvd dvdr dvdread encode esd evo fam firefox flac foomaticdb fortran gdbm gif gpm hal iconv icq jack jpeg kde kdeenablefinal kdehiddenvisibility kpathsea libcaca libnotify mad midi mikmod mmx mng mp3 mpeg mplayer mudflap multilib ncurses nls nptl nptlonly offensive ogg opengl openmp oscar pam pcre pdf perl png ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection scanner sdl session spell spl srt sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis xcb xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Mike Limansky 2009-05-25 20:54:30 UTC
Created attachment 192442 [details, diff]
hugin-0.7.0-gcc-44.patch

I've prepare a patch to make it built with gcc 4.4., please take a look on it.
Comment 2 Markus Meier gentoo-dev 2009-05-26 21:44:08 UTC
this should already be fixed in cvs, commited that on sunday.

*** This bug has been marked as a duplicate of bug 270593 ***