Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270758 - gnome-base/nautilus-2.24.2-r3: wrong permission read on network file system
Summary: gnome-base/nautilus-2.24.2-r3: wrong permission read on network file system
Status: VERIFIED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-05-21 20:23 UTC by Fabiano Francesconi
Modified: 2010-01-27 23:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Francesconi 2009-05-21 20:23:46 UTC
Don't know if is a problem related only to cifs/samba but this strange thing happen to me with a particular directory that I shared with Windows Vista.

The weird is that I shared a directory that has "Everyone" as co-owner role.
Well, Nautilus can access to it, can browse it, can delete/add/modify everything and everywhere *but* the root.
I'll drop you an example.

Windows Vista PC: 192.168.1.1
Shared directory: Music

Music content: directories [A] and [B]

smb://192.168.1.1/Music is the link I give in Nautilus to access the shared resource.

I can do whatever I want but I can't create new folder, add files in that directory.
I can rename [A] to [WHATEVER_I_WANT] or [B] as well.
I can't create a [C] directory or add a song.mp3 file into the "root".

I thought that maybe there were a problem in the sharing: so I re did it. Nothing changed.

So I tried with the old-fashioned console way:
mount -t cifs //192.168.1.1/Music /mnt/cifs/ -o allow_others

"cd /mnt/cifs && mkdir C " and it worked. The directory has been created so.. what's going on?

I tried with another PC running Windows and it works flawlessy.

The real thing that scares me off is that I have 5 shared directories and this is the only that gives this problems.

Reproducible: Always

Steps to Reproduce:
1. Access to smb://whatever


Actual Results:  
Can't create new folder in that path but can do whatever you want in any other dirs

Expected Results:  
Everything should work just as always
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-10-26 23:07:34 UTC
is this still a probem in 2.26 ? please attach your emerge --info and emerge -pv nautilus glib gvfs gnome-vfs samba samba-libs samba-client.
Comment 2 Fabiano Francesconi 2010-01-27 22:44:46 UTC
Can't say it anymore since very much changed in almost 8 months.

Mainly I've switched OS on my home-server and now it's running on a Gentoo machine so no more issues so far.

Said so, this bug should be closed.
Comment 3 Gilles Dartiguelongue gentoo-dev 2010-01-27 23:05:48 UTC
thanks for the heads up.