Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270611 - app-text/t1utils-1.34 fails to compile with glibc-2.10 getline conflict
Summary: app-text/t1utils-1.34 fails to compile with glibc-2.10 getline conflict
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-20 18:54 UTC by Justin Lecher
Modified: 2009-05-22 14:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/tmp/emerge.info (emerge.info,4.34 KB, text/plain)
2009-05-20 18:56 UTC, Justin Lecher
Details
/tmp/build.log (build.log,5.22 KB, text/plain)
2009-05-20 18:56 UTC, Justin Lecher
Details
t1utils-1.34-glibc-2.10.patch (t1utils-1.34-glibc-2.10.patch,968 bytes, patch)
2009-05-21 11:14 UTC, Honza Macháček
Details | Diff
t1utils-1.34.ebuild.patch (t1utils-1.34.ebuild.patch,736 bytes, patch)
2009-05-21 11:16 UTC, Honza Macháček
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher gentoo-dev 2009-05-20 18:54:56 UTC
make[1]: Entering directory `/var/tmp/portage/app-text/t1utils-1.34/work/t1utils-1.34'
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I./include   -O2 -pipe -march=prescott -fomit-frame-pointer -MT clp.o -MD -MP -MF .deps/clp.Tpo -c -o clp.o clp.c
mv -f .deps/clp.Tpo .deps/clp.Po
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I./include   -O2 -pipe -march=prescott -fomit-frame-pointer -MT t1lib.o -MD -MP -MF .deps/t1lib.Tpo -c -o t1lib.o t1lib.c
t1lib.c: In function ‘pfb_writer_output_block’:
t1lib.c:346: warning: ignoring return value of ‘fwrite’, declared with attribute warn_unused_result
mv -f .deps/t1lib.Tpo .deps/t1lib.Po
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I./include   -O2 -pipe -march=prescott -fomit-frame-pointer -MT t1ascii.o -MD -MP -MF .deps/t1ascii.Tpo -c -o t1ascii.o t1ascii.c
mv -f .deps/t1ascii.Tpo .deps/t1ascii.Po
i686-pc-linux-gnu-gcc  -O2 -pipe -march=prescott -fomit-frame-pointer  -Wl,-O1,--hash-style=gnu,--sort-common,--as-needed -o t1ascii clp.o t1lib.o t1ascii.o  
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I./include   -O2 -pipe -march=prescott -fomit-frame-pointer -MT t1binary.o -MD -MP -MF .deps/t1binary.Tpo -c -o t1binary.o t1binary.c
mv -f .deps/t1binary.Tpo .deps/t1binary.Po
i686-pc-linux-gnu-gcc  -O2 -pipe -march=prescott -fomit-frame-pointer  -Wl,-O1,--hash-style=gnu,--sort-common,--as-needed -o t1binary clp.o t1lib.o t1binary.o  
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -I./include   -O2 -pipe -march=prescott -fomit-frame-pointer -MT t1asm.o -MD -MP -MF .deps/t1asm.Tpo -c -o t1asm.o t1asm.c
t1asm.c:283: error: conflicting types for ‘getline’
/usr/include/stdio.h:651: error: previous declaration of ‘getline’ was here
make[1]: *** [t1asm.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/t1utils-1.34/work/t1utils-1.34'
make: *** [all] Error 2
 *
Comment 1 Justin Lecher gentoo-dev 2009-05-20 18:56:03 UTC
Created attachment 191926 [details]
/tmp/emerge.info

=emerge --info
Comment 2 Justin Lecher gentoo-dev 2009-05-20 18:56:13 UTC
Created attachment 191927 [details]
/tmp/build.log

=build.log
Comment 3 Sebastian Wiesner 2009-05-20 20:49:33 UTC
Same here.

Comment 4 Honza Macháček 2009-05-21 11:14:01 UTC
Created attachment 192024 [details, diff]
t1utils-1.34-glibc-2.10.patch

Patch change all the offending uses of getline to _getline.
Comment 5 Honza Macháček 2009-05-21 11:16:07 UTC
Created attachment 192026 [details, diff]
t1utils-1.34.ebuild.patch

Patch for the app-text/t1utils-1.34.ebuild to use the patch above.
Comment 6 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-21 13:50:47 UTC
Note: Functions starting with _ are reserved in C and should not be used. If you want to fix these kinds of bugs, patches should (for example) rename the getline function to nameofpackage_getline
Comment 7 Sebastian Wiesner 2009-05-21 15:21:45 UTC
Can someone please explain me how to use these two patches? I#M not experienced in patching ebuilds. Thank you.
Comment 8 Justin Lecher gentoo-dev 2009-05-21 15:40:26 UTC
(In reply to comment #7)
> Can someone please explain me how to use these two patches? I#M not experienced
> in patching ebuilds. Thank you.
> 
1.
http://en.gentoo-wiki.com/wiki/Creating_an_Updated_Ebuild
2. Please try to find the solution yourself first in future. Like in this case you will find the answer very fast.
3.
As it was said the patch isn't good.
--> 
Use a solution like 
http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-util/unifdef/unifdef-1.20.ebuild?r1=1.4&r2=1.5
Comment 9 Alexis Ballier gentoo-dev 2009-05-22 14:39:02 UTC
applied, thanks.