Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270452 - net-dialup/minicom-2.3-r1 can not compile due to conflicting type for ‘getline’
Summary: net-dialup/minicom-2.3-r1 can not compile due to conflicting type for ‘getline’
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Dialup Developers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-19 16:32 UTC by daveswen
Modified: 2009-06-23 20:37 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
minicom-2.3-getline-rename.patch (minicom-2.3-getline-rename.patch,3.61 KB, patch)
2009-05-19 20:16 UTC, Conrad Kostecki
Details | Diff
new patch for minicom (minicom-2.3-getline-rename-r2.patch,3.67 KB, patch)
2009-06-08 07:47 UTC, Viktor S
Details | Diff
updated ... (minicom-2.3-getline-rename-r3.patch,3.67 KB, patch)
2009-06-08 07:49 UTC, Viktor S
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description daveswen 2009-05-19 16:32:38 UTC
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I../lib -DCONFDIR=\"/etc/minicom\" -DLOCALEDIR=\"/usr/share/locale\"  -O2 -march=native -pipe -fomit-frame-pointer -Wall -W -O2 -march=native -pipe -fomit-frame-pointer -MT util.o -MD -MP -MF .deps/util.Tpo -c -o util.o util.c
minicom.c:170: error: conflicting types for ‘getline’
/usr/include/stdio.h:651: error: previous declaration of ‘getline’ was here


Reproducible: Always

Steps to Reproduce:
1.emerge -av minicom
2.
3.




Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r4-i686-Intel-R-_Core-TM-2_Duo_CPU_L9400_@_1.86GHz-with-gentoo-2.0.0
Timestamp of tree: Tue, 19 May 2009 14:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.7
dev-lang/python:     2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ http://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/thirdparty"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa applet bash-completion berkdb bluetooth bzip2 cairo cdr cli consolekit cracklib crypt cscope cups dbus dri dvd emacs exif fbsplash ffmpeg firefox fontconfig fortran gdbm geoip gif gimp git gmp gnome gnome-keyring gnutls gphoto2 gpm graphviz gtk hal iconv isdnlog jpeg jpeg2k libnotify midi mikmod mmx mpeg mplayer mudflap nautilus ncurses networkmanager nls nptl nptlonly opengl openmp pam pcmcia pcre perl png policykit pppd python raw readline reflection samba session smp spl sqlite sse sse2 ssl ssse3 subversion svg sysfs tcpd threads tiff truetype unicode usb vorbis wifi win32codecs x264 x86 xinetd xml xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Viktor S 2009-05-19 19:24:10 UTC
Please add bug 270353 to the bugs that this one blocks as that's the tracker for glibc-2.10 related bugs
Comment 2 Conrad Kostecki gentoo-dev 2009-05-19 20:16:00 UTC
Created attachment 191837 [details, diff]
minicom-2.3-getline-rename.patch

Hi!
Here is an patch, which renames all getline() to _getline() functions.
Now I can compile with glibc 2.10.1

Btw, could someone add this bug please to the tracker? Thanks!
Comment 3 Markus Ullmann (RETIRED) gentoo-dev 2009-05-19 21:58:48 UTC
Thanks, added to CVS :)
Comment 4 daveswen 2009-05-20 02:00:52 UTC
it works,thanks
Comment 5 Viktor S 2009-06-08 07:47:19 UTC
Created attachment 193855 [details, diff]
new patch for minicom

The patch here renames getline() to _getline(), which is bad - see 5th paragraph of [1]. This patch renames it to minic_getline() instead. Could you please use it instead?



[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 6 Viktor S 2009-06-08 07:49:32 UTC
Created attachment 193856 [details, diff]
updated ...

missed one of the functions.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-08 15:53:02 UTC
Reopening for a different patch method. Please consider.

Adding jokey to CC because he was originally working on it.
Comment 8 Viktor S 2009-06-15 19:19:17 UTC
Hey! Net-mail guys, wake up! Albeit the problem solved in the updated patch is minor, it's still important that it gets merged. Else, why even have minicom in the tree if we're not going to maintain it?
Comment 9 Alin Năstac (RETIRED) gentoo-dev 2009-06-20 10:38:56 UTC
Fixed in 2.3-r2.

FYI, we respond better to appellative "net-dialup guys".
Comment 10 Viktor S 2009-06-23 20:37:30 UTC
Oh, sorry my bad ... Thank you for the merge! :-)