Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270449 - gnome-extra/gnome-games-2.24.3 fails to compile with glibc 2.10 due to getline clash
Summary: gnome-extra/gnome-games-2.24.3 fails to compile with glibc 2.10 due to getlin...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 283515 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-19 16:28 UTC by Lars Lindley
Modified: 2009-09-02 14:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix glibc-2.10 getline conflict (glibc-2.10.patch,1.28 KB, patch)
2009-08-01 23:58 UTC, saellaven
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Lindley 2009-05-19 16:28:50 UTC
Another of these getline compile errors:

In file included from cmd.c:35:
common.h:747: error: ‘getline’ redeclared as different kind of symbol
/usr/include/stdio.h:651: error: previous declaration of ‘getline’ was here
In file included from book.c:34:
common.h:747: error: ‘getline’ redeclared as different kind of symbol
/usr/include/stdio.h:651: error: previous declaration of ‘getline’ was here


Reproducible: Always




Portage 2.1.6.11 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.29-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r4-x86_64-AMD_Phenom-tm-_II_X3_720_Processor-with-glibc2.2.5
Timestamp of tree: Tue, 19 May 2009 15:30:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=amdfam10 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.rhnet.is/pub/gentoo/ http://mirror.muntinternet.net/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://mirror.bytemark.co.uk/gentoo/ ftp://gentoo.imj.fr/pub/gentoo/ http://trumpetti.atm.tut.fi/gentoo/ http://mirror.bytemark.co.uk/gentoo/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="en_US.UTF-8"
LC_ALL="sv_SE.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac acl alsa amd64 apache2 bash-completion berkdb bonobo branding bzip2 cairo cdinstall cdparanoia cdr cli cracklib crypt cups cupsddk curl dbus dga dri dvd dvdr dvdread eds encode evo exif expat fam ffmpeg firefox flac fltk fortran ftp gdbm gif gimp gmp gnome gnutls gpm gstreamer gtk hal iconv icq imagemagick imap imlib ipv6 isdnlog java javascript jbig jpeg jpeg2k lcms libgda libnotify libwww lm_sensors mad midi mime mmap mmx mmxext mng mozilla mp3 mplayer msn mudflap multilib ncurses nls nocd nptl nptlonly nsplugin ogg opengl openmp oscar pam pcre pdf perl png posix pppd python quicktime rar raw readline reflection sdl session sharedmem slang snmp sockets spell spl sse sse2 ssl svg symlink sysfs tcl tcpd threads tiff tk truetype unicode usb userlocales vcd videos vorbis wma wmf x264 xmp xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-05-31 18:52:19 UTC
gnome-games-2.26 builds just fine.
Comment 2 saellaven 2009-08-01 23:58:52 UTC
Created attachment 199867 [details, diff]
fix glibc-2.10 getline conflict

fixes stable gnome-games since not everyone is on 2.26 yet even if we're using glibc-2.10
Comment 3 Justin Lecher gentoo-dev 2009-09-02 14:36:06 UTC
*** Bug 283515 has been marked as a duplicate of this bug. ***