Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270263 - app-openoffice-3.1.0 does not build with sys-libs/glibc-2.10.1 due to getline() prototype
Summary: app-openoffice-3.1.0 does not build with sys-libs/glibc-2.10.1 due to getline...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
: 270259 270342 270366 270375 270484 270489 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-05-18 09:25 UTC by Graham Murray
Modified: 2009-09-10 00:59 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
rename getline to ooo_getline (ooo_getline.diff,1.32 KB, patch)
2009-05-18 13:40 UTC, Hanno Zysik (geki)
Details | Diff
Buildlog of failure svenneK (build.log,237.01 KB, text/plain)
2009-05-20 20:16 UTC, Svenne Krap
Details
the right file, hopefully (build.log.gz,343.69 KB, application/gzip)
2009-05-20 21:37 UTC, Svenne Krap
Details
build.log (build.log.tar.gz,5.66 KB, application/gzip)
2009-05-21 10:26 UTC, egon2003
Details
(sraybaud) ooo build log (sraybaud.build.log.gz,86.17 KB, application/x-gzip)
2009-07-30 10:53 UTC, Sylvain Raybaud
Details
(sraybaud) emerge --info (sraybaud.emerge.info,3.70 KB, text/plain)
2009-07-30 10:54 UTC, Sylvain Raybaud
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Murray 2009-05-18 09:25:20 UTC
Building with MAKEOPTS="-j1" as suggested following a build error
Making: ../unxlngi6.pro/obj/cppsetup.obj
gcc -fmessage-length=0 -c -Os -fno-strict-aliasing -DENABLE_LAYOUT_EXPERIMENTAL=0   -I.  -I../unxlngi6.pro/inc/make_makedepend -I../inc -I../inc/pch -I../inc -I../unx/inc -I../unxlngi6.pro/inc -I. -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solver/310/unxlngi6.pro/incdont_use_stl -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solver/310/unxlngi6.pro/inc/external -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solver/310/unxlngi6.pro/inc -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solenv/unxlngi6/inc -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solenv/inc -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/res -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solver/310/unxlngi6.pro/incdont_use_stl -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solenv/inc/Xp31 -I/opt/sun-jdk-1.6.0.13/include -I/opt/sun-jdk-1.6.0.13/include/linux -I/opt/sun-jdk-1.6.0.13/include/native_threads/include -Idefault_x_includes  -I/var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/solver/310/unxlngi6.pro/inc/offuh -I. -I../res -I. -pipe -march=native -mtune=native -pipe -DGL_GLEXT_PROTOTYPES  -Wall -Wextra -Wendif-labels  -DLINUX -DUNX -DVCL -DGCC -DC341 -DINTEL -DCVER=C341 -DNPTL -DGLIBC=2 -DX86 -D_PTHREADS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -DHAVE_GCC_VISIBILITY_FEATURE -D__DMAKE -DUNIX -DCPPU_ENV=gcc3 -DGXX_INCLUDE_PATH=/usr/lib/gcc/i686-pc-linux-gnu/4.3.3/include/g++-v4 -DSUPD=310 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE -DGSTREAMER -DENABLE_LAYOUT=1 -DCUI -DSOLAR_JAVA   -DNO_X11 -DXP_PC -DHW_THREADS    -o ../unxlngi6.pro/obj/cppsetup.o cppsetup.c
In file included from cppsetup.c:29:
def.h:157: error: conflicting types for 'getline'
/usr/include/stdio.h:651: error: previous declaration of 'getline' was here
cppsetup.c: In function '_my_if_errors':
cppsetup.c:122: warning: unused parameter 'ip'
cppsetup.c:123: warning: unused parameter 'cp'
cppsetup.c:124: warning: unused parameter 'expecting'
cppsetup.c: In function '_lookup_variable':
cppsetup.c:159: warning: unused variable 'pd'
dmake:  Error code 1, while making '../unxlngi6.pro/obj/cppsetup.obj'

ERROR: Error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/soltools/mkdepend
rmdir /tmp/1101
make: *** [stamp/build] Error 1
 
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.13"

Building on a similarly configured system, which has not yet been upgraded from glibc-2.9, yesterday evening completed with no errors. So I am assuming that the failure is caused by a change introduced by glibc-2.10

 emerge --info
Portage 2.2_rc33 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.30-rc6-00043-g22ef37e i686)
=================================================================
System uname: Linux-2.6.30-rc6-00043-g22ef37e-i686-Intel-R-_Core-TM-2_Duo_CPU_E8200_@_2.66GHz-with-gentoo-2.0.0
Timestamp of tree: Mon, 18 May 2009 06:30:17 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -mtune=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -mtune=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="buildsyspkg distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://gentoo.tiscali.nl/ http://mirror.ovh.net/gentoo-distfiles/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_GB.UTF-8"
LC_ALL="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa apache2 bash-completion berkdb branding bzip2 cairo caps cdr cli cracklib crypt cups curl cvs cxx dbus doc dri dvd dvdr dvdread eds emacs emboss encode esd evo examples expat fam ffmpeg flac fortran gd gdbm gif gnome gnome-keyring gnutls gpm gstreamer gtk gtkhtml hal htmlhandbook iconv idn imagemagick imlib ipv6 isdnlog java jpeg kde kdehiddenvisibility ldap libnotify libsamplerate logrotate lzo mad midi mikmod mmap mmx mng mono mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png postgres ppds pppd pulseaudio python qt3 qt3support qt4 quicktime readline reflection samba sdl session speex spell spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs tcl tcpd theora threads tiff tk truetype unicode usb vim-syntax vorbis win32codecs x264 x86 xattr xcb xcomposite xml xorg xulrunner xv zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en" USERLAND="GNU" VIDEO_CARDS="vesa fbdev nv"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Sebastian Luther (few) 2009-05-18 10:04:33 UTC
*** Bug 270259 has been marked as a duplicate of this bug. ***
Comment 2 Serkan Kaba (RETIRED) gentoo-dev 2009-05-18 12:34:02 UTC
*** Bug 270273 has been marked as a duplicate of this bug. ***
Comment 3 Andreas Proschofsky (RETIRED) gentoo-dev 2009-05-18 12:38:02 UTC
Not so great, OOo 3.1 fresh in portage and already broken by a glibc update.

@toolchain-herd: Could you take a look / chime in here?
Comment 4 Hanno Zysik (geki) 2009-05-18 13:39:54 UTC
It looks like the new glibc defines the getline function now.
I looked at the OOo code of mkdepend, it dates 1994.

# grep -rn getline soltools/
soltools/mkdepend/parse.c:48:	while ((line = getline(filep))) {
soltools/mkdepend/parse.c:171:	while ((line = getline(filep))) {
soltools/mkdepend/def.h:157:char			*getline();
soltools/mkdepend/main.c:551:char *getline(filep)

I attach a patch to simply rename OOo's very own getline implementation.
Comment 5 Hanno Zysik (geki) 2009-05-18 13:40:22 UTC
Created attachment 191664 [details, diff]
rename getline to ooo_getline
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2009-05-18 18:57:12 UTC
*** Bug 270342 has been marked as a duplicate of this bug. ***
Comment 7 Oschtan 2009-05-18 19:19:28 UTC
(In reply to comment #6)
> *** Bug 270342 has been marked as a duplicate of this bug. ***
> 

No, this bug is not a duplicate of this bug.
This problem was observed under such conditions:
sys-libs/glibc-2.9_p20081201-r2 and sys-devel/gcc-4.3.3-r2 and
app-office/openoffice-3.1.0_beta7 
Comment 8 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-18 19:21:53 UTC
(In reply to comment #5)
> Created an attachment (id=191664) [edit]
> rename getline to ooo_getline
> 

Looks good. Fedora did the same thing:
http://cvs.fedoraproject.org/viewvc/devel/openoffice.org/openoffice.org-3.1.0.oooXXXXX.gcc44.buildfixes.patch?revision=1.3&view=markup&sortby=date
( the last hunks address this issue )
Comment 9 Constantin Baranov 2009-05-18 19:59:09 UTC
(In reply to comment #5)
> Created an attachment (id=191664) [edit]
> rename getline to ooo_getline
Thanks! With this patch, openoffice-3.1.0 successfully emerged on ~amd64 with
USE="cups dbus gstreamer gtk java nsplugin opengl pam" and MAKEOPTS="-j2"
Comment 10 Oschtan 2009-05-18 22:00:34 UTC
Using ooo_getline.diff
compile failed
Making: ../../../unxlngx6.pro/slb/edit.lib
echo unxlngx6.pro/slo/eddel.o unxlngx6.pro/slo/edlingu.o unxlngx6.pro/slo/edfldexp.o unxlngx6.pro/slo/edtab.o unxlngx6.pro/slo/acorrect.o unxlngx6.pro/slo/autofmt.o unxlngx6.pro/slo/edatmisc.o unxlngx6.pro/slo/edattr.o unxlngx6.pro/slo/edfcol.o unxlngx6.pro/slo/edfld.o unxlngx6.pro/slo/edfmt.o unxlngx6.pro/slo/edglbldc.o unxlngx6.pro/slo/edglss.o unxlngx6.pro/slo/editsh.o unxlngx6.pro/slo/ednumber.o unxlngx6.pro/slo/edredln.o unxlngx6.pro/slo/edtox.o unxlngx6.pro/slo/edundo.o unxlngx6.pro/slo/edws.o unxlngx6.pro/slo/edsect.o | xargs -n1 > ../../../unxlngx6.pro/slb/edit.lib
Running processes: 0

2 module(s):
        fpicker
        sw
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/sw/source/core/doc
ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/fpicker/source/unx/kde_unx

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from fpicker sw"

rmdir /tmp/8933
make: *** [stamp/build] Error 1
Comment 11 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-18 22:10:46 UTC
(In reply to comment #10)
> Using ooo_getline.diff
> compile failed
[...]
> make: *** [stamp/build] Error 1

As I said on bug 270342, please open a new bug for the issue you're experiencing. You will need to provide the full build log. In the new bug. Thank you.

Comment 12 Lars Wendler (Polynomial-C) gentoo-dev 2009-05-19 05:18:44 UTC
*** Bug 270366 has been marked as a duplicate of this bug. ***
Comment 13 Sebastian Luther (few) 2009-05-19 05:43:39 UTC
*** Bug 270375 has been marked as a duplicate of this bug. ***
Comment 14 Andreas Proschofsky (RETIRED) gentoo-dev 2009-05-19 11:28:54 UTC
Just fixed this in portage now, thanks especially to Hanno for providing the patch!
Comment 15 Sebastian Luther (few) 2009-05-19 20:03:39 UTC
*** Bug 270484 has been marked as a duplicate of this bug. ***
Comment 16 Sebastian Luther (few) 2009-05-19 20:14:02 UTC
Reopening to save us from a flood of duplicates. I'll close it tomorrow again. Sorry for the spam.
Comment 17 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-19 20:14:22 UTC
*** Bug 270489 has been marked as a duplicate of this bug. ***
Comment 18 Svenne Krap 2009-05-19 21:09:24 UTC
Mine still fails ....


1 module(s):
        vcl
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/vcl/util

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from vcl"
Comment 19 Oschtan 2009-05-20 05:32:03 UTC
Hm. In principle OOo-3.1.0 compile with sys-libs/glibc-2.10.1?
Comment 20 Svenne Krap 2009-05-20 06:37:19 UTC
Yes. OOo 3.1.0 with glibc 2.10.1 and gcc (Gentoo 4.3.3-r2 p1.1, pie-10.1.5) 4.3.3
Comment 21 Sebastian Luther (few) 2009-05-20 06:41:29 UTC
As I understand it, the bug should be fixed now (the commit was 19 hours ago). Run emerge --sync and try again. If it still fails, attach the build.log and provide "emerge -pvq openoffice".
Comment 22 Svenne Krap 2009-05-20 06:46:19 UTC
okay, willdo. But I cannot work on it before tomorrow.
Comment 23 Oschtan 2009-05-20 07:39:25 UTC
(In reply to comment #22)
> okay, willdo. But I cannot work on it before tomorrow.
> 

In portage fixed soltool but I post bug 270366 and other bugs not fixed. I used ooo_getline.diff in bug 270366 and problem with soltool fixed earlier
Comment 24 Svenne Krap 2009-05-20 20:14:49 UTC
still failing
Comment 25 Svenne Krap 2009-05-20 20:16:52 UTC
Created attachment 191939 [details]
Buildlog of failure svenneK
Comment 26 Svenne Krap 2009-05-20 20:17:43 UTC
[ebuild  N    ] app-office/openoffice-3.1.0  USE="bash-completion cups dbus gnome gstreamer gtk java kde nsplugin opengl pam -binfilter -debug -eds -ldap -mono -odk -templates" LINGUAS="en -af -ar -as_IN -be_BY -bg -bn -br -brx -bs -ca -cs -cy -da -de -dgo -dz -el -en_GB -en_US -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gl -gu -he -hi_IN -hr -hu -id -it -ja -ka -kk -km -kn_IN -ko -kok -ks -ku -lt -mai -mk -ml_IN -mn -mni -mr_IN -nb -ne -nl -nn -nr -ns -oc -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sa_IN -sat -sd -sh -sk -sl -sr -ss -st -sw_TZ -ta -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -uz -ve -vi -xh -zh_CN -zh_TW -zu"
Comment 27 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-20 20:28:37 UTC
(In reply to comment #25)
> Created an attachment (id=191939) [edit]
> Buildlog of failure svenneK
> 

Wrong file.
Comment 28 Svenne Krap 2009-05-20 20:31:52 UTC
which file do you need?
Comment 29 Svenne Krap 2009-05-20 21:37:18 UTC
Created attachment 191946 [details]
the right file, hopefully
Comment 30 egon2003 2009-05-21 10:19:04 UTC
my build stops here:

Module 'scp2' delivered successfully. 88 files copied, 4 files unchanged                                                                          

1 module(s): 
        vcl  
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/vcl/util
Comment 31 egon2003 2009-05-21 10:26:27 UTC
Created attachment 192021 [details]
build.log

Compressed, over 1000Kb unpacked
Comment 32 egon2003 2009-05-21 10:28:28 UTC
emerge -pvq openoffice:

[ebuild     U ] app-office/openoffice-3.1.0 [3.0.1] USE="cups dbus gtk java kde nsplugin opengl pam -bash-completion% -binfilter -debug -eds -gnome -gstreamer -ldap -mono -odk -templates" LINGUAS="-af -ar -as_IN -be_BY -bg -bn -br -brx% -bs -ca -cs -cy -da -de -dgo% -dz -el -en -en_GB -en_US -en_ZA -eo -es -et -eu% -fa -fi -fr -ga -gl -gu -he -hi_IN -hr -hu -id% -it -ja -ka -kk -km -kn_IN% -ko -kok% -ks% -ku -lt -mai% -mk -ml_IN -mn -mni% -mr_IN -nb -ne -nl -nn -nr -ns -oc% -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sa_IN% -sat% -sd% -sh -sk -sl -sr -ss -st -sw_TZ -ta -ta_IN% -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -uz% -ve -vi -xh -zh_CN -zh_TW -zu (-lv%) (-sv%*)"
Comment 33 keenblade 2009-05-21 20:46:27 UTC
(In reply to comment #30)
> my build stops here:
> 
> Module 'scp2' delivered successfully. 88 files copied, 4 files unchanged        
> 
> 1 module(s): 
>         vcl  
> need(s) to be rebuilt
> 
> Reason(s):
> 
> ERROR: error 65280 occurred while making
> /var/tmp/portage/app-office/openoffice-3.1.0/work/ooo/build/ooo310-m11/vcl/util
> 
Exactly same here. But openoffice-3.1.0 compiles fine without kde useflag. Kde4 installed without kdeprefix useflag. Up to date ~x86_64 arch here.
Comment 34 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-21 20:56:59 UTC
Another bug, then. This bug is FIXED.
Comment 35 Svenne Krap 2009-05-22 07:20:22 UTC
Mine does NOT compile without kde
I also tried USE=-* emerge openoffice which failed too...
Comment 36 keenblade 2009-05-22 13:35:53 UTC
(In reply to comment #35)
> Mine does NOT compile without kde
> I also tried USE=-* emerge openoffice which failed too...
> 

I see. My bug is different. I found my bug belongs to bug #238539. So I atached my log there.
Comment 37 Sylvain Raybaud 2009-07-30 10:50:56 UTC
(In reply to comment #14)
> Just fixed this in portage now, thanks especially to Hanno for providing the
> patch!
> 

Hello

  Looks like the problem is not fixed for openoffice-3.0.0
I'm attaching build.log (sraybaud.build.log.gz) and emerge info (sraybaud.emerge.info).

markov sylvain # emerge -pvq app-office/openoffice
[ebuild   R   ] app-office/openoffice-3.0.0  USE="cups kde pam -binfilter -dbus -debug -eds -gnome -gstreamer -gtk -java -ldap -mono -nsplugin -odk -opengl -templates" LINGUAS="en en_GB fr -af -ar -as_IN -be_BY -bg -bn -br -bs -ca -cs -cy -da -de -dz -el -en_US -en_ZA -eo -es -et -fa -fi -ga -gl -gu_IN -he -hi_IN -hr -hu -it -ja -km -ko -ku -lt -lv -mk -ml_IN -mr_IN -nb -ne -nl -nn -nr -ns -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sh -sk -sl -sr -ss -st -sv -sw_TZ -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -ve -vi -xh -zh_CN -zh_TW -zu"

regards,

Sylvain
Comment 38 Sylvain Raybaud 2009-07-30 10:53:03 UTC
Created attachment 199633 [details]
(sraybaud) ooo build log
Comment 39 Sylvain Raybaud 2009-07-30 10:54:06 UTC
Created attachment 199637 [details]
(sraybaud) emerge --info
Comment 40 Andreas Proschofsky (RETIRED) gentoo-dev 2009-07-30 11:17:10 UTC
(In reply to comment #37)
> 
>   Looks like the problem is not fixed for openoffice-3.0.0
> I'm attaching build.log (sraybaud.build.log.gz) and emerge info
> (sraybaud.emerge.info).

Why would you use OOo 3.0 with glibc 2.10.1?
Comment 41 Lesseps 2009-09-10 00:59:31 UTC
Thanks. 

In may case, LFS (Linux From Scratch) running in a VMWare Player machine, hosted by Ubuntu Jaunty, trying to compile/install OOo_3.1.1.

I do not know how to use diff, but edited the referred files, and made the changes by hand.

The error disappeared. Do not know if dmake will run to the end.