Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270043 - x11-libs/gtk+-2.14.7-r2 ./configure fails
Summary: x11-libs/gtk+-2.14.7-r2 ./configure fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2009-05-16 10:59 UTC by Jaak Ristioja
Modified: 2009-05-27 19:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,14.27 KB, text/plain)
2009-05-16 10:59 UTC, Jaak Ristioja
config.log (config.log,96.20 KB, text/plain)
2009-05-16 11:03 UTC, Jaak Ristioja

Note You need to log in before you can comment on or make changes to this bug.
Description Jaak Ristioja 2009-05-16 10:59:19 UTC
checking Pango flags... -D_REENTRANT -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12   -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0           
configure: error:                                                                                                                                                
*** Can't link to Pango. Pango is required to build                                                                                                              
*** GTK+. For more information see
Comment 1 Jaak Ristioja 2009-05-16 10:59:48 UTC
Created attachment 191462 [details]
Comment 2 Jaak Ristioja 2009-05-16 11:03:33 UTC
Created attachment 191464 [details]

Oh yeah - and I forgot:

[ebuild   R   ] x11-libs/pango-1.22.4  USE="X doc -debug" 0 kB
[ebuild   R   ] x11-libs/gtk+-2.14.7-r2  USE="X cups jpeg jpeg2k tiff xinerama -debug -doc -vim-syntax" 0 kB

Portage (default/linux/amd64/2008.0/developer, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r4-arm x86_64)
System uname: Linux-2.6.29-gentoo-r4-arm-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8700_@_2.53GHz-with-glibc2.2.5
Timestamp of tree: Fri, 15 May 2009 20:00:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.4
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.29
CFLAGS="-march=core2 -O2 -pipe -fopenmp -ggdb"
CXXFLAGS="-march=core2 -O2 -pipe -fopenmp -ggdb"
FEATURES="collision-protect cvs distlocks fixpackages installsources multilib-strict parallel-fetch protect-owned sandbox sfperms sign splitdebug strict unmerge-orphans userfetch userpriv usersandbox usersync"
LINGUAS="en et de"
USE="X acl acpi alsa amd64 apache2 aspell berkdb bindist bzip2 cairo caps cdr cli consolekit cracklib crypt cups dbus directfb djvu doc dri dvd dvdr dvdread eds emboss encode esd evo exif faac faad fam fbcon firefox flac fortran gdbm gif git glitz gmp gnokii gnutls gpm gstreamer gtk hal hdri htmlhandbook iconv icu idn ipv6 isdnlog jbig jpeg jpeg2k kde kdeprefix kontact kpathsea latex lcms libnotify lua lzma lzo mad mailwrapper md5sum midi mikmod mmx mng mp3 mp4 mpeg mudflap multilib mysql ncurses nptl nptlonly ogg opengl openmp pam pcre pdf perl phonon php pic plasma png postgres ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl semantic-desktop session snmp source spell spl sqlite sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcpd threads tiff truetype ucs2 unicode usb vorbis webkit xcb xcomposite xetex xinerama xml xorg xprint xscreensaver xulrunner xv zlib" ELIBC="glibc" KERNEL="linux" LINGUAS="en et de" USERLAND="GNU" VIDEO_CARDS="fbdev intel vesa i810"
Comment 3 Sebastian Luther (few) 2009-05-16 11:13:38 UTC
Please try revdep-rebuild. If it does not fix it, try emerge -1 x11-libs/libdrm. If it is still not fixed reopen this bug.
Comment 4 Jaak Ristioja 2009-05-16 11:17:33 UTC
(In reply to comment #3)
> Please try revdep-rebuild. If it does not fix it, try emerge -1
> x11-libs/libdrm. If it is still not fixed reopen this bug.

Already tried that. Twice.

[ebuild   R   ] x11-libs/libdrm-2.4.9  USE="-debug" 0 kB
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-16 11:22:20 UTC
What's the output of:
ldd -r /usr/lib/

For reference, this is my output:
loki ~ # ldd -r /usr/lib/ =>  (0x00007fff18bfd000) => /lib/ (0x00007fd010644000) => /lib/ (0x00007fd0102f5000) => /lib/ (0x00007fd0100d9000)
	/lib64/ (0x00007fd010a84000)
Comment 6 Jaak Ristioja 2009-05-16 11:25:51 UTC
"/usr/lib/ undefined reference to `clock_gettime'" is the same reason media-sound/exaile stopped working today, after I did the following upgrades:

media-libs/mesa               7.4      -> 7.4.1-r2
x11-drivers/xf86-video-intel  2.6.3-r1 -> 2.7.1
x11-libs/libdrm               2.4.6    -> 2.4.9

# ldd -r /usr/lib/ =>  (0x00007fffad9ff000) => /lib/ (0x00007f8aa540e000)
        /lib64/ (0x00007f8aa598c000)
undefined symbol: clock_gettime (/usr/lib/
Comment 7 Peter Alfredsen (RETIRED) gentoo-dev 2009-05-16 12:09:18 UTC
This is the code from of libdrm that ensures that this should work:

dnl We use clock_gettime to check for timeouts in drmWaitVBlank

AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
               [AC_CHECK_LIB([rt], [clock_gettime], [CLOCK_LIB=-lrt],
                             [AC_MSG_ERROR([Couldn't find clock_gettime])])])

I suspect that, in other words, that your failure to properly link against librt is caused by -fopenmp in CFLAGS. Since fopenmp will implicitly include both -lpthread and -lrt, will feel it unnecessary to properly link the library, which means that if you want a working system, you should not be using -fopenmp indiscriminately.
Comment 8 Jaak Ristioja 2009-05-16 12:23:01 UTC
You're probably right and that worked, thanks.
Comment 9 Pablo Hess 2009-05-27 19:05:00 UTC
> I suspect that, in other words, that your failure to properly link against
> librt is caused by -fopenmp in CFLAGS.

Peter, I have to thank you very much for pointing this out. I've been struggling with build failures like this for a long time, and now I can finally get back to building my packages.