Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270019 - x-11-libs/libXt-1.0.5 needs aclocal-1.9 (automake-1.9-r6) but isnt being pulled in as a dep
Summary: x-11-libs/libXt-1.0.5 needs aclocal-1.9 (automake-1.9-r6) but isnt being pull...
Status: RESOLVED DUPLICATE of bug 270010
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://forums.gentoo.org/viewtopic-p-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-16 05:38 UTC by Nicolas
Modified: 2009-05-16 07:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas 2009-05-16 05:38:04 UTC
First time filing,  hope this is correct :)

As per the URL above (http://forums.gentoo.org/viewtopic-p-5729258.html#5729258) I started running into this issue three days ago where libXt would fail to compile because "Failed Running aclocal !"  Took some digging around to find out that aclocal is part of the automake ebuild.  The only version of automake installed (from the 20090422 Gentoo not-so-weekly autobuild) was 1.10.2

x11-libs/libXt-1.0.5 requires aclocal version 1.9, but automake-1.9-r6 wasnt being pulled in as a dependancy.

Reproducible: Always

Steps to Reproduce:
1. untar a new stage3 (or system without automake-1.9
2. emerge libXt (fails)
3. emerge =sys-devel/automake-1.9-r6 and then emerge libXt (works)
Comment 1 Nicolas 2009-05-16 05:40:29 UTC
Oops, the correct version of automake is 1.9.6-r2 and NOT 1.9-r6
Comment 2 Sebastian Luther (few) 2009-05-16 07:18:22 UTC

*** This bug has been marked as a duplicate of bug 270010 ***