Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270012 - No sound from headphones. Kernel module error message: hda_codec: Unknown model for ALC861, trying auto-probe from BIOS...
Summary: No sound from headphones. Kernel module error message: hda_codec: Unknown mod...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2009-05-16 00:10 UTC by Peter Basista
Modified: 2009-05-19 10:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

lspci -vvvnn (lspcivvvnn,25.36 KB, text/plain)
2009-05-16 00:14 UTC, Peter Basista
aplay -L (aplayl,833 bytes, text/plain)
2009-05-16 00:15 UTC, Peter Basista
The alsamixer as shown when having model=asus (alsamixer.png,28.52 KB, image/png)
2009-05-16 00:19 UTC, Peter Basista

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Basista 2009-05-16 00:10:49 UTC
I am using ASUS A6Tc laptop with linux kernel form Platform is amd64, own config. Briefly: ALSA enabled, OSS disabled. The error message:
hda_codec: Unknown model for ALC861, trying auto-probe from BIOS...
is displayed in /var/log/messages for every boot.

Reproducible: Always

Steps to Reproduce:
0. A must is a sound card with codec Realtek ALC660. And maybe the problem only exists on ASUS laptops...
1. Compile and install the newest kernel from
2. Make sure ALSA is enabled and that Intel High Definition Audio with Realtek codec are selected to be compiled as a module
3. Try to modprobe snd_hda_intel and see the error message

Actual Results:  
In my case, this results in poor sound quality. When using other (mainly asus-specific) options for modprobe, then headphones are not working.

Expected Results:  
I would expect to have a headphone switch working in alsamixer, as well as some controls to control volume (like master). And of course, the sound quality should be at least as good as it is in Windows with Realtek High Definition Audio driver.

Here is what I tried, in more detail:
Added the following line to /etc/modprobe.d/alsa:
options snd-hda-intel model=asus

Not helped. Looked up another options in Documentation/sound/alsa/HD-Audio-Models.txt file from the documentation of linux kernel:

  3stack        3-jack
  3stack-dig    3-jack with SPDIF I/O
  6stack-dig    6-jack with SPDIF I/O
  3stack-660    3-jack (for ALC660)
  uniwill-m31   Uniwill M31 laptop
  toshiba       Toshiba laptop support
  asus          Asus laptop support
  asus-laptop   ASUS F2/F3 laptops
  auto          auto-config reading BIOS (default)

and tried basically those: asus, asus-laptop, 3stack, 3stack-dig and 3stack-660. None of those worked correctly.

With some of these options, I was able to have a headphone switch in alsamixer. But this switch did not do anyting. Whether it was on or off, I was only able to hear sound from built-in speakers and only when the headphones were not plugged in. The headphones remained silent all the time.

With model=auto option, however, the headphones works, but the sound (overall, not in headphones) is a little bit of poor quality. I can hear too much noise at higher volume levels. It is not that bad, but compared to sound I get in Windows, it is a noticeable difference.

The problem is that when using model=auto option, there is a line-in volume control in alsamixer. And I cannot mute it, because it causes all the sound to be muted. When I have it unmuted, but at minimum volume, I can hear the sound clearly, but it is very quiet. When I rise the line-in volume to about 40%, then the overall sound volume is acceptable, but there comes the noise. At higher levels of line-in volume, I am not able to hear anything (at all, not just from headphones) again. This happens at about over 50%. Also, there is a loud crack in the speakers, but also in the headphones, when I cross the 50% volume level for line-in. It is strange.

First, what can have the line-in volume possibly to do with sound output? And why it is affecting overall volume?
And second, there is no master volume control, only PCM (I don't know why, but it is not adjustable with some of the options to modprobe).

It is at least confusing...

I will attach some lspci, aplay and similar outputs...

I would appreciate any insights in what could be causing this and more importantly, how to make this working.

Thank you.
Comment 1 Peter Basista 2009-05-16 00:14:13 UTC
Created attachment 191435 [details]
lspci -vvvnn

I am sorry if it is too verbose, I did not know which verbose level suffices...
Comment 2 Peter Basista 2009-05-16 00:15:02 UTC
Created attachment 191436 [details]
aplay -L
Comment 3 Peter Basista 2009-05-16 00:19:59 UTC
Created attachment 191437 [details]
The alsamixer as shown when having model=asus
Comment 4 Peter Basista 2009-05-16 00:24:13 UTC
Comment on attachment 191437 [details]
The alsamixer as shown when having model=asus

Notice that the headphone switch is present here, but it does not work.
Comment 5 Peter Basista 2009-05-16 00:30:00 UTC
Portage (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, x86_64)
System uname: Linux-
Timestamp of tree: Fri, 15 May 2009 14:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=k8 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en sk cs"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X acl alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvdr fortran gdbm gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg libnotify midi mmx mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode v4l2 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard evdev synaptics mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en sk cs" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 6 Peter Basista 2009-05-16 00:50:24 UTC
Just tried the model=3stack module option and the results are the same as with model=auto.

It seems that the automatic selection selects this option. But despite there is a sound from the headphones (and headphone switch works) with this option, it is of unacceptably poor quality when increasing the "Line" volume in alsamixer. At 0%, the quality seems clear, but alsamixer says it is -36dB, so it is really quiet. Increasing it towards zero gain produces a poor quality. Above zero, there is no sound or just a very quiet, almost unheard mumbling. Also note that with this option, I don't even have a PCM volume in alsamixer on its first run. I don't know why, but I had to run alsamixer the second time and just then, the PCM volume control was present.

So, more or less, nothing changed.
Comment 7 Peter Basista 2009-05-16 19:30:51 UTC
I think that this might be a bug in ALSA drivers, so I have just submitted it to ALSA bugtracking system as a bug with ID = 0004525.

You can follow it here:

I also suggest moving the bug to the UPSTREAM.
Comment 8 Peter Basista 2009-05-19 10:32:43 UTC
Moved to upstream.