Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269931 - xkbcomp error: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
Summary: xkbcomp error: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-15 11:27 UTC by Christian Weiske
Modified: 2012-12-12 12:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emergeinfo,4.27 KB, text/plain)
2009-05-15 15:16 UTC, Christian Weiske
Details
Xorg.0.log (Xorg.0.log,112.16 KB, text/plain)
2009-05-15 15:18 UTC, Christian Weiske
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Weiske 2009-05-15 11:27:42 UTC
Everytime I run X manually, I get the following error message:
----
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
----

Since this is really annoying to me, I tracked it down to:

/usr/share/X11/xkb/symbols/level3:
----
// the default behavior is for the right Alt key (AltGr) to generate the
// third engraved symbol
default partial modifier_keys
xkb_symbols "ralt_switch" {
  key <RALT> {
    type[Group1]="ONE_LEVEL",
    symbols[Group1] = [ ISO_Level3_Shift ]
    };
  modifier_map Mod5   { ISO_Level3_Shift };
};
----

and /usr/share/X11/xkb/symbols/altwin:
---
partial modifier_keys 
xkb_symbols "meta_alt" {
    key <LALT> {        [       Alt_L,  Meta_L          ]       };
    key <RALT> {        [       Alt_R,  Meta_R          ]       };
    modifier_map Mod1   { Alt_L, Alt_R, Meta_L, Meta_R };
};
----

Here you see that two symbols are assigned to RALT, which is defined as ONE_LEVEL. Commenting out the RALT line in /usr/share/X11/xkb/symbols/altwin helps, as well as changing ONE_LEVEL to TWO_LEVEL in /usr/share/X11/xkb/symbols/level3.

I don't know which one is the correct way. I only know that hundreds of people have the same warnings (search the web for the message). It would be great if that issue could be fixed, perhaps even upstream.


Related:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=291853

Reproducible: Always

Steps to Reproduce:
1. start X as root on the shell
2. watch the output

Actual Results:  
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

Expected Results:  
No warning/error

I use  x11-apps/xkbcomp 1.0.5 and x11-apps/setxkbmap 1.0.4 (dunno if that helps). xorg-server 1.5.3-r5, x11-libs/libxkbfile 1.0.5

My xorg.conf lists no keyboard configuration, but
/etc/hal/fdi/policy/10-keymap.fdi contains:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.model" type="string">macintosh</merge>
    </match>
  </device>
</deviceinfo>
Comment 1 Sebastian Luther (few) 2009-05-15 14:16:08 UTC
Please attach emerge --info and Xorg.0.log.
Comment 2 Christian Weiske 2009-05-15 15:16:24 UTC
Created attachment 191391 [details]
emerge --info
Comment 3 Christian Weiske 2009-05-15 15:18:20 UTC
Created attachment 191392 [details]
Xorg.0.log

Attached Xorg.0.log. You will not see anything there since the error message does not get logged - only visible during startup of X on the shell.
Comment 4 Rémi Cardona gentoo-dev 2009-05-15 17:37:21 UTC
I am completely clueless wrt XKB, and most of the other devs here are too.

Please file a bug in FreeDesktop's bugzilla and paste the url here so upstream can comment on this bug that I've indeed seen a few times before.

Thanks
Comment 5 Christian Weiske 2009-05-16 07:48:45 UTC
Upstream URL: https://bugs.freedesktop.org/show_bug.cgi?id=21761
Comment 6 Rémi Cardona gentoo-dev 2009-05-16 07:56:02 UTC
Alright, let's track the bug upstream then.

Thanks
Comment 7 Achim Derigs 2012-12-12 12:52:06 UTC
Just seen this message in my log. On upstream the fix seems to be lost somehow:

   https://bugs.freedesktop.org/show_bug.cgi?id=21761#c5