Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 2699 - rpm-4.0.4-r1.ebuild fails, problem with popt.h
Summary: rpm-4.0.4-r1.ebuild fails, problem with popt.h
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Dan Armak (RETIRED)
Depends on:
Reported: 2002-05-13 11:04 UTC by Sandy McArthur
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sandy McArthur 2002-05-13 11:04:28 UTC
The rpm-4.0.4-r1.ebuild files duing the compile with the following error message:

make[2]: *** No rule to make target `../popt/popt.h', needed by `files.lo'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/rpm-4.0.4-r1/work/rpm-4.0.4/build'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/rpm-4.0.4-r1/work/rpm-4.0.4'
make: *** [all-recursive-am] Errot 2
Comment 1 Dan Armak (RETIRED) gentoo-dev 2002-05-13 12:10:36 UTC
Updated the patch to use /usr/include/popt.h. Please try now.  PS: I hope having /usr/include/popt.h as a dep in the makefile won't make it do anything nasty, since it doesn't have any actual rule about it. Anyway, if it tried the sandbox would stop it. 
Comment 2 Sandy McArthur 2002-05-13 12:52:55 UTC
merge worked. closing.