Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269765 - net-libs/webkit-gtk-1.1.10: fails to compile with --disable-dependency-tracking
Summary: net-libs/webkit-gtk-1.1.10: fails to compile with --disable-dependency-tracking
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 211529
  Show dependency tree
 
Reported: 2009-05-13 23:49 UTC by Jonathan Callen (RETIRED)
Modified: 2009-10-31 22:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (net-libs:webkit-gtk-0_p40220:20090513-233441.log,12.90 KB, text/plain)
2009-05-13 23:49 UTC, Jonathan Callen (RETIRED)
Details
emerge --info (emerge.info,4.51 KB, text/plain)
2009-05-14 12:41 UTC, Jonathan Callen (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Callen (RETIRED) gentoo-dev 2009-05-13 23:49:01 UTC
When building net-libs/webkit-gtk-0_p40220, I've found that the build fails immediately upon calling emake, as the makefile never creates the "DerivedSources" directory, which is needed for the first file to be built to be placed in.  An easy fix for this is to call "mkdir DerivedSources" immediately before emake in the ebuild, which allows the build to proceed.  My build logs are attached.
Comment 1 Jonathan Callen (RETIRED) gentoo-dev 2009-05-13 23:49:56 UTC
Created attachment 191215 [details]
build log
Comment 2 Jonathan Callen (RETIRED) gentoo-dev 2009-05-13 23:51:46 UTC
Note that while the build log shows MAKEOPTS=-j5, the build fails with -j1 as well.
Comment 3 Sebastian Luther (few) 2009-05-14 12:36:25 UTC
emerge --info please.
Comment 4 Jonathan Callen (RETIRED) gentoo-dev 2009-05-14 12:41:25 UTC
Created attachment 191255 [details]
emerge --info
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-23 20:00:17 UTC
Still an issue with 1.1.7?
Comment 6 Jonathan Callen (RETIRED) gentoo-dev 2009-05-26 23:19:07 UTC
(In reply to comment #5)
> Still an issue with 1.1.7?

Yes, and the same fix (`mkdir DerivedSources` at the end of src_configure) still works.
Comment 7 Jonathan Callen (RETIRED) gentoo-dev 2009-06-21 23:14:27 UTC
This is still an issue with the latest 1.1.10
Comment 8 Peter Volkov (RETIRED) gentoo-dev 2009-08-28 13:47:53 UTC
Jonathan, I've just struggled from the same problem and found the root cause on my system: it's --disable-dependency-tracking enabled system wide. DerivedSources directory is created during dependency checking at ./config.status. I don't see any hints in your build output that you've disabled dependency tracking but may be this idea gives you clues...
Comment 9 Jonathan Callen (RETIRED) gentoo-dev 2009-08-28 17:28:08 UTC
I had forgotten that I had the line "enable_dependency_tracking=${enable_dependency_tracking-no}" in my /usr/share/config.site, which is equivalent to passing --disable-dependency-tracking everywhere.  So, yes, that does appear to be the cause on my system as well.
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-10-31 22:09:02 UTC
closing invalid then, thanks for reporting.